Author Topic: Reaver fails (wash fails)  (Read 40737 times)

skank

  • Newbie
  • *
  • Posts: 8
    • View Profile
on: February 22, 2012, 04:32:35 PM
installed reaver, running sudo airmon-ng start wlan0 it starts up in monitor mode. Running wash -i mon0 and i get the error


Wash v1.4 WiFi Protected Setup Scan Tool
Copyright (c) 2011, Tactical Network Solutions, Craig Heffner <cheffner@tacnetsol.com>

[X] ERROR: Failed to open 'mon0' for capturing
kusse@luder-lars:~$


airodump-ng mon0 works fine



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #1 on: February 22, 2012, 04:47:42 PM
As i can see you use sudo, then use sudo for all commands, if not, open terminal type sudo -i and pass. After this you need to run : reaver -i mon0 -b BSSID -vv.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


skank

  • Newbie
  • *
  • Posts: 8
    • View Profile
Reply #2 on: February 22, 2012, 05:04:36 PM
I know how to use reaver, the problem is with "wash" the app for finding WPS enabled routers

Running sudo wash -i mon0 or just wash -i mon0 gives me the same error.



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #3 on: February 22, 2012, 05:15:26 PM
I saw that you asked reaver dev team as well. Show error log when you run tool, and we will see.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


skank

  • Newbie
  • *
  • Posts: 8
    • View Profile
Reply #4 on: February 22, 2012, 05:41:13 PM
yup asked there aswell, some days ago. But never received any reply, so went here instead :)

Can you tell me in what file i find the logs you want to see. Because i can't seem to be able to locate any logs anywhere regarding reaver or wash :)



skank

  • Newbie
  • *
  • Posts: 8
    • View Profile
Reply #5 on: February 22, 2012, 05:59:25 PM
The only thing i seem to be able to find is
Code: [Select]
Feb 22 13:46:26 luder-lars kernel: [ 3044.241426] wash uses obsolete (PF_INET,SOCK_PACKET)



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #6 on: February 22, 2012, 09:36:04 PM
Only issue i have found with this error, it's was kernel problem. If you run, last kernel, maybe this is problem, or if you don't have last kernel, that can be problem as well. It's about you to try this time if this make wash problems out of box.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


skank

  • Newbie
  • *
  • Posts: 8
    • View Profile
Reply #7 on: February 22, 2012, 11:36:54 PM
I fixed it somehow. I went to network manager and removed the "bock" infront of "activate wireless" so its deactivated, and then it worked perfect.



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #8 on: February 22, 2012, 11:47:05 PM
Take screenshot and post it pls, i need to see how you got this. And thank you for share.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


skank

  • Newbie
  • *
  • Posts: 8
    • View Profile
Reply #9 on: February 23, 2012, 12:06:47 AM
I'll take a screenshot later when my wife is done with charging the ps3 remote, she took the cable from my alfa awus36 card. The button isent there when its not plugged in



skank

  • Newbie
  • *
  • Posts: 8
    • View Profile
Reply #10 on: February 23, 2012, 01:17:54 AM
here ya go, my backbox is in Danish

« Last Edit: February 23, 2012, 01:21:01 AM by skank »



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #11 on: February 23, 2012, 01:38:42 AM
Ok, thanks. I asked for this photo, because word you have used : "bock". For me it's check or uncheck, like do or undo.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


InstantNoodles

  • Newbie
  • *
  • Posts: 7
    • View Profile
Reply #12 on: October 30, 2012, 12:46:30 PM
Hey there. Long time user, first time caller :)

Did this ever get resolved? Currently, when I switch my adapter to monitor and attempt to run wash or reaver as root, I get no results. I had attempted to "disable" wireless  (This is what skank had recommended, however it disables the adapter itself and renders it unusable) but I had no successful result.

I am switching to backbox from backtrack for a few reasons. Cleaner interface, larger community, but the main reason being, backtrack uses a dated kernal which is not supported by the new USB 3.0.



InstantNoodles

  • Newbie
  • *
  • Posts: 7
    • View Profile
Reply #13 on: October 31, 2012, 04:35:01 AM
I found this on Google code and the following solved my problem. The problem is it was simply a missing directory which wash was attempting to use that needs to be created

I created the directory  /etc/reaver   

Wash and reaver both work. Hope this helps.



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #14 on: October 31, 2012, 04:59:46 AM
Thank you,

Can you provide me some proof ...PM if you want. Like that we can be sure and we will update reaver package.

EDIT : No need, i see now that reaver need /etc/reaver to stock database file.



Cheers !
« Last Edit: October 31, 2012, 06:51:14 AM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*