Author Topic: [SOLVED] Metasploit error (Gems error)  (Read 3508 times)

nephop

  • Newbie
  • *
  • Posts: 18
    • View Profile
on: April 13, 2015, 07:12:45 PM
Using recog 1.0.16

Gem::InstallError: metasploit_data_models requires Ruby version >= 2.1.
An error occurred while installing metasploit_data_models (0.23.1), and Bundler
cannot continue.
Make sure that `gem install metasploit_data_models -v '0.23.1'` succeeds before
bundling.
dpkg: error processing package metasploit-framework (--configure):
 subprocess installed post-installation script returned error exit status 5
dpkg: dependency problems prevent configuration of armitage:
 armitage depends on metasploit-framework; however:
  Package metasploit-framework is not configured yet.

dpkg: error processing package armitage (--configure):
 dependency problems - leaving unconfigured
Setting up libxrender1:amd64 (1:0.9.8-1build0.14.04.1) ...
No apport report written because the error message indicates its a followup error from a previous failure.
                          Processing triggers for libc-bin (2.19-0ubuntu6.6) ...
Errors were encountered while processing:


(I am facing this error since I reinstall backbox can someone help me )
« Last Edit: April 24, 2015, 01:41:33 PM by raffaele »



ZEROF

  • Hero Member
  • *****
  • Posts: 1244
    • View Profile
    • Pen Tester
Reply #1 on: April 13, 2015, 07:17:23 PM
Hi,

You error message give you kind of solution:

gem install metasploit_data_models -v '0.23.1'


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


nephop

  • Newbie
  • *
  • Posts: 18
    • View Profile
Reply #2 on: April 14, 2015, 04:16:11 AM
Thanks for the reply.

When i try to install that command I get error message.

ERROR:  Error installing metasploit_data_models:
   metasploit_data_models requires Ruby version >= 2.1.

I have been to some forum and blog but still unsuccessful. :(



ZEROF

  • Hero Member
  • *****
  • Posts: 1244
    • View Profile
    • Pen Tester
Reply #3 on: April 14, 2015, 07:59:39 PM
Ok,

Can you share what you did trying to fix your issue (?), because on my side, i don't have that problem. First i did check my gem version gem -v,  (2.2.2) then i put all up to date. And i can't get that error again.

Some basic stuff i did to try make msf crash :) :

sudo -i
apt update
apt upgrade
apt-get dist-upgrade
msfupdate

Next to do is gems updating, but skip this step, will take awhile and i don't know how other tools will act after that, run msfconsole before.

gem update

Try:

msfconsole

If you have problems even after this, update gems (on your own risk). I did even step with gems updates on my side, and again i get what i want:



All goes well.
« Last Edit: April 14, 2015, 08:34:23 PM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


nephop

  • Newbie
  • *
  • Posts: 18
    • View Profile
Reply #4 on: April 15, 2015, 04:37:38 AM
Thanks for reply I am gonna reinstall backbox if i got error again will let you know thx :) !!



nephop

  • Newbie
  • *
  • Posts: 18
    • View Profile
Reply #5 on: April 16, 2015, 03:34:51 AM
Seems like this problem is exist in backbox 4.0 today I get updated in 4.1 and everything is working fine...
hope someone will solve in 4.0 thax for help.



ZEROF

  • Hero Member
  • *****
  • Posts: 1244
    • View Profile
    • Pen Tester
Reply #6 on: April 16, 2015, 08:23:44 AM
Man, it's normal that you have issue with old version. Because of that we make system updates. But I guess, you know now. And you never said that you are using 4.0. We don't provide support for older system version, because we made few GB of updates from version to version.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*