Author Topic: [SOLVED] Issue with Armitage in Backbox 4.0  (Read 4824 times)

majestyk

  • Newbie
  • *
  • Posts: 2
    • View Profile
on: November 24, 2014, 09:06:55 PM
Good evening. First time poster here.

First of all I want to say great work with Backbox. It is an amazing distro and I find it very easy to use! And looks-wise it is not bad either :-)

My issue is with the new version of Backbox. It is installed as the main OS on two different laptops. When I am trying to start Armitage I get the error message listed below. I have not had any issues with the previous version and as this was installed on two different laptops with the same error I was wondering if Armitage is a lot more resource hungry in the later version? The laptops are not new, have 2GB vs 4GB of memory.
Reason I bring this up is that the link in the error message mentions that memory may be an issue.

Error Below:


Metasploits RPC daemon shut down. This is the service Armitage uses to talk to Metasploit.

When this happens, it means something is wrong. The developer of Armitage feels your pain from afar.
Would you like help troubleshooting this?

PS, yes you would--the answer is known and its easy to deal with. Click Yes to visit
the troubleshooting guide at:

http://www.fastandeasyhacking.com/nomsfrpcd
« Last Edit: January 31, 2015, 08:29:16 AM by ZEROF »



b4d_bl0ck

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
Reply #1 on: November 24, 2014, 11:12:50 PM
Well, i cannot reproduce... My installation is working, i have the dialog informing me about msfrpcd being shut down, and it asks me if i want it to start on my behalf. Then i click yes and everything goes as it needs to. I don't know if it's a memory issue, since i'm running it fine on my virtual machine with 1Gb RAM, so even less powerful than your physical installations.
You can try starting armitage from the terminal and looking at the messages it outputs.
Also, did you try to follow the suggestion at the url you got?

Let us know!
Oh, and welcome anyways ;)

bool secure = check_paranoia() ? true : false;


ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #2 on: November 25, 2014, 01:45:12 PM
Same here, i don't have this problem. You need to let RPC daemon to start when you open Armitage, that is all what i can san you. Reinstall is 2nd option, but not the best because you will remove other apps as well but you can reinstall them with running sudo apt-get backbox-tools.
« Last Edit: November 25, 2014, 01:53:02 PM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


ostendali

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 587
    • View Profile
Reply #3 on: December 01, 2014, 12:32:58 PM
I can't reproduce either, it is working for me perfectly.

Pls do as ZEROF suggested, try to run armitage in console and you will see a huge output which can help us out to understand your problem.