Author Topic: Errore sqlmap [SOLVED]  (Read 3365 times)

Mito125

  • Newbie
  • *
  • Posts: 33
    • View Profile
on: June 21, 2011, 01:45:49 PM
Non so se a voi succede, ma quando lancio sqlmap da riga di comando, che cmq è riconosciuto come comando, mi dà questo errore:

Code: [Select]
Traceback (most recent call last):
  File "/usr/bin/sqlmap", line 26, in <module>
    from lib.controller.controller import start
  File "/usr/share/sqlmap/lib/controller/controller.py", line 12, in <module>
    from lib.controller.action import action
  File "/usr/share/sqlmap/lib/controller/action.py", line 10, in <module>
    from lib.controller.handler import setHandler
  File "/usr/share/sqlmap/lib/controller/handler.py", line 10, in <module>
    from lib.core.common import Backend
  File "/usr/share/sqlmap/lib/core/common.py", line 43, in <module>
    from lib.core.data import conf
  File "/usr/share/sqlmap/lib/core/data.py", line 12, in <module>
    from lib.core.settings import LOGGER
  File "/usr/share/sqlmap/lib/core/settings.py", line 21, in <module>
    REVISION           = getRevisionNumber()
  File "/usr/share/sqlmap/lib/core/revision.py", line 24, in getRevisionNumber
    if client.info(curDir):
pysvn._pysvn_2_6.ClientError: '/usr/share/sqlmap/lib/core' is not a working copy

Anche se provo ad avviarlo dal menu con il mouse ottengo lo stesso errore... Ho fatto un'installazione pulita, dando solo apt-get update e apt-get upgrade...
« Last Edit: June 23, 2011, 12:33:10 PM by SYSTEM_OVERIDE »



ultra_lazer

  • Guest
Reply #1 on: June 21, 2011, 03:14:51 PM
Ciao , penso che il problema sta' qui :  pysvn._pysvn_2_6.ClientError: '/usr/share/sqlmap/lib/core' is not a working copy
Credo che BBx come ubuntu 10.04 porta Python 2.5 , e l'errore evidenzia il mancato update o' la mancanza totale della versione 2.6.

non sono esperto in materia ma penso che quello e' il problema!



raffaele

  • Administrator
  • Hero Member
  • *****
  • Posts: 507
    • View Profile
    • My Blog
Reply #2 on: June 21, 2011, 06:26:41 PM
Ciao Mito, grazie per la segnalazione... in effetti c'è un problema con quel pacchetto. Conto di risolvere a breve.

raffaele@backbox:~$ Get root or die tryin'


Mito125

  • Newbie
  • *
  • Posts: 33
    • View Profile
Reply #3 on: June 21, 2011, 07:29:15 PM
 ;) grazie... Attenderò su twitter le segnalazione :)



raffaele

  • Administrator
  • Hero Member
  • *****
  • Posts: 507
    • View Profile
    • My Blog
Reply #4 on: June 21, 2011, 11:00:26 PM
Ho appena caricato il nuovo pacchetto sul nostro repository. Non ho ancora avuto modo di testarlo a fondo ma tutto dovrebbe funzionare... Se ci sono problemi, fammi sapere ;)

Code: [Select]
sudo apt-get update
sudo apt-get dist-upgrade

raffaele@backbox:~$ Get root or die tryin'


Mito125

  • Newbie
  • *
  • Posts: 33
    • View Profile
Reply #5 on: June 22, 2011, 08:12:08 AM
Ok adesso funziona perfettamente... Grazie... Però un'altra domanda... E' possibile avere JTR in versione jumbo per accedere a ulteriori hash da crackare... Mi sembra che la versione presente non sia jumbo, infatti non mi accetta gli hashes sql... Avevo provato ad installarmelo da solo, ma quando do make clean linux-x86-any mi da qualche tipo di errore... :)



raffaele

  • Administrator
  • Hero Member
  • *****
  • Posts: 507
    • View Profile
    • My Blog
Reply #6 on: June 22, 2011, 08:19:55 AM
Non è questa la sezione giusta per proporre nuovi tools, ti rispondo velocemente e chiudo il post... JTR+Jumbo non ha la stessa stabilità della versione ufficiale di John.

Quote
This patch for John the Ripper adds a lot of code, documentation, and data
contributed by the user community.  This is not "official" John the Ripper
code.  It is very easy for new code to be added to this patch: the quality
requirements are low.  This means that you get a lot of functionality that
is not "mature" enough or is otherwise inappropriate for the official JtR,
which in turn also means that bugs in this code are to be expected, etc.

How to apply this patch to JtR:
http://openwall.info/wiki/john/how-to-extract-tarballs-and-apply-patches

raffaele@backbox:~$ Get root or die tryin'