Author Topic: CompatWireless didn't work (Fixed channel mon0 -1)  (Read 11440 times)

Kirk

  • Newbie
  • *
  • Posts: 13
    • View Profile
 HI all,
 although it is a problem largely discussed, I can not solve.
There are thousands of tutorials on the web to solve, but it's nothing has solved my problem.
I have followed step-by-step this tutorial www.aircrack-ng.org/doku.php?id=compat-wireless (my wireless card is bcm4313, driver:brcm80211 )
i when run:
Code: [Select]
# modprobe brcm80211
this is output:
Code: [Select]
FATAL: Error inserting brcm80211 (/lib/modules/2.6.38-8-generic/kernel/drivers/staging/brcm80211/brcm80211.ko): Invalid argument

How to resolve??  ??? ??? ??? thanks all
« Last Edit: June 04, 2012, 10:45:18 AM by raffaele »



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #1 on: June 04, 2012, 08:17:45 AM
Hi Kirk,

The new broadcom driver is included in the 2.6.38 kernel as i know. To use them :

sudo modprobe mac80211

At this point the wireless should work correctly in network-manager. If this work i will show you how to run drivers with boot. If not type in terminal : lspci -n | grep 14e4 and post what you get.
« Last Edit: June 04, 2012, 09:59:37 AM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


Kirk

  • Newbie
  • *
  • Posts: 13
    • View Profile
Reply #2 on: June 04, 2012, 01:19:09 PM
Hi zerof,first of all thanks for the answer.
I have run modprobe mac80211(without apply compat wireless) but the problem persist(fixed channel mon0 -1);

Code: [Select]
# lspci -vnn | grep 14e4
02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)



weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #3 on: June 04, 2012, 01:54:46 PM
Hi zerof,first of all thanks for the answer.
I have run modprobe mac80211(without apply compat wireless) but the problem persist(fixed channel mon0 -1);

Code: [Select]
# lspci -vnn | grep 14e4
02:00.0 Network controller [0280]: Broadcom Corporation BCM4313 802.11b/g/n Wireless LAN Controller [14e4:4727] (rev 01)
Hi kirk! i have fixed this issue compiling myself the aircrack source code! if you want you can try it, may be can works even for you!!
bye!!

una voce libera è sempre liberatrice
under_r00t


ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester

Kirk

  • Newbie
  • *
  • Posts: 13
    • View Profile
Reply #5 on: June 05, 2012, 01:30:43 AM
Hi weVeg, i want resolve the problem with my driver also because i can't create an ad-hoc wireless connection...
(drivers did not allow this mode)..

@ZEROF:

Thanks for the documentation :D , I have installed this driver (and now i could create one ad-hoc wireless connection :D )...
But the original problem has not yet been completely solved.. because i enabled the monitor mode:

Code: [Select]
# echo 1 > /proc/brcm_monitor0

and he created a new instance of network interface...prism0
Code: [Select]
# ifconfig -a
eth0      Link encap:Ethernet  HWaddr ...  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
          Interrupt:46

eth1      Link encap:Ethernet  HWaddr ....
          inet addr:192.168.1.11  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::... Scope:Link
          UP BROADCAST RUNNING  MTU:1500  Metric:1
          RX packets:4330 errors:46 dropped:0 overruns:0 frame:171148
          TX packets:5226 errors:15 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2631783 (2.5 MiB)  TX bytes:926118 (904.4 KiB)
          Interrupt:17 Base address:0xc000

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:494 errors:0 dropped:0 overruns:0 frame:0
          TX packets:494 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:36020 (35.1 KiB)  TX bytes:36020 (35.1 KiB)

prism0    Link encap:UNSPEC  HWaddr ....-00-00-00-00-00-00-00-00-00-00  
          BROADCAST NOTRAILERS PROMISC ALLMULTI  MTU:1500  Metric:1
          RX packets:4330 errors:46 dropped:286834 overruns:0 frame:171148
          TX packets:5226 errors:15 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000
          RX bytes:2631783 (2.5 MiB)  TX bytes:926118 (904.4 KiB)

eth1 is wilress interface (before was wlan0)..

Code: [Select]
# iwconfig prism0
prism0    IEEE 802.11  Mode:Managed  Channel:6  
          Access Point: ...   Bit Rate=54 Mb/s  
          RTS thr:off   Fragment thr:off
          Power Managementmode:All packets received

the problem is that i can't put it listens on a particular channel.
Code: [Select]
# ifconfig prism0 down
# iwconfig prism0 mode monitor
Error for wireless request "Set Mode" (8B06) :
    SET failed on device prism0 ; Invalid argument.
# iwconfig prism0 channel 3
Error for wireless request "Set Mode" (8B06) :
    SET failed on device prism0 ; Invalid argument.

Any ideas?? Thanks again

Kirk
« Last Edit: June 05, 2012, 01:32:38 AM by Kirk »



Kirk

  • Newbie
  • *
  • Posts: 13
    • View Profile
Reply #6 on: June 05, 2012, 01:38:38 PM
I have noticed that at every reboot, I have to recompile the driver, how do I make the change permanent?



weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #7 on: June 05, 2012, 02:30:47 PM
I have noticed that at every reboot, I have to recompile the driver, how do I make the change permanent?
i don't know if i right understand your request, but try to blacklist old driver.... recompile the driver every time you reboot?!?!?  :-\

una voce libera è sempre liberatrice
under_r00t


ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #8 on: June 05, 2012, 06:23:18 PM
Hi Kirk,

Check one more time documentation :

1.You will see how to blacklist old drivers.
2.And try to see what you have here :



Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #9 on: June 05, 2012, 07:50:02 PM
Ok, let's try simple solution :

Go to Synaptic :



Type to search BCM4313 :



Check 3 packages, and install this packages. Reboot your pc, and this will fix your issue. This worked today for my friend, i made 15km to see how to fix this problem :). I don't use Broadcom because they have pure and non stable (drivers) support for Linux.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


Kirk

  • Newbie
  • *
  • Posts: 13
    • View Profile
Reply #10 on: June 06, 2012, 10:11:46 PM
I solved the problem of reboot...before it loads the old driver wl and i have them removed...and I had the wrong syntax in the blacklist(i was added only the name of module and not "blacklist module_name").

In any case now works! but I still have the problem in the monitor mode prism0...

Quote
I don't use Broadcom because they have pure and non stable (drivers) support for Linux.

yes, the broadcom wireless card only give problems...


BYe



Kirk

  • Newbie
  • *
  • Posts: 13
    • View Profile
Reply #11 on: June 07, 2012, 11:49:10 PM
I have not the idea how to fix the problem ... I'm looking on google but can not find anything interesting  ???

if it helps:

Code: [Select]
# airmon-ng start prism0


Found 2 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!
-e
PID     Name
1652    NetworkManager
1737    wpa_supplicant


Interface       Chipset         Driver

prism0          Unknown         Unknown (MONITOR MODE NOT SUPPORTED)
eth1            Broadcom                wl


the monitor mode is disabled
« Last Edit: June 08, 2012, 12:15:40 AM by Kirk »



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #12 on: June 08, 2012, 12:07:10 AM
Hi,

Now just type sudo airmon-ng and say me what you have ?!


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


Kirk

  • Newbie
  • *
  • Posts: 13
    • View Profile
Reply #13 on: June 08, 2012, 06:43:51 PM
Hi,

Now just type sudo airmon-ng and say me what you have ?!

It's only one more info...I'm trying to give all info that may be useful



weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #14 on: June 08, 2012, 10:55:53 PM
i have read again all the 3d... there is a little confusion... if you are looking for to put your card in ad-hoc mode  to create an ad-hoc wireless conn. why you waste your time with monitor mode, second thing this output is really clear      prism0          Unknown         Unknown (MONITOR MODE NOT SUPPORTED)  
and again your trouble with channel -1 its matter of aircrack....
fix your problems one at time! =)
Bye!!
« Last Edit: June 08, 2012, 11:02:39 PM by weVeg »

una voce libera è sempre liberatrice
under_r00t