Author Topic: Error updating Metasploit framework  (Read 11009 times)

fuemo

  • Newbie
  • *
  • Posts: 3
    • View Profile
on: June 21, 2017, 11:02:58 PM
Hi All,
after upgrading BB to 4.7 version, I'm never able to update MSF.
Executing "msfupdate" command, I obtain this :

  • Attempting to update the Metasploit Framework...
  • Checking for updates via git
  • Note: Updating from bleeding edge

/usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in 'require': cannot load such file -- os (LoadError)
      from /usr/lib/ruby/2.2.0/rubygems/core_ext/kernel_require.rb:54:in 'require'
      from /usr/lib/gems/2.2.0/gems/backports-3.8.0/lib/backports/std_lib.rb:9:in 'require_with_backports'
      from /opt/metasploit-framework/msfupdate:153:in 'git_globals_okay?'
      from /opt/metasploit-framework/msfupdate:202:in 'update_git!'
      from /opt/metasploit-framework/msfupdate:143:in 'block in run!'
      from /opt/metasploit-framework/msfupdate:136:in 'chdir'
      from /opt/metasploit-framework/msfupdate:136:in 'run!'
      from /opt/metasploit-framework/msfupdate:316:in '<main>'


I also tried to reinstall ruby and gems, without obtain success.

Some suggestion?
Thanks a lot.





drego85

  • Global Moderator
  • Full Member
  • *****
  • Posts: 128
    • View Profile
    • Andrea Draghetti
Reply #1 on: June 22, 2017, 08:03:04 AM
Hi Fuemo,
please try following the update instructions here: https://backbox.org/portal/blog/backbox-linux-47-released

Andrea Draghetti
Personal Blog


fuemo

  • Newbie
  • *
  • Posts: 3
    • View Profile
Reply #2 on: June 30, 2017, 07:12:00 PM
Hi drego85, thank you for your answer (and sorry for delay in answering you)
Unfortunately, repeating all the steps, nothing is changed, I have exactely the same error...    :-\



ZEROF

  • Hero Member
  • *****
  • Posts: 1246
    • View Profile
    • Pen Tester
Reply #3 on: July 01, 2017, 09:19:23 PM
All looks ok here, got last version etc..


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


fuemo

  • Newbie
  • *
  • Posts: 3
    • View Profile
Reply #4 on: July 08, 2017, 01:40:56 PM
Hi ZEROF.
Nothing to do, I always have the same error...
I installed a new vm from scratch (I need a running machine, just now) and everything goes right.
The "failed" VM is actually saved, I hope to find enough time next days to try to understand where the problem is: if I get some results from my search, I will update this post.

Thanks to you (and drego85, obviously) for your support.