Author Topic: Alfa wifi card power settings  (Read 28907 times)

ultra_lazer

  • Guest
on: March 21, 2012, 09:26:42 PM
Hi everyone
Ciao tutti.

As many of you know or maybe not, Alfa wifi cards have multiple power settings depends on the country you buy the card from.
Example :
* If you have purchased your Alfa card from Italy, the Txpower will be more likely set to 20 dBm , in some cases 27 dBm , ( 27 dBm=500w)
Many cards clame 1000w but the setting says otherwise !
here is the initial test on Alfa AWUS036H , RTL8187L , 1000w :

$ iwconfig wlan0
wlan0     IEEE 802.11bg  ESSID:off/any  
          Mode:Managed  Frequency:2.462 GHz  Access Point: Not-Associated  
          Tx-Power=20 dBm  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off

As you can see is set to 20 dBm , that is clearly less than 500w.

THE FIX :

Now, if you try to increase the txpower to 30 dBm = 1000w ,  like this : iwconfig wlan0 txpower 30
 you might likely get an error due to restrictions in the country!
Error :   Error for wireless request "Set Tx Power" (8B26) :
    SET failed on device wlan0 ; Invalid argument.

So, what we do ??

Luckely The least restrictive countries are BO and BZ. You can set you Alfa card according to these countries:

ifconfig wlan0 down
iw reg set BO
ifconfig wlan0 up
iwconfig wlan0 channel 13
iwconfig wlan0 txpower 30


* Now hopefully you wont get errors and your Alfa is pumping out full power  ;)

Disclaimer :   It might be illegal in your country, so use it at your own risk .

Good luck
UL
« Last Edit: March 21, 2012, 09:43:18 PM by ultra_lazer »



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #1 on: March 21, 2012, 09:59:35 PM
Hi,

1. This settings are on your own risk.
2. Some models will not support this settings (don't try this with older 500mw etc. models)


Thanks !


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


ultra_lazer

  • Guest
Reply #2 on: March 22, 2012, 09:14:46 AM
Playing around with it, here is the final resault : " Full 30 dBm "

root@backbox:/home/backbox# ifconfig wlan1 down
root@backbox:/home/backbox# iw reg set BO
root@backbox:/home/backbox# ifconfig wlan1 up
root@backbox:/home/backbox# iwconfig wlan1 channel 13
root@backbox:/home/backbox# iwconfig wlan1 txpower 30
root@backbox:/home/backbox# iwconfig wlan1
wlan1     IEEE 802.11bg  ESSID:"ilker" 
          Mode:Managed  Frequency:2.462 GHz  Access Point: 00:14:C1:2B:0C:62   
          Bit Rate=1 Mb/s  Tx-Power=30 dBm  
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:7265-6472-6564-3132-3334-3536-37
          Power Management:off
          Link Quality=39/70  Signal level=-71 dBm 
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

root@backbox:/home/backbox#




ultra_lazer

  • Guest
Reply #4 on: March 26, 2012, 07:55:23 PM
 ;) thanks man, much appreciated  ;)



ultra_lazer

  • Guest
Reply #5 on: March 30, 2012, 10:11:12 AM
EDIT:

Finally found the best solution for my Alfa , been playing around with power settings starting from 1M to 54M, i tested aircrack, injection power and reaver, they all worked best  with 11M.

Here is how you do it:

root@backbox:/home/backbox# ifconfig wlan1 down
root@backbox:/home/backbox# iw reg set BO
root@backbox:/home/backbox# ifconfig wlan1 up
root@backbox:/home/backbox# iwconfig wlan1 channel 13
root@backbox:/home/backbox# iwconfig wlan1 txpower 30
root@backbox:/home/backbox# iwconfig wlan1 rate 11M auto

This is so far the best solution i achieved, good luck to you !
 ;) UL