Author Topic: Firefox is starting immediately after Booting system [SOLVED]  (Read 9162 times)

ranjeet44

  • Newbie
  • *
  • Posts: 5
    • View Profile
Hi all,

I am new to BackBox, I'm using backbox 3.01.When I start the system, after login, firefox immediately starts up. Whats the reason behind it?
« Last Edit: May 15, 2013, 06:23:07 PM by raffaele »



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #1 on: May 09, 2013, 12:02:36 PM
Hi,

That is not normal. Open terminal and type :

sudo insserv -r firefox

Then reboot your pc. Keep me posted.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


b4d_bl0ck

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
Reply #2 on: May 09, 2013, 12:36:10 PM
Hi ranjeet44,
it could also be you saved the xfce session logging out or shutting down your system, so it gets restored automatically.
Check MENU -> Settings -> Settings Manager -> Session and Startup and see if you have the Automatically save session on, or if firefox is checked in Application Autostart tab. You can also display session chooser on startup to see if there actually are some saved sessions.
If you cannot find anything there you can delete your saved sessions:
Code: [Select]
rm -f ~/.cache/sessions/*Then try to logout and login again...

Bye... let us know.

bool secure = check_paranoia() ? true : false;


ranjeet44

  • Newbie
  • *
  • Posts: 5
    • View Profile
Reply #3 on: May 10, 2013, 05:07:42 AM
Hi,

That is not normal. Open terminal and type :

sudo insserv -r firefox

Then reboot your pc. Keep me posted.

That not working see the terminal output below-

root@autobot:/home/ranjeet# sudo insserv -r firefox
sudo: insserv: command not found

 
I was logged in as root.



N3tw0rk47

  • Newbie
  • *
  • Posts: 12
    • View Profile
Reply #4 on: May 10, 2013, 06:23:05 AM
If you put your propeller cap on and think what would Jesus do ?

Code: [Select]
whereis insserv

as you can see that insserv is located in /usr/lib/insserv/insserv

Code: [Select]
sudo ln -s /usr/lib/insserv/insserv /usr/bin/insserv

or

Code: [Select]
sudo /usr/lib/insserv/insserv --help


But as badblock  said

Code: [Select]
sudo rm -rf ~/.config/sessions/*

should fix that problem
« Last Edit: May 10, 2013, 06:48:20 AM by N3tw0rk47 »



weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #5 on: May 10, 2013, 01:25:53 PM
If you are root why type sudo?
btw badblock tell you the way:
Quote
Check MENU -> Settings -> Settings Manager -> Session and Startup and see if you have the Automatically save session on, or if firefox is checked in Application Autostart tab. You can also display session chooser on startup to see if there actually are some saved sessions.

una voce libera รจ sempre liberatrice
under_r00t


b4d_bl0ck

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
Reply #6 on: May 10, 2013, 03:32:14 PM
Thanks N3tw0rk47, great support on here ;)

Code: [Select]
sudo rm -rf ~/.config/sessions/*
Just a little thing, sessions shoul be saved in .cache/sessions, not in .config/sessions ;D so:
Code: [Select]
rm -f ~/.cache/sessions/*
Thx again man! ;)

bool secure = check_paranoia() ? true : false;


ranjeet44

  • Newbie
  • *
  • Posts: 5
    • View Profile
Reply #7 on: May 14, 2013, 01:28:13 PM
Thanks guys, Problem got solved.