Author Topic: WPS & Reaver ?  (Read 6557 times)

Ro0ttrE3

  • Newbie
  • *
  • Posts: 2
    • View Profile
on: January 23, 2012, 09:17:38 PM
How do I know if a router has WPS enable in BackBox ?

Thank you. :)



raffaele

  • Administrator
  • Hero Member
  • *****
  • Posts: 506
    • View Profile
    • My Blog
Reply #1 on: January 23, 2012, 10:54:07 PM
Code: [Select]
wash --help

raffaele@backbox:~$ Get root or die tryin'


Ro0ttrE3

  • Newbie
  • *
  • Posts: 2
    • View Profile
Reply #2 on: January 24, 2012, 02:45:57 AM



Ananke

  • Guest
Reply #3 on: February 08, 2012, 05:11:45 PM
A proposito ho visto che su backbox la versione è ancora la 1.3 ma il 22 gennaio è uscita la versione 1.4.

Volevo solo avvisare nel caso vi fosse sfuggito



raffaele

  • Administrator
  • Hero Member
  • *****
  • Posts: 506
    • View Profile
    • My Blog
Reply #4 on: February 08, 2012, 06:20:28 PM
tieni aggiornata la tua backbox, reaver è gia all'ultima versione ;)

Code: [Select]
sudo apt-get update
sudo apt-get dist-upgrade

raffaele@backbox:~$ Get root or die tryin'


Ananke

  • Guest
Reply #5 on: February 08, 2012, 08:29:51 PM
A ecco  :D Scusa l'errore.


Purtroppo però a me non lo aggiorna e ho installato la 1.3 di Reaver. Penso che dipenda dal fatto che ho ancora Backbox 2.0 e non la 2.1 giusto?
Comunque gli altri softwares li aggiorna correttamente.



berghem

  • Jr. Member
  • **
  • Posts: 97
    • View Profile
    • http://lorenzistefano.com
Reply #6 on: February 08, 2012, 08:35:13 PM
Ma nel tuoi repo cosa hai?
Prova a digitare apt-cache search pacchetto


raffaele

  • Administrator
  • Hero Member
  • *****
  • Posts: 506
    • View Profile
    • My Blog
Reply #7 on: February 08, 2012, 08:41:25 PM
la backbox 2.0 e la 2.01 hanno gli stessi repo... prova a dare:

Code: [Select]
sudo apt-get clean
sudo apt-get update
sudo apt-get dist-upgrade

raffaele@backbox:~$ Get root or die tryin'


Ananke

  • Guest
Reply #8 on: February 08, 2012, 08:46:42 PM
Dando il comando consigliato da Berghem l'output è stato:

Code: [Select]
reaver - Brute force attack against Wifi Protected Setup
Con i comandi di Raffaele il terminale ad "apt-get dist-upgrade" ha restituito:

Code: [Select]
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
Calcolo dell'aggiornamento... Eseguito
0 aggiornati, 0 installati, 0 da rimuovere e 0 non aggiornati.

Come posso risolvere?
Grazie della disponibilità ragazzi



berghem

  • Jr. Member
  • **
  • Posts: 97
    • View Profile
    • http://lorenzistefano.com
Reply #9 on: February 08, 2012, 09:10:31 PM
Significa che hai il pacchetto aggiornato...
Ora, se sei certo che la versione non sia l'ultima,allora non so aiutarti.... almeno che tu non intenda scaricarti i sorgent e provi a compilarli


Ananke

  • Guest
Reply #10 on: February 08, 2012, 09:25:49 PM
Prima che Reaver fosse aggiunto ai repository l'avevo installato compilando i sorgenti. Successivamente l'avevo rimosso per installare la versione di backbox. Che sia questo il problema?

Che dite se provo con:
apt-get purge reaver
apt-get install reaver

?
« Last Edit: February 08, 2012, 09:28:43 PM by Ananke »



berghem

  • Jr. Member
  • **
  • Posts: 97
    • View Profile
    • http://lorenzistefano.com
Reply #11 on: February 08, 2012, 09:51:40 PM
quindi se ho ben capito hai fatto un downgrade dell'applicativo?


Ananke

  • Guest
Reply #12 on: February 08, 2012, 10:01:36 PM
Avevo anche io la 1.3.
L'ho solo rimossa ed installato quella dai repository.

Solo che quando è uscita la nuova versione non me l'ha aggiornata. Ed eccomi qui a parlarne.
Può essere dovuto a quello?
Provo a fare purge e poi a installarla di nuovo o rischio di far più danni che altro?

Grazie dell'assistenza



berghem

  • Jr. Member
  • **
  • Posts: 97
    • View Profile
    • http://lorenzistefano.com
Reply #13 on: February 08, 2012, 10:08:42 PM
beh, in teoria non dovresti fare danni, alla fine stai solo didinstallando un pacchetto e lo reinstalli...


Ananke

  • Guest
Reply #14 on: February 08, 2012, 10:24:36 PM
Dando "apt-get purge" l'output è:

Code: [Select]
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti saranno RIMOSSI:
  reaver*
0 aggiornati, 0 installati, 1 da rimuovere e 0 non aggiornati.
Dopo quest'operazione, verranno liberati 618 kB di spazio su disco.
Continuare [S/n]? s
(Lettura del database... 129869 file e directory attualmente installati.)
Rimozione di reaver...
Eliminazione dei file di configurazione di reaver...
Elaborazione dei trigger per man-db...
Elaborazione dei trigger per python-gmenu...
Rebuilding /usr/share/applications/desktop.it_IT.utf8.cache...
Elaborazione dei trigger per desktop-file-utils...
Elaborazione dei trigger per python-support...

Quando poi do "apt-get install" l'output è:

Code: [Select]
apt-get install reaver
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze       
Lettura informazioni sullo stato... Fatto
I seguenti pacchetti NUOVI saranno installati:
  reaver
0 aggiornati, 1 installati, 0 da rimuovere e 0 non aggiornati.
È necessario scaricare 204 kB di archivi.
Dopo quest'operazione, verranno occupati 618 kB di spazio su disco.
Scaricamento di:1 http://ppa.launchpad.net/backbox/two/ubuntu/ natty/main reaver i386 1.4-0backbox1 [204 kB]
Recuperati 204 kB in 0s (246 kB/s)
Selezionato il pacchetto reaver.
(Lettura del database... 129855 file e directory attualmente installati.)
Estrazione di reaver (da .../reaver_1.4-0backbox1_i386.deb)...
Elaborazione dei trigger per python-gmenu...
Rebuilding /usr/share/applications/desktop.it_IT.utf8.cache...
Elaborazione dei trigger per desktop-file-utils...
Elaborazione dei trigger per man-db...
Elaborazione dei trigger per python-support...
Configurazione di reaver (1.4-0backbox1)...


Sembrerebbe quindi che abbia installato la versione 1.4. Ma purtroppo se l'avvio noto che è ancora la versione 1.3
Inizio a dubitare di riuscire a risolvere la questione. Qualche idea?