Author Topic: [SOLVED] Vidalia malfunction  (Read 3149 times)

fukwad

  • Newbie
  • *
  • Posts: 13
    • View Profile
on: March 07, 2016, 06:40:39 AM
Hello. I started Vidalia and it did work with no problems.  Now after I restart the computer, I start Valdia and it works. If I stop it and start it again it says: 'Vidalia was unable to start Tor. Check your settings to ensure the correct name and location of tour Tor executable is specified'
If I check the settings and check to see if everything is good when I click 'ok'  it says:
  'Vidalia was unable to save your Advanced settings. ControlSocket path doesnt exist.'  
When I stop tor and start Vidalia it says:
Vidalia unable to register for some events. many Vidalia features unavailable.

I really don't want to reboot every time I stop it so it runs properly. I tried reinstalling everything and it still does the same thing.  Does anyone know why its doing this?
« Last Edit: March 09, 2016, 10:33:33 AM by ZEROF »



nephop

  • Newbie
  • *
  • Posts: 18
    • View Profile
Reply #1 on: March 07, 2016, 01:34:05 PM
May be you should update your system.

try it if not than post again. with screen shot.



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #2 on: March 07, 2016, 09:17:46 PM
Hi,

This was solution for some users, this is just copy/paste:

"Just follow up these steps

Open up /etc/apparmor.d/usr.bin.vidalia file with root permissions.

For this you can run sudo gedit /etc/apparmor.d/usr.bin.vidalia in a Terminal.

Add this line /usr/bin/tor Ux, anywhere inside the /usr/bin/vidalia {...} block. Place of this line in that block does not matter. Add just after /usr/share/icons/*/index.theme k, for exemple.

Run sudo apparmor_parser --replace /etc/apparmor.d/usr.bin.vidalia in a Terminal.

Okay, now you're done!"


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


fukwad

  • Newbie
  • *
  • Posts: 13
    • View Profile
Reply #3 on: March 09, 2016, 09:01:24 AM
Awesome thanks. It eventually worked. I had to reinstall it [I used apt-get remove instead of synaptic] and change the setting to 'use TCP port' and do the 'apparmor_parser --replace /etc/apparmor.d/usr.bin.vidalia' magic trick again and now I can stop & start it without having to reboot.  :)