Author Topic: OpenVAS troubleshooting! (what I did to get it to work... kind of..)  (Read 3694 times)

xer0point

  • Newbie
  • *
  • Posts: 1
    • View Profile
Okay well, first of all, I am very new with backbox, but I am pretty good at trouble shooting things in general.  As many others, I have ran into several issues with openVAS and setting it up to run properly.  I screwed up my first installation somehow, but following a purge and reinstall, and following the generous information from previous posts and sinflood.net's post installation setup, I managed to get it functional last night after about 2 days of working on it.  I was very excited and pleased.  THen today, I went ahead and tried to start everything up...  Oh crap, that same darn Starting OpenVas Manager error.. WTF!!  Well, I decided to play with the extremely valuable script openvas-check-setup.. I just make sure to sudo -s prior to running the script to avoid a hassle of permission denials.  Hmm what a interesting read out.

To highlight MY particular errors discovered through that script in order... - Problem:Issues with tasks.db being corrupt, etc. Fix: Purge/Reinstall/Following postinstallation from sinflood.net exactly.  This lead to my first successful login to the Greenbone Security Assistant. Next problem, today:  Same Openvasmd error... weird... frustrating.. especially since it was working last night..  I run the openvas-check-setup script again... this time a different error, which changed occassionally, but essentially the same error.  1: Openvas Manager not runnning!(openvasmd) well.. okay... duh..  Openvas Administrator not running! (openvasad).  Greenbone Security assistant not running (gsad).. Fix: okay well... everytime i tried to openvas-services start, I got the same manager error.  so I decided to restart, then run the check script again, to see which openvas service was not running.  then i simply executed the service manually; ie: sudo openvasad start ; sudo openvasmd start ; sudo gasd start , etc..  Time to run the openvas-check-setup script again and see if it worked...  SWEET, "It seems like your OpenVAS-6 installation is okay"  Im stoaked, so what do I do?  I try and go to localhost:9392 like i did last night... CRAP it doesnt work..  Now, I go back and carefully read through the readout from the openvas-check-setup...  well a few weird things are noted... one, my ports are all over the place according to the read out.  Openvas Scanner port is at 9391 ; Openvas Manager port is at 9390 ; Openvas Administrator port is at 9393; and the Greenbone Security Assistant is on port 443, for whatever reason.  Now I figure I should test the Greenbone security assistant..  soo.. open up the web and shoot in localhost:443 and there we go... the log in screen arrives like it did last night.. 

Now, I wouldn't go so far as saying I have OpenVas functional, as I have not even got around to testing it out, etc.  but I wanted to share what I ran into so anyone else with trouble, or people far more experienced with backbox and or openvas can figure a more permanent solution.  I still have full logs, if anyone wants em, let me know and I will post them.

Oh and a few details that might be important.  Running backbox via VirtualMachine through VMWare workstation 10.  Let me know if I can help, even if I really am quite a beginner.  Again, I'm very new to backbox and the forum, so if I'm screwing up any etiquette please let me know.



b4d_bl0ck

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
Hi xer0point,
thanks for sharing the workaround you have found.
lol, it resembles an old post of mine (it's in italian but there are more or less the same steps, but after the first login on port 443, the following times gsad spawned up on port 9392 regularly (weeeird!)). ;D
Anyways the problem is that recently (with the new version if i'm right) this solution is not working anymore for me and some other users, so i don't know if it will work for everyone.
But thanks for your time and dedication! ;)
...and welcome!

Have fun!

bool secure = check_paranoia() ? true : false;


sinflooddotnet

  • Newbie
  • *
  • Posts: 40
    • View Profile
have a look at this regarding tasks.db

http://comments.gmane.org/gmane.comp.security.openvas.users/4934

Quote
>>>>>
try :
locate openvas/mgr

checking logs,  yours should be /usr/local/lib/var/lib/locate
openvas/mgr

do a :
touch /usr/local/lib/var/lib/locate openvas/mgr/task.db

and retry:
openvasmd --rebuild  (take care that openvassd must be running)
<<<<<