Author Topic: [SOLVED]My rtl8187 is fine but not listed and I cant put into monitor mode?  (Read 3753 times)

lister

  • Newbie
  • *
  • Posts: 23
    • View Profile
sudo airmon-ng does not list my rtl8187 (I have Alfa wireless card)

However, if I "modprobe rtl8187" then the card is apparently activated but it is not listed? Any ideas why not? I updated to Kernel 3 - could that be the problem?

If I try to put up an interface on wlan0 it activates another driver - ?

# dmesg | grep rtl8187

Gives me output like this

# usbcore: registered new interface driver rtl8187

What could the problem be? Thanks
« Last Edit: May 04, 2013, 11:44:26 PM by ZEROF »



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Hi,

What you want to say with "not listed" ?

Now go to problem :)

I think that you try to use adapter with vmware  (maybe i'm wrong), and rfkill switch off rtl8187:

1. Boot your system
2. After 20 sec (+-) plugin your adapter and enable it

3.Open terminal and run all commands one by one:

rmmod rtl8187
rfkill block all
rfkill unblock all
modprobe rtl8187
rfkill unblock all
ifconfig wlan0 up


You will need to do this every time you plugin your card. That is my solution.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


lister

  • Newbie
  • *
  • Posts: 23
    • View Profile
Thanks I think I fixed it - not sure how but it seems to be ok