Author Topic: Metasploit rpc daemon shut down [SOLVED]  (Read 8314 times)

All3xJ

  • Newbie
  • *
  • Posts: 8
    • View Profile
on: June 29, 2014, 10:29:17 PM
When I open Armitage there is this bug with metasploit:

http://image.bayimg.com/e05ff32edda565229de6a7cfd04c6f1fd3cc3030.jpg

Please what can i do for resolve this bug?? :'(

Please help meee  :-\
« Last Edit: July 03, 2014, 06:47:48 PM by ZEROF »



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #1 on: June 30, 2014, 12:47:22 PM
Strange, i don't have problem with this. Where to start? That is all what you can give to us?

1. Did you run updates?
2. Did you check if msf is connected to data base? (to check this type db_status and you need to get message "postgresql connected to metasploit4" if not in msf console run db_connect -y /opt/backbox/config/database.yml)
3. Then you can open Armitage

And as you can see, you just need to read your error message (http://www.fastandeasyhacking.com/nomsfrpcd). But before this, check steps I mentioned before.

Etc ...
« Last Edit: June 30, 2014, 01:22:14 PM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


All3xJ

  • Newbie
  • *
  • Posts: 8
    • View Profile
Reply #2 on: June 30, 2014, 11:19:51 PM
Strange, i don't have problem with this. Where to start? That is all what you can give to us?

1. Did you run updates?
2. Did you check if msf is connected to data base? (to check this type db_status and you need to get message "postgresql connected to metasploit4" if not in msf console run db_connect -y /opt/backbox/config/database.yml)
3. Then you can open Armitage

And as you can see, you just need to read your error message (http://www.fastandeasyhacking.com/nomsfrpcd). But before this, check steps I mentioned before.

Etc ...

Thanks you very much for the help..
I do some test... and these are results (i am not english  ;D)

Code: [Select]
alex@alex-900:~$ sudo msfconsole
[sudo] password for alex:

[!] Warning: This tool is located in /opt/backbox/msf
[i] Remember to give the full absolute path when specifying a file

[*] Metasploit requires the Bundler gem to be installed
    $ gem install bundler
alex@alex-900:~$ sudo msfrpcd -U msf -P test -f -S

[!] Warning: This tool is located in /opt/backbox/msf
[i] Remember to give the full absolute path when specifying a file

[*] Metasploit requires the Bundler gem to be installed
    $ gem install bundler
alex@alex-900:~$ sudo gem install bundler
Successfully installed bundler-1.6.3
1 gem installed
Installing ri documentation for bundler-1.6.3...
Building YARD (yri) index for bundler-1.6.3...
Installing RDoc documentation for bundler-1.6.3...
alex@alex-900:~$ sudo msfconsole

[!] Warning: This tool is located in /opt/backbox/msf
[i] Remember to give the full absolute path when specifying a file

[*] Metasploit requires the Bundler gem to be installed
    $ gem install bundler
alex@alex-900:~$ sudo msfrpcd -U msf -P test -f -S

[!] Warning: This tool is located in /opt/backbox/msf
[i] Remember to give the full absolute path when specifying a file

[*] Metasploit requires the Bundler gem to be installed
    $ gem install bundler
alex@alex-900:~$
???



blackhat-security

  • Newbie
  • *
  • Posts: 2
    • View Profile
Reply #3 on: July 01, 2014, 12:34:32 AM
When using Linux the vast majority of errors tell you whats wrong .. so it says it requires bundler installed so if you just google gem bundle install metasploit you will see how to fix the error

but this is how you fix that error



Code: [Select]
cd /opt/backbox/msf
sudo gem install bundler
sudo gem update
« Last Edit: July 01, 2014, 08:40:59 AM by b4d_bl0ck »



All3xJ

  • Newbie
  • *
  • Posts: 8
    • View Profile
Reply #4 on: July 02, 2014, 11:43:51 AM
Thanks you I relsolve!!!
Thanks you all!!  ;) ;D



b4d_bl0ck

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
Reply #5 on: July 02, 2014, 02:30:01 PM
Nice... so you can now mark the thread as [SOLVED]  ;)

Have fun!

bool secure = check_paranoia() ? true : false;