Author Topic: Macchanger [SOLVED]  (Read 5706 times)

pixar

  • Newbie
  • *
  • Posts: 7
    • View Profile
on: January 28, 2011, 06:34:47 PM
Salve  a tutti!!!
Intanto vorrei farvi i complimenti x l'ottimo progetto che sta crescendo e migliorando a vista d'occhio!!!
Purtroppo non sono in grado di apportare migliorie xke non sono molto

Vorrei chiedere il vostro aiuto xke non riesco a far funzionare macchanger, in pratica se cambio il mac con il programma non mi si connette + a nessuna rete. Ho fatto decine di prove seguendo anche qualche guida sul web ma niente, se non ripristino tutto e torno al mac originale non va neanche con la mia rete.

Non capisco cosa possa essere xke è un problema che ho anche con ubuntu 10.10 ma non si presenta con backtrack4 che non è sviluppato su quella versione di ubuntu. Per precisione ho provato anche su un'altro notebook ma niente.

Voi avete notato lo stesso problema o è solo mio?
« Last Edit: May 19, 2011, 01:27:42 PM by SYSTEM_OVERIDE »



clshack

  • Full Member
  • ***
  • Posts: 177
    • View Profile
    • ClsHack | Blog
Reply #1 on: January 28, 2011, 07:15:26 PM
non ho lo stesso problema cioè a me macchanger va e non va a volte lo cambia a volte no..

Hai provato a cambiarlo utilizzando ifconfig ? :)

[a me va tranquillo]

Code: [Select]
ifconfig eth0 |grep HWaddrE dopo:
Code: [Select]
ifconfig eth0 down
ifconfig eth0 hw ether MAC
ifconfig eth0 up

Code: [Select]
ifconfig eth0 |grep HWaddrIl problema del non navigare comunque potrebbe essere che possono navigare solo certi mac però se va con bt4 non è questo il problema.
 



pixar

  • Newbie
  • *
  • Posts: 7
    • View Profile
Reply #2 on: January 29, 2011, 09:30:28 AM
Grazie per la risp, ho provato come hai detto tu e il mac me lo cambia cosi come con macchanger il problema è che quando vado a connettermi nuovamente alla mia rete wifi (che non ha il filtro mac) non mi fa + accedere mi chiede la pass come se fosse sbagliata! Riesco a connettermi con l'ap solo ripristinando la connessione e quindi mi riporta di nuovo il mac originale...
Ho provato anche tramite l'utility del gestore delle connessioni ma niente neanche in quel modo, forse sarà un problema della mia scheda di rete  ???

Aggiungo che mi sono accorto del problema dall'introduzione di ubuntu 10.04.
Oggi ho cercato nuovamente in rete e mi sono accorto che molti hanno il mio stesso problema con le versioni di ubuntu e non hanno trovato soluzioni neanche nel forum ufficiale... :( mi sa che mi devo rassegnare
« Last Edit: January 29, 2011, 05:58:24 PM by pixar »



clshack

  • Full Member
  • ***
  • Posts: 177
    • View Profile
    • ClsHack | Blog
Reply #3 on: January 30, 2011, 10:04:13 AM
purtroppo se è un bug di ubuntu noi ci possiamo fare poco.. . anche se mi sembra strano a me va tutto ok...





pixar

  • Newbie
  • *
  • Posts: 7
    • View Profile
Reply #4 on: March 20, 2011, 10:15:30 PM
Ciao Alessio, dopo un po di tempo ho ricominciato ad usare backbox e si è ripresentato il problema ma provando e riprovando sono riuscito a trovare una soluzione, bastava riavviare il network manager con il comando
Code: [Select]
sudo service network-manager restart .

Quindi in totale eseguo questi comandi:
Code: [Select]
ifconfig wlan0 down
macchanger -a wlan0
ifconfig wlan0 up
/etc/init.d/networking restart
service network-manager restart

Mi sembrava giusto condividere la soluzione per chi ne avesse bisogno, grazie e a presto!



clshack

  • Full Member
  • ***
  • Posts: 177
    • View Profile
    • ClsHack | Blog
Reply #5 on: March 22, 2011, 08:53:52 AM
Teoricamente basterebbero solo questi:

Code: [Select]
ifconfig wlan0 down
macchanger -a wlan0
ifconfig wlan0 up



pixar

  • Newbie
  • *
  • Posts: 7
    • View Profile
Reply #6 on: March 24, 2011, 09:45:01 PM
Si lo so!   ;D Prima bastavano anche per me ma da ubuntu 10.04 non mi funziona più e ho dovuto aggiungere le altre 2 righe!  ;D



clshack

  • Full Member
  • ***
  • Posts: 177
    • View Profile
    • ClsHack | Blog
Reply #7 on: March 26, 2011, 06:51:45 PM
A me va solo con i 3 pezzi di codice ;)  se raf è daccordo si potrebbe anche rimuovere questo software visto che va e non va ;) e lasciare solo la lista dei mac tanto ci vogliono due comandi per cambiarlo ;) oppure alternative :)