Author Topic: Iinterface up or insufficient permissions (macchanger)[SOLVED]  (Read 8971 times)

leopard

  • Newbie
  • *
  • Posts: 6
    • View Profile
Hey guys,

I have a problem with macchanger command.
Error message: [ERROR] Could not change MAC: interface up or insufficient permissions: Too many open files in system

This is how i tried it;
sudo ifconfig wlan0 down
sudo service network-manager stop  
sudo macchanger -a wlan0
OR
sudo macchanger -r wlan0
OR
sudo macchanger --mac xx:xx:xx:xx:xx:xx wlan0

But i get still the same message: [ERROR] Could not change MAC: interface up or insufficient permissions: Too many open files in system
Any ideas why?
« Last Edit: January 10, 2015, 01:28:52 PM by ZEROF »

Where there's a shell, there's a way!!


ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #1 on: October 03, 2014, 03:05:06 AM
Hi,

Make sure that your interface is down and you are running macchanger as a root user.

Or just copy/paste:

sudo -i
ifconfig wlan0 down
macchanger -A wlan0

And you are done.

« Last Edit: October 03, 2014, 03:50:41 AM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


leopard

  • Newbie
  • *
  • Posts: 6
    • View Profile
Reply #2 on: October 03, 2014, 10:28:58 PM
Hi,

Make sure that your interface is down and you are running macchanger as a root user.

Or just copy/paste:

sudo -i
ifconfig wlan0 down
macchanger -A wlan0

And you are done.




Hey thanks for the answer.
So i did what you said but i still get the same error!

Where there's a shell, there's a way!!


ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #3 on: October 04, 2014, 10:25:39 AM
Look, it's not a magic to stop interface and set mac. I don't know how i can help you.

Do you know how to record terminal? There are few ways, easy way is with ttyrec:

apt-get install ttyrec

To start recording terminal session:

ttyrec "MyVideo"

Stop recording:

exit

To play your terminal recording:

ttyplay MyVideo

Upload what you are doing (http://playterm.org/). Or learn how to use asciinema https://asciinema.org

1. Reboot your system
2. Start ttyrec
3. Type ifconifg
4. Stop interface
5. Check if interface is down with ifconfig (sometimes Network manager will restart connection, because of that you must to stop interface twice, brutal solution is to stop Network manager, but it's not needed).
5. Look macchanger help (-h), because you can use few switches (macchanger -A or -a or -r  + name of your interface) etc

And next step will be:



Good luck.

« Last Edit: October 04, 2014, 11:05:03 AM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


leopard

  • Newbie
  • *
  • Posts: 6
    • View Profile
Reply #4 on: October 04, 2014, 06:56:37 PM
Look, it's not a magic to stop interface and set mac. I don't know how i can help you.

Do you know how to record terminal? There are few ways, easy way is with ttyrec:

apt-get install ttyrec

To start recording terminal session:

ttyrec "MyVideo"

Stop recording:

exit

To play your terminal recording:

ttyplay MyVideo

Upload what you are doing (http://playterm.org/). Or learn how to use asciinema https://asciinema.org

1. Reboot your system
2. Start ttyrec
3. Type ifconifg
4. Stop interface
5. Check if interface is down with ifconfig (sometimes Network manager will restart connection, because of that you must to stop interface twice, brutal solution is to stop Network manager, but it's not needed).
5. Look macchanger help (-h), because you can use few switches (macchanger -A or -a or -r  + name of your interface) etc

And next step will be:



Good luck.




Thank you so much for your help!
I will do what you said and will give you the answer.
Just i realized something: When i run macchanger the result is:

sudo -i
ifconfig wlan0 down
macchanger -A wlan0

Current MAC:   xx:xx:xx:xx:xx:xx (unknown)
Permanent MAC: xx:xx:xx:xx:xx:xx (unknown)
[ERROR] Could not change MAC: interface up or insufficient permissions: Too many open files in system

PS: I put "x" instead of my mac.
So as you can see it seems that doesn't recognize my wireless driver but if run "sudo lshw -C network" the result would be:

configuration: broadcast=yes driver=wl0 driverversion=6.30.223.141 (r415941) ip=192.168.1.6 latency=0 multicast=yes wireless=IEEE 802.11abg resources: irq:17 memory:a0600000-a0603fff

So that is mean the driver is installed and am connected with my wifi right now so i don't get it.
But anyway i reinstalled my wireless driver by following this two links:

http://wireless.kernel.org/en/users/Drivers/b43
https://help.ubuntu.com/community/WifiDocs/Driver/bcm43xx#b43%20-%20Internet%20access

I still get the same error. I think there is a problem with the driver, i don't know!

Where there's a shell, there's a way!!


ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #5 on: October 04, 2014, 10:05:00 PM
Ok, we are geting somewhere. maybe. This is how you need to install drivers:

Quote
sudo -i
cd /usr/src/backports-*; make uninstall; cd .. ; sudo rm -rf /usr/src/backports-*

And then in same terminal session copy all in this as one command (you need to be root), then run it..

Quote
cd /usr/src/;wget https://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.15.1/backports-3.15.1-1.tar.gz; tar -zxvf backports-*; cd backports-*; apt-get install patch; wget http://patches.aircrack-ng.org/mac80211.compat08082009.wl_frag+ack_v1.patch; patch -p1 < mac80211.compat08082009.wl_frag+ack_v1.patch; wget -Ocompatdrivers_chan_qos_frag.patch http://www.pastie.org/pastes/8846771/download; patch -p1  < compatdrivers_chan_qos_frag.patch; make defconfig-b43; make; make install; update-initramfs -u; echo "REBOOT"; sleep 5; reboot

Then try again. This is not perfect install script but i don't have time to check for all patches you will need to have 100% injection enabled adapter. It's a lot of learning and time. 2nd patch don't help your adapter, but help fixing other issues with aircrack.

And in the end. How the hell you see wlan0 interface if you don't have some kind of working drivers? I don't see how this will fix your issue, but at last you will learn how to do some things, 101 Linux system.
« Last Edit: October 04, 2014, 10:22:54 PM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


leopard

  • Newbie
  • *
  • Posts: 6
    • View Profile
Reply #6 on: October 07, 2014, 02:44:53 AM
Ok, we are geting somewhere. maybe. This is how you need to install drivers:

Quote
sudo -i
cd /usr/src/backports-*; make uninstall; cd .. ; sudo rm -rf /usr/src/backports-*

And then in same terminal session copy all in this as one command (you need to be root), then run it..

Quote
cd /usr/src/;wget https://www.kernel.org/pub/linux/kernel/projects/backports/stable/v3.15.1/backports-3.15.1-1.tar.gz; tar -zxvf backports-*; cd backports-*; apt-get install patch; wget http://patches.aircrack-ng.org/mac80211.compat08082009.wl_frag+ack_v1.patch; patch -p1 < mac80211.compat08082009.wl_frag+ack_v1.patch; wget -Ocompatdrivers_chan_qos_frag.patch http://www.pastie.org/pastes/8846771/download; patch -p1  < compatdrivers_chan_qos_frag.patch; make defconfig-b43; make; make install; update-initramfs -u; echo "REBOOT"; sleep 5; reboot

Then try again. This is not perfect install script but i don't have time to check for all patches you will need to have 100% injection enabled adapter. It's a lot of learning and time. 2nd patch don't help your adapter, but help fixing other issues with aircrack.

And in the end. How the hell you see wlan0 interface if you don't have some kind of working drivers? I don't see how this will fix your issue, but at last you will learn how to do some things, 101 Linux system.

Thank you for the answer i really appreciate your help!

That's why i don't get it. It's like i have and don't have the driver but my wifi works!

I did exactly what you said and it didn't work for macchanger but airmon works now thanks.
macchanger, airodump and aircrack they still don't work.

I have done more research and it seems they didn't find any solution for the wireless driver's problem on new macbooks!
Check these:
https://help.ubuntu.com/community/MacBookPro9-2/Ringtail#Wireless
https://help.ubuntu.com/community/MacBookPro9-2/Precise

Where there's a shell, there's a way!!


ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #7 on: October 07, 2014, 04:15:10 AM
Look, if your issue is your hardware, i can't help you.I don't use MAC products, and grab one older/new pc only for BackBox and have fun.
« Last Edit: October 07, 2014, 04:18:50 AM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


leopard

  • Newbie
  • *
  • Posts: 6
    • View Profile
Reply #8 on: October 08, 2014, 03:29:55 AM
Look, if your issue is your hardware, i can't help you.I don't use MAC products, and grab one older/new pc only for BackBox and have fun.


Thanks a lot for your help. I have it on my PC and it works without any problem.
I will let you know if i found any solution for the MAC.
Have a good one...

Where there's a shell, there's a way!!