Author Topic: [SOLVED]ioctl(SIOCGIFINDEX) failed: No such device  (Read 64395 times)

Er74b1

  • Newbie
  • *
  • Posts: 4
    • View Profile
on: August 15, 2012, 02:34:15 PM
Hallo :D
When i Try to start Monitor Mode with Airodump-ng in backbox i got this error message !
my wifi usb has worked under backtrack 5 with airodump-ng !
i have tryed  it with all my usb who works under bt5 etc. to start montor mode in backbox but  without sucess!  :)

er74b1@er74b1-ASE571-AST671:~$ sudo airmon-ng
[sudo] password for er74b1:


Interface   Chipset      Driver

wlan0      Unknown       r8712u
wlan1      Unknown       usb

er74b1@er74b1-ASE571-AST671:~$ sudo airmon-ng start wlan1

Found 5 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID   Name
582   avahi-daemon
583   avahi-daemon
584   NetworkManager
623   wpa_supplicant
1536   dhclient
Process with PID 1536 (dhclient) is running on interface wlan0


Interface   Chipset      Driver

wlan0      Unknown       r8712u
wlan1      Unknown       usb (monitor mode enabled)

er74b1@er74b1-ASE571-AST671:~$ sudo airodump-ng mon0
Interface mon0:
ioctl(SIOCGIFINDEX) failed: No such device
er74b1@er74b1-ASE571-AST671:~$

« Last Edit: September 04, 2012, 10:06:37 PM by ZEROF »



weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #1 on: August 15, 2012, 03:33:13 PM
Quote
wlan1      Unknown       usb (monitor mode enabled)
try:
Code: [Select]
sudo airodump-ng wlan1

una voce libera è sempre liberatrice
under_r00t


Er74b1

  • Newbie
  • *
  • Posts: 4
    • View Profile
Reply #2 on: August 15, 2012, 04:35:25 PM
Thanks! this  Start the airodump-ng windows but does monitor  :-\




weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #3 on: August 15, 2012, 04:50:47 PM
can you paste iwconfig please?

una voce libera è sempre liberatrice
under_r00t


Er74b1

  • Newbie
  • *
  • Posts: 4
    • View Profile
Reply #4 on: August 15, 2012, 10:18:39 PM
lo        no wireless extensions.

eth0      no wireless extensions.

wlan0     IEEE 802.11bg  ESSID:"JOHNDOE"  Nickname:"rtl_wifi"
          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:01:E3:C5:78:4F   
          Bit Rate:54 Mb/s   Sensitivity:0/0 
          Retry:off   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=95/100  Signal level=48/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

wlan1     Ralink STA  ESSID:""  Nickname:"RT2870STA"
          Mode:Auto  Frequency=2.412 GHz  Access Point: Not-Associated   
          Bit Rate:1 Mb/s   
          RTS thr:off   Fragment thr:off
          Link Quality=10/100  Signal level:0 dBm  Noise level:-115 dBm
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0








weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #5 on: August 16, 2012, 12:58:52 PM
Code: [Select]
sudo iwconfig wlan1 mode monitor

una voce libera è sempre liberatrice
under_r00t


Er74b1

  • Newbie
  • *
  • Posts: 4
    • View Profile
Reply #6 on: September 03, 2012, 12:32:34 PM
Does work !  :-\



weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #7 on: September 03, 2012, 01:07:08 PM
Does work !  :-\
well! add SOLVED to the title!

una voce libera è sempre liberatrice
under_r00t