Author Topic: OpenVas services not working [SOLVED]  (Read 73579 times)

reaperz73

  • Newbie
  • *
  • Posts: 21
    • View Profile
on: June 02, 2013, 04:39:58 AM
Backbox 3.5 64bit


Whenever I use the start service for OpenVas from the menu it does not work
I get this
Code: [Select]
[i] Starting OpenVAS services...

Starting OpenVAS Scanner: openvassd.
Starting OpenVAS Manager: ERROR.

reaperz73@bbox:~$

However I can start services manually from the command line and all is good but the one click start the whole thing is not working.
Any fix for this?
« Last Edit: June 03, 2013, 09:18:02 AM by raffaele »



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #1 on: June 02, 2013, 06:18:42 AM
When you get that error, just go back to menu and run restart option, and openvas will start ;).
« Last Edit: June 02, 2013, 06:20:14 AM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


reaperz73

  • Newbie
  • *
  • Posts: 21
    • View Profile
Reply #2 on: June 02, 2013, 06:37:22 AM
nope same thing
Code: [Select]
[i] Stopping OpenVAS services...

Stopping Greenbone Security Assistant: gsad.
Stopping OpenVAS Administrator: openvasad.
Stopping OpenVAS Manager: openvasmd.
Stopping OpenVAS Scanner: openvassd.

[i] Starting OpenVAS services...

Starting OpenVAS Scanner: openvassd.
Starting OpenVAS Manager: ERROR.

reaperz73@bbox:~$



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #3 on: June 02, 2013, 07:35:10 AM
Ok, let's see. You mast have boot conflicts. After update some services can start when you boot your system, as openvas was updated few days before, i guess your system start some of openvas services in boot.

Open terminal and run:

sudo -i

Then copy all and run in terminal :

update-rc.d -f greenbone-security-assistant remove;
update-rc.d -f openvas-administrator remove;
update-rc.d -f openvas-manager remove;
update-rc.d -f openvas-scanner remove;

Reboot your system, and openvas will start from menu.

;)
« Last Edit: June 02, 2013, 07:36:57 AM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


reaperz73

  • Newbie
  • *
  • Posts: 21
    • View Profile
Reply #4 on: June 02, 2013, 08:55:32 AM
Nope still didn't work . that last one you posted ZEROF really had my hopes up.
Thought for sure that would work.



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #5 on: June 02, 2013, 09:24:08 AM
Run system update, then do what i write in last topic.

sudo -i

apt-get update && apt-get upgrade && apt-get dist-upgrade

...

This solution work, when you start openvas for the 1st time it will take some time (few min). But i'm sure it's good solution.

And i want to check something. Install chkconfig tool, and post terminal output (with pastebin) when you run command chkconfig --list.

;)


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


reaperz73

  • Newbie
  • *
  • Posts: 21
    • View Profile
Reply #6 on: June 02, 2013, 06:45:08 PM
Got it working now. Had to purge openvas and reinstall. But all good now.



romeyro

  • Newbie
  • *
  • Posts: 14
    • View Profile
Reply #7 on: October 04, 2013, 03:07:25 AM
Next time try

./openvas-check-setup

:)

---
ROmeyro


TH3CR4CK3R

  • Newbie
  • *
  • Posts: 13
    • View Profile
Reply #8 on: October 08, 2013, 11:01:39 PM
I have ran into this same issue before and usually clicking the update option from the services menu will do the trick. and you also have to create the user, this is the command I use to do so.

openvasad -c 'add_user' -n <name> -r Admin



sinflooddotnet

  • Newbie
  • *
  • Posts: 40
    • View Profile
Reply #9 on: October 09, 2013, 09:34:32 AM
sudo openvas-services stop
sudo openvasmd --rebuild
sudo openvas-services start

for openvas setup see also: http://sinflood.net/?p=104



qednet

  • Newbie
  • *
  • Posts: 1
    • View Profile
Reply #10 on: December 03, 2013, 07:53:29 PM
Hi

I also have a problem with openvas. I have followed the steps suggested here. No good.

I ran the openvas-check-setup script, did the fixes it suggested. No good http://www.openvas.org/setup-and-start.html

The problem seems to be with the Greenbone Security Assistant. It crashes with this error message

"Error: received handshake message out of context"

:/



raffaele

  • Administrator
  • Hero Member
  • *****
  • Posts: 506
    • View Profile
    • My Blog
Reply #11 on: December 04, 2013, 09:57:58 AM

raffaele@backbox:~$ Get root or die tryin'


ostendali

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 581
    • View Profile
Reply #12 on: December 05, 2013, 01:12:06 PM
As we stated earlier, OpenVAs is working for most of us without any issues.

Please follow the wiki page tutorial and if it doesn't work, come back with your full logs that we can help and dig in further.

Cheers