Pages: [1]   Go Down
Print
Author Topic: [SOLVED] rt2800usb No Longer Injecting Packets With Newer Kernels (4.x)  (Read 5433 times)
electroblu3
Newbie
*
Posts: 18


View Profile
« on: January 03, 2017, 08:33:09 PM »

As the title says, my rt28000usb cards are no longer injecting with the newer versions of BackBox using kernel 4.x. If I downgrade back to 3.19 it appears to work again. I have somewhat found a soultion but I have no idea how to go about implimenting it as I don't know anything about patching:

https://bugs.kali.org/view.php?id=3298

Any help would be apprecaited, thanks.

« Last Edit: January 05, 2017, 01:41:03 AM by ZEROF » Logged
ZEROF
Hero Member
*****
Posts: 1194


View Profile WWW
« Reply #1 on: January 03, 2017, 11:05:51 PM »

Hi,

We are short on info here. What is your adapter? Pls check and share info with us: https://forum.backbox.org/software-support/how-to-ask-for-wifi-adaptersdrivers-help-!-!-!/

And if you have card i think that you have, you can use rt3070 drivers.
« Last Edit: January 03, 2017, 11:30:25 PM by ZEROF » Logged


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*
electroblu3
Newbie
*
Posts: 18


View Profile
« Reply #2 on: January 03, 2017, 11:39:24 PM »

Thanks for your reponse. Here are the details, let me know if you require anything else:

https://0bin.net/paste/oOBRZdAHhJv5dXEi#9Z2UWjIeCkHsCRZpD40hKUrvtDRrv1laquDirhbxar9

Sorry about the long link, it wouldnt let me generate a short url for some reason.
Logged
ZEROF
Hero Member
*****
Posts: 1194


View Profile WWW
« Reply #3 on: January 04, 2017, 12:04:55 AM »

Before we go to some tricky stuff, if I was you, would try new kernel, in this case 4.5, today to install this version is kind easy.

First to be sure if something goes wrong and that you can use old kernel:

sudo nano /etc/default/grub

Few first lines need to looks like this:

GRUB_DEFAULT=0
#GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=10

This will give you grub menu when you boot your system and you can chose kernel you want to use in "Advanced option". But ... after that and before reboot etc..

If you have x64 system:

Code:
cd /tmp/

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/linux-headers-4.5.0-040500_4.5.0-040500.201603140130_all.deb

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/linux-headers-4.5.0-040500-generic_4.5.0-040500.201603140130_amd64.deb

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/linux-image-4.5.0-040500-generic_4.5.0-040500.201603140130_amd64.deb

sudo dpkg -i *.deb

For x86

Code:
cd /tmp/

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/linux-headers-4.5.0-040500_4.5.0-040500.201603140130_all.deb

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/linux-headers-4.5.0-040500-generic_4.5.0-040500.201603140130_i386.deb

wget http://kernel.ubuntu.com/~kernel-ppa/mainline/v4.5-wily/linux-image-4.5.0-040500-generic_4.5.0-040500.201603140130_i386.deb

sudo dpkg -i *.deb

Run:

sudo update-grub

Reboot, check if you have new kernel with uname -r,  and try injection again. If this don't help, we can check other solution. This is easy fix if it's working, because your can remove this packages with apt remove.

Remove:

Reboot computer and select boot with previous kernel (under Advanced Options) entry when you’re at Grub bootloader.Login and remove kernel 4.5 via command:
sudo apt remove linux-headers-4.5.0-* linux-image-4.5.0-*; sudo update-grub

Hope it will work Smiley

« Last Edit: January 04, 2017, 12:16:58 AM by ZEROF » Logged


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*
electroblu3
Newbie
*
Posts: 18


View Profile
« Reply #4 on: January 04, 2017, 02:14:07 PM »

root@alphonses:~# aireplay-ng -9 mon0
12:51:13  Trying broadcast probe requests...
12:51:13  Injection is working!
12:51:15  Found 4 APs

Thanks so much for that response, it worked!!!  Grin

However it caused another problem. Because I was using VirtualBox, it would no longer allow me to install Guest Additions after upgrading the kernel to 4.5, throwing out errors but the main one being "-fstack-protector-strong". After much Googling I discovered this was because of the GCC version. I updated this to 5 and was able to install Guest Additions  Smiley

Here are the steps for those who may face the same problem:

Code:
sudo add-apt-repository ppa:ubuntu-toolchain-r/test
sudo apt-get update
sudo apt-get install gcc-5 g++-5
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-5 60 --slave /usr/bin/g++ g++ /usr/bin/g++-5

The above will leave version 5 configured only. If you wish to have 4.8 (current) as well:

Code:
sudo update-alternatives --install /usr/bin/gcc gcc /usr/bin/gcc-4.8 50 --slave /usr/bin/g++ g++ /usr/bin/g++-4.8

To switch:

Code:
sudo update-alternatives --config gcc

To remove repo afterwards:

Code:
sudo add-apt-repository --remove ppa:ubuntu-toolchain-r/test


Naturally, if you are running BackBox directly and not using VirutalBox, you simply need to upgrade the kernel to fix the injection issue.
Logged
ZEROF
Hero Member
*****
Posts: 1194


View Profile WWW
« Reply #5 on: January 04, 2017, 04:40:57 PM »

You see Smiley

But for Virtualbox i think that you did to much of work. I had almost the same situation and i just reinstalled dkms. Something like apt-get install --reinstall virtualbox-dkms, but maybe this is new issue i'm not aware. Anyway all back to normal Smiley
« Last Edit: January 04, 2017, 05:43:46 PM by ZEROF » Logged


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*
Pages: [1]   Go Up
Print
Jump to: