Author Topic: Problema Intel wireless 1030 [SOLVED]  (Read 4827 times)

Dark Angel

  • Newbie
  • *
  • Posts: 27
    • View Profile
on: May 25, 2011, 02:20:51 AM
ciao a tutti ho appena installato backbox 1.05 sul mio nuovo dell xps 15 con scheda wireless intergrata intel 1030. con ubuntu non ho mai avuto problemi ma appane ho avviato backbox la scheda non mi veniva riconosciuta (o forse io non so come attivarla coc win7 e ubuntu uso un tasto sulla tastiera).....qualquno saprebbe aiutarmi


grazie mille???
« Last Edit: June 23, 2011, 06:28:50 PM by vincenzo »



raffaele

  • Administrator
  • Hero Member
  • *****
  • Posts: 506
    • View Profile
    • My Blog
Reply #1 on: May 25, 2011, 10:29:44 AM
usa il tasto sulla tastiera... anche io ho un dell e non ho mai avuto problemi.

raffaele@backbox:~$ Get root or die tryin'


Dark Angel

  • Newbie
  • *
  • Posts: 27
    • View Profile
Reply #2 on: May 25, 2011, 11:45:42 AM
usa il tasto sulla tastiera... anche io ho un dell e non ho mai avuto problemi.

non funziona ho gia provato...di solito uso il tasto fn + f2 ma qui sembra non funzionare



raffaele

  • Administrator
  • Hero Member
  • *****
  • Posts: 506
    • View Profile
    • My Blog
Reply #3 on: May 25, 2011, 03:23:17 PM
prova a cercare su google. la compatibilità hw di backbox è la stessa di ubuntu lucid

raffaele@backbox:~$ Get root or die tryin'


Dark Angel

  • Newbie
  • *
  • Posts: 27
    • View Profile
Reply #4 on: May 26, 2011, 09:49:51 AM
prova a cercare su google. la compatibilità hw di backbox è la stessa di ubuntu lucid
infatti strano con ubuntu funzionava....



Dark Angel

  • Newbie
  • *
  • Posts: 27
    • View Profile
Reply #5 on: May 27, 2011, 10:24:22 AM
prova a cercare su google. la compatibilità hw di backbox è la stessa di ubuntu lucid
ho cercato un po' ma ho trovato i driver per il kernel 2.6.36 mentre BackBox 1.05 usa 2.6.31 come posso fare??
(tra l'altro l'installazione non sembra affatto cosi semplice)

i driver li ho trovati qui http://intellinuxwireless.org/
io ho la N-1030

grazie ancora



vincenzo

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Reply #6 on: May 27, 2011, 03:18:40 PM
Prova a vedere un po' anche i consigli che sono stati dati ad altri utenti che hanno avuto problemi col wireless, di solito installare i compat-wireless, aggiornare il kernel, o cercare degli altri repo sono le vie "standard". Se non risolvi usando questi mezzi allora sarebbe più efficace postare il tuo problema in un forum specializzato al produttore del tuo portatile.

In ogni caso, dando un'occhiata a un thread nel forum di ubuntu:

http://ubuntuforums.org/showthread.php?t=1718211

ho visto che qualcuno ha risolto il problema per la tua stessa scheda usando esattamente lo stesso metodo di aggiornamento al kernel 2.6.38 che ti ho suggerito nell'altro thread. :) ( a parte che lì si consiglia la 2.6.38-1 e io ti ho proposto la 2.6.38-8 ).

Se le cose non vanno bene puo' dipendere da un conflitto con la tua scheda video (integrata o dedicata), e quindi dovresti installare i drivers per la tua scheda video prima di riavviare. In ogni caso cerca su altri forum se e come hanno risolto altri. Specifica i dettagli del tuo hardware, non solo della scheda wireless. Dovessi risolvere anche tu, posta la tua soluzione anche qui se vuoi, così dai una mano agli utenti di Backbox con lo stesso problema e fai cosa molto gradita alla nostra comunità. :)
« Last Edit: May 27, 2011, 03:39:48 PM by vincenzo »

You cannot teach a man anything. You can only help him discover it within himself.




Dark Angel

  • Newbie
  • *
  • Posts: 27
    • View Profile
Reply #7 on: May 28, 2011, 02:16:52 PM
Prova a vedere un po' anche i consigli che sono stati dati ad altri utenti che hanno avuto problemi col wireless, di solito installare i compat-wireless, aggiornare il kernel, o cercare degli altri repo sono le vie "standard". Se non risolvi usando questi mezzi allora sarebbe più efficace postare il tuo problema in un forum specializzato al produttore del tuo portatile.

In ogni caso, dando un'occhiata a un thread nel forum di ubuntu:

http://ubuntuforums.org/showthread.php?t=1718211

ho visto che qualcuno ha risolto il problema per la tua stessa scheda usando esattamente lo stesso metodo di aggiornamento al kernel 2.6.38 che ti ho suggerito nell'altro thread. :) ( a parte che lì si consiglia la 2.6.38-1 e io ti ho proposto la 2.6.38-8 ).

Se le cose non vanno bene puo' dipendere da un conflitto con la tua scheda video (integrata o dedicata), e quindi dovresti installare i drivers per la tua scheda video prima di riavviare. In ogni caso cerca su altri forum se e come hanno risolto altri. Specifica i dettagli del tuo hardware, non solo della scheda wireless. Dovessi risolvere anche tu, posta la tua soluzione anche qui se vuoi, così dai una mano agli utenti di Backbox con lo stesso problema e fai cosa molto gradita alla nostra comunità. :)
ok grazie adesso provo ad aggiornare il kernel con l'indirizzo che hai postato prima.......incrociamo le dita.....vi faro' sapere come e' andata



Dark Angel

  • Newbie
  • *
  • Posts: 27
    • View Profile
Reply #8 on: May 28, 2011, 02:38:12 PM
niente da fare ho provato e riprovato ad aggiornare il kernel da terminale come suggerito ma quando avvio il nuovo kernel lo schermo rimane nero e si blocca....niente da fare purtroppo...!



vincenzo

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Reply #9 on: May 28, 2011, 06:44:24 PM
Se vuoi prova a dirci che modello è il tuo portatile e possibilmente i dettagli sull'hardware.

You cannot teach a man anything. You can only help him discover it within himself.




Dark Angel

  • Newbie
  • *
  • Posts: 27
    • View Profile
Reply #10 on: May 29, 2011, 02:51:08 PM
Se vuoi prova a dirci che modello è il tuo portatile e possibilmente i dettagli sull'hardware.
Ho un dell xps 15 con nvidia geforce gt 540m da 2 gb e usa un'architettura a 64 bit



vincenzo

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Reply #11 on: May 30, 2011, 01:47:35 AM
Ok, prova così:

1) Parti con il kernel di default (2.6.32) e assicurati di aver installato tutti gli aggiornamenti:
   
Code: [Select]
sudo apt-get update && sudo apt-get dist-upgrade   
   se te lo chiede riavvia.
   
2) installa dei componenti importanti:
   
Code: [Select]
sudo apt-get install binutils build-essential   
3) scarica gli ultimi driver Nvidia per GeForce GT 540M (dando per scontato che usi Linux a 32-bit):
   http://www.nvidia.com/content/DriverDownload-March2009/confirmation.php?url=/XFree86/Linux-x86/270.41.19/NVIDIA-Linux-x86-270.41.19.run&lang=us&type=GeForce
   
   [Se il tuo username è "darkangel" Firefox scaricherà questo pacchetto in /home/darkangel/Scaricati]
   
4) installa i sorgenti del kernel 2.6.32:
   
Code: [Select]
sudo apt-get install linux-source   
5) apri il modulo di blacklist:
   
Code: [Select]
gksudo geany /etc/modprobe.d/blacklist.conf   
   e una volta aperto l'editor aggiungi alla fine:
   
   blacklist vga16fb
   blacklist nouveau
   blacklist rivafb
   blacklist nvidiafb
   blacklist rivatv

   [ricorda di salvare il file.]
   
6) disinstalla i driver Nouveau e Nvidia preesistenti:
Code: [Select]
sudo apt-get --purge remove xserver-xorg-video-nouveau
sudo apt-get --purge remove nvidia-*
 
7)
Code: [Select]
sudo reboot
==========================================================
CASO A: il sistema parte col kernel 2.6.38 senza problemi.
==========================================================

A1) una volta fatto il login apri un terminale e chiudi il server X con il comando:
     
Code: [Select]
sudo /etc/init.d/gdm stop
A2) vedrai che il sistema ti fa loggare in modalità testo e a questo punto
Code: [Select]
cd Scaricati
sudo sh NVIDIA-Linux-x86-270.41.19.run
   
Compariranno delle schermate, accetta e rispondi sempre si/ok.
Anche dopo l'installazione quando ti chiede di nvidia-xconfig rispondi Yes.
   
Code: [Select]
startx   
    per far ripartire il desktop.
   
==========================================================
CASO B: il kernel 2.6.38 ti dà ancora schermata nera.
==========================================================

B1) Fai partire sempre il kernel 2.6.38 ma in modalità ripristino (la scegli dal menù di avvio),
      seleziona "resume" dal menù che ti compare in seguito. Il sistema parte in modalità testo, fai il login.
   
B2)
Code: [Select]
cd Scaricati
sudo sh NVIDIA-Linux-x86-270.41.19.run
   
Compariranno delle schermate, accetta e rispondi sempre si/ok.
Anche dopo l'installazione quando ti chiede di nvidia-xconfig rispondi Yes.
   
Code: [Select]
sudo reboot   

==========================================================
CASO C: funziona solo il kernel 2.6.32
==========================================================

Entra in BackBox > Sistema > Gestore pacchetti e cerca il pacchetto:
   
  linux-backports-modules-compat-wireless-2.6.38-2.6.32-31-generic-pae
   
e installalo. Non ti dovesse rilevare il wireless allora segui il wiki di Backbox:

http://wiki.backbox.org/Customization#How_to_install_compat-wireless_aircrack_patches

In ogni caso devi installare i driver per la tua scheda nvidia quindi i punti da 1) al 5) e A1) e A2) sotto il
kernel 2.6.32 ti conviene comunque eseguirli (a meno che tu non abbia gia installato i driver col gestore
automatico di aggiornamenti o in altro modo).

------------------------------------------------------------------------


Dovessero esserci ancora problemi ci sarebbe qualche altra via sempre nella modalità di ripristino sotto il
kernel 2.6.38 per regolare la risoluzione di avvio, puo' essere anche quello che fa i capricci, ma in ogni
caso i passaggi che ti ho detto dovresti seguirli. Facci sapere.
« Last Edit: July 07, 2011, 03:23:26 PM by vincenzo »

You cannot teach a man anything. You can only help him discover it within himself.




Dark Angel

  • Newbie
  • *
  • Posts: 27
    • View Profile
Reply #12 on: June 23, 2011, 05:34:39 PM
Grazie tanto per l'aiuto Vincenzo....sono riuscito ad aggiornare il kernel con il tuo aiuto ed ora (con la versione 2.6.38-8.42) la scheda wireless funziona correttamente.
L'unica cosa e' che quando accedo e provo da terminale :
Code: [Select]
sudo /etc/init.d/gdm stopper attivare la modalita' testo ad installare i driver nvidia precedentemente scaricati mi compare una schermata con delle scritte e poi si blocca.
se provo invece ad installare i file da terminale mi dice che devo chiudere X server.
Comunque anche senza driver nvidia direi che funziona tutto corrattamente...forse usa la intel integrata??
tu cosa ne pensi??

RIEPILOGO I PASSAGGI ESEGUITI:
-ho eseguito la tua guida dal punto 1 al 7 (i driver che ho scaricato erano diversi da quelli indicati )
-al riavvio potevo avviare solo il kernel 2.6.32 (il 2.6.38) non compariva
-ho ripreso questa giuda e ho riprovato ad aggiorare il kernel cosi (anche se un mese fa non funzionava in questo modo):
Code: [Select]
sudo add-apt-repository ppa:kernel-ppa/ppa
sudo apt-get update
sudo apt-get install linux-headers-2.6.38-8-generic linux-image-2.6.38-8-generic
sudo update-grub
-ora all'avvio posso avviare il nuovo kernel 2.6.38-8.42 e tutto funziona correttamente!!!

Grazie e scusa per il ritardo ma sono stato impegnato all'uni con degli esami....
a presto
« Last Edit: June 23, 2011, 05:40:56 PM by Dark Angel »



vincenzo

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Reply #13 on: June 23, 2011, 06:27:56 PM
Ciao, figurati. Si credo stia usando la scheda "built-in". Allora, quel comando "sudo /etc/init.d/gdm stop" serve per chiudere il server X. Ma se non riesci in questo modo fai partire linux in recovery mode all'avvio (menu di grub) così il server X non lo vedi proprio e fai il login testuale dopo aver scelto "resume" da un menu che compare prima del login. Dopo "sudo sh NVIDIA.xxx.xxx.run" e dovrebbe andare. Il link che avevo postato portava direttamente alla lettura dei termini di licenza, e dopo aver accettato ti faceva scaricare. Vai al sito di Nvidia e scarica i drivers per il tuo modello, è facilissimo trovarli. L'installazione dovrebbe filare se hai seguito quei passi perchè i drivers originali hanno bisogno di compilare qualche modulo, quindi con il pacchetto build-essential e i sorgenti del kernel dovrebbe essere tutto a posto. Se proprio non ti riesce, leggi il wiki di backbox sui drivers nvidia ed eventualmente apri un altro thread. Nel frattempo chiudo questo, visto che il problema originario dei driver wireless si è risolto. Ciao!
« Last Edit: June 23, 2011, 06:33:22 PM by vincenzo »

You cannot teach a man anything. You can only help him discover it within himself.