Author Topic: How to permanently disable laptop's internal wifi card? [SOLVED]  (Read 26376 times)

ReallyHosed

  • Newbie
  • *
  • Posts: 20
    • View Profile
I want to use a high quality usb wifi adapter with Linux, and I can, but I haven't been able to figure out how to disable my HP laptop's stupid 30 mw internal pci wifi. I could unclip the two Hirose connectors, remove the screws and pop it out before booting but then when I want to use it  in Windows I'd have to pop it back in, what a pain!
Here's some information: In Network Manager, it is named:
Intel PRO/Wireless 3945ABG [Golan]
The driver appears to be e1000e:
sudo ls /sys/class/net/eth0/device/driver/module/drivers
pci:e1000e
When I tried to use rfkill all it did was toggle the laptop's wifi on/off button, and with that "off" I can't use ANY wifi including USB adapters. (!!)
I was hoping there'd be a quick on/off option using setpci but so far all I've found via google is techo-babble, way over my noob head.
Google found a GUI for start processes which looked hopeful but it isn't showing up in Synaptic Package Manager and I haven't found a working download link:
BootUp-Manager Version 2.5.2
Anyone have a suggestion that I can understand?




« Last Edit: January 12, 2015, 11:48:56 AM by ZEROF »



weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #1 on: October 31, 2013, 02:29:28 AM
may be......
Code: [Select]
sudo ifconfig wlanX down

[edit]
« Last Edit: October 31, 2013, 12:05:39 PM by weVeg »

una voce libera è sempre liberatrice
under_r00t


ReallyHosed

  • Newbie
  • *
  • Posts: 20
    • View Profile
Reply #2 on: October 31, 2013, 07:32:56 AM
Thanks for the reply!  I've done sudo ifconfig wlan0 down  but wlan0 comes back online soon after, is Network Manager calling it back to life?  For that matter, doing sudo kill -9 for the PID number of Network Manager is little help because THAT comes right back up.
Gwad it sucks not knowing WTF I'm doing! lol
As for using sudo iwconfig wlan0 power, uh, will that turn off the mini-pci card? I don't see how it could...



weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #3 on: October 31, 2013, 12:28:42 PM
Thanks for the reply!  I've done sudo ifconfig wlan0 down  but wlan0 comes back online soon after, is Network Manager calling it back to life?  For that matter, doing sudo kill -9 for the PID number of Network Manager is little help because THAT comes right back up.
Gwad it sucks not knowing WTF I'm doing! lol
How can come back on line??
Have you tried to remove the driver of wlan?

Quote
As for using sudo iwconfig wlan0 power, uh, will that turn off the mini-pci card? I don't see how it could...
indeed! I made a mistake!! lol

una voce libera è sempre liberatrice
under_r00t


ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #4 on: October 31, 2013, 01:37:46 PM
ReallyHosed,

Find your card driver and add to blacklist. That's all.

« Last Edit: October 31, 2013, 01:55:29 PM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


b4d_bl0ck

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
Reply #5 on: October 31, 2013, 04:01:56 PM
...or disable it into the BIOS configuration screen, if it can be done. ;)

Anyways welcome to BackBox!
Have fun!

bool secure = check_paranoia() ? true : false;


ReallyHosed

  • Newbie
  • *
  • Posts: 20
    • View Profile
Reply #6 on: November 01, 2013, 03:43:44 AM
Thanks for the reply, b4d_bl0ck, that would have been my first choice but my laptop's BIOS lacks that option.
And thanks to you too, ZEROF,  although I've already forgotten how to blacklist a module, a quick google search reminded me how to use your advice and now it's working exactly the way I wanted, YIPPEE!
Thanks again!!



weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #7 on: November 01, 2013, 04:39:52 PM
Blacklisting the drivers you can't use anymore any other device that use that driver... Is an half solution of your problem... I'm used to find the problem, and in this case is: why your wifi card come back up when you put it down??

una voce libera è sempre liberatrice
under_r00t


ReallyHosed

  • Newbie
  • *
  • Posts: 20
    • View Profile
Reply #8 on: November 02, 2013, 12:08:23 AM
Hello weVeg, what's worse is why does Network Manager come right back to life after I do
sudo kill -9 (then type the PID number of Network Manager)
That shuts Network Manager down but it rises from the dead immediately after. I don't know if that's
why I've never yet been able to capture a four-way handshake?  What I'm talking about is when I do:
airmon-ng start wlan1
It starts mon0 but airmon-ng tells me there's five processes which may cause trouble. Network Manager is one of them.



b4d_bl0ck

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
Reply #9 on: November 02, 2013, 10:38:39 AM
To stop it:
Code: [Select]
sudo service network-manager stopto reenable it:
Code: [Select]
sudo service network-manager start
Or search the web on how to prevent that interface from being handled by NetworkManager

Bye!

bool secure = check_paranoia() ? true : false;


ReallyHosed

  • Newbie
  • *
  • Posts: 20
    • View Profile
Reply #10 on: November 02, 2013, 12:25:05 PM
Fantastic, THANK YOU!  Being a noob, I've been trying to stop it with kill -9 and the PID (i did try "sudo service Network Manager stop" and that didn't work, lol!).
Now that you've taught me how I'll try to capture a handshake again. Wish me luck!
« Last Edit: November 02, 2013, 10:44:23 PM by ReallyHosed »



ostendali

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 587
    • View Profile
Reply #11 on: November 06, 2013, 09:34:18 PM
Fantastic, THANK YOU!  Being a noob, I've been trying to stop it with kill -9 and the PID (i did try "sudo service Network Manager stop" and that didn't work, lol!).
Now that you've taught me how I'll try to capture a handshake again. Wish me luck!
hello there,
i have seen 2 thread of yours and both of them are really basic of linux usage.
when you signed to the forum have you noticed the disclaimer?
if not i will help you to get there: https://forum.backbox.org/announcements/general-forum-conditions/
please be advised and the next come with your homework.
ciao



ReallyHosed

  • Newbie
  • *
  • Posts: 20
    • View Profile
Reply #12 on: November 07, 2013, 04:56:30 AM
Hello ostendali,
I did read the disclaimer and saw "If you are beginner, please go first for "Linux Basic System Administration Tutorial"" so I googled for "Linux Basic System Administration Tutorial" and didn't find anything by that name. I was misled, but I now gather that your intention was to direct me to some of the help links you listed down below. Thank you for those; I will study more.
As for why I started this thread: when airmon-ng said "found 5 processes that could cause trouble" and gave me PIDs, I was again misled by airmon-ng, this time in TWO ways. First, since I was given a PID I tried to try to stop it with kill -9 (which killed it but it kept coming back up). Secondly, airmon-ng named it as "Network Manager" so when I tried to do "sudo service Network Manager stop" you know what happened - NOTHING. I became desperate, therefore I asked here and you people helped me. Thanks again, all!



ostendali

  • Global Moderator
  • Hero Member
  • *****
  • Posts: 587
    • View Profile
Reply #13 on: November 08, 2013, 09:09:31 AM
Hello ostendali,
I did read the disclaimer and saw "If you are beginner, please go first for "Linux Basic System Administration Tutorial"" so I googled for "Linux Basic System Administration Tutorial" and didn't find anything by that name. I was misled, but I now gather that your intention was to direct me to some of the help links you listed down below. Thank you for those; I will study more.
As for why I started this thread: when airmon-ng said "found 5 processes that could cause trouble" and gave me PIDs, I was again misled by airmon-ng, this time in TWO ways. First, since I was given a PID I tried to try to stop it with kill -9 (which killed it but it kept coming back up). Secondly, airmon-ng named it as "Network Manager" so when I tried to do "sudo service Network Manager stop" you know what happened - NOTHING. I became desperate, therefore I asked here and you people helped me. Thanks again, all!
there are many ways of disabling wifi card:
modprope -r wifi-module, add blacklist wifi-module, ifconfig wlanx and set to down the script that takes it back online on reboot, etc.
stopping network manager is not part of that, it will stop the entire network including wired interface and not only wifi.
the above solutions are all very basic of linux, any of user with basic linux knowledge will definitely manage them without any help, for those who are not there thousands of forums for basic knowledge and just googling you find many solutions.

here what i just typed on google was:
disable wifi card linux

and the first result in the list:
https://www.google.de/url?sa=t&rct=j&q=&esrc=s&source=web&cd=1&cad=rja&ved=0CC0QFjAA&url=http%3A%2F%2Faskubuntu.com%2Fquestions%2F168032%2Fhow-to-disable-built-in-wifi-and-use-only-usb-wifi-card&ei=v5t8Uuj3FMTesgbJ8YHgAQ&usg=AFQjCNG-1zi1zM2SPIpvouRHiJtpQ95I_A&sig2=0iY1iqyh6OEeQVDTxZk2jw&bvm=bv.56146854,d.Yms

and guess what, all solutions i've listed are just there.



ReallyHosed

  • Newbie
  • *
  • Posts: 20
    • View Profile
Reply #14 on: November 11, 2013, 03:53:00 AM
Fantastic, ostendali, I can't thank you enough!
Best regards,
RH