Author Topic: can't run aircrack suite on HP pavilion dm4  (Read 12800 times)

dexhering

  • Newbie
  • *
  • Posts: 3
    • View Profile
on: May 28, 2013, 12:40:20 AM
Hi
well, just install backbox, and so check if my wireless card it's supported, but when i try to run aircrack suite, don't run
my card is
broadcom BCM94313
so if some one can help me
thanks



b4d_bl0ck

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
Reply #1 on: May 28, 2013, 09:27:22 AM
Hi dexhering,
but when i try to run aircrack suite, don't run
Can you specify what do you mean with this? Can't you perform some attacks or something, or does aircrack-ng not even start? Do you get some errors?

Have fun!

bool secure = check_paranoia() ? true : false;


weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #2 on: May 28, 2013, 01:53:37 PM
Hi dexhering, when you have this kind of problem it's a good idea tell us what you type on command line and what errors are reported... You have also to past your configurations, as used driver and if you patched it and so on....

una voce libera è sempre liberatrice
under_r00t


dexhering

  • Newbie
  • *
  • Posts: 3
    • View Profile
Reply #3 on: May 28, 2013, 06:43:32 PM
hi, well when i try to check which card have say me this:

iwconfig
lo        no wireless extensions.

vmnet8    no wireless extensions.

eth1      IEEE 802.11abg  ESSID:off/any 
          Mode:Managed  Access Point: Not-Associated   Tx-Power=200 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Encryption key:off
          Power Management:off
         
eth0      no wireless extensions.

vmnet1    no wireless extensions.


so check that i have wireless on eth1, then try to run airmon and say me this.


airmon-ng start eth1


Found 5 processes that could cause trouble.
If airodump-ng, aireplay-ng or airtun-ng stops working after
a short period of time, you may want to kill (some of) them!

PID   Name
922   avahi-daemon
923   avahi-daemon
987   NetworkManager
1150   dhclient
1902   wpa_supplicant


Interface   Chipset      Driver

eth1      Unknown    wl - [phy0]mon0: ERROR while obtained interface flags: No such device

            (monitor mode enabled on mon0)

what can i do?
thanks.



weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #4 on: May 28, 2013, 07:10:46 PM
Hi dexhering, I haven't your broadcom card but if I well remember, you have to blacklist wl driver and install the right driver... I'm sure to saw that on aircrack-ng forum. This is what you should find by yourself:
Quote
Broadcom Chipset Comments

Broadcom's “AirForce One” line of chipsets is recently catching up with Atheros in terms of Linux support. The new b43/b43legacy driver in 2.6.24 and up, when patched, can inject at speeds pretty much on par with Atheros. It also handles all attacks nicely, including fragmentation (although the underlying stack, mac80211, requires a patch to inject fragments). Current development versions of the driver can actually reach speeds higher than those possible with Atheros, often up to 700 PPS and over. Multi-VAP operation/concurrent monitor and managed interfaces, similar to the one seen in Madwifi, is also implemented through the underlying mac80211 stack.

Windows, on the other hand, is not supported, except for some older 802.11b-only chipsets.

Like Madwifi, b43 offers no support for Broadcom-based USB devices. For those, a separate driver called rndis_wlan exists, which doesn't support monitor mode (and will never do so, as the chipset has no raw mode). Draft-N devices are also not yet supported.

Users whom use broadcom linux_sta driver (otherwise known as wl) should note that there are no monitor/injection modes with such driver. Broadcom deliberately removed the functionality out of their proprietary binary blob. Read here for more info: http://seclists.org/fulldisclosure/2008/Nov/506. Also b43 supports less than a handful of chipsets, take note on which ones are unsupported and see if yours fall into that category: b43

This is the page [1].


[1] http://tinyurl.com/2qfltb

« Last Edit: May 28, 2013, 07:13:20 PM by weVeg »

una voce libera è sempre liberatrice
under_r00t


dexhering

  • Newbie
  • *
  • Posts: 3
    • View Profile
Reply #5 on: May 28, 2013, 07:20:13 PM
thanks. i check it now.



chacho_2me

  • Newbie
  • *
  • Posts: 1
    • View Profile
Reply #6 on: August 25, 2013, 12:38:33 PM
same problem with me.. looks like i cannot turn on my wifi...

when i try sudo modprobe brcmsmac

i get this error

Error inserting brcmsmac (/lib/modules/3.2.0-43-generic/updates/cw-3.8/brcmsmac.ko): Invalid argument

even tried with other drivers...

i even tried download from ADD DRIVERS usng STA..still nothing

please help

i followed instructions also from this site

http://www.aircrack-ng.org/doku.php?id=compat-wireless

please help

i will try to update/check after few weeks because internet here is scarce... i work on a ship and usually i am at sea

hope to have some help by then

i am new to this distro..turns out i like this.. only i had this issue with wifi(this is my first time, because normal ubuntu can detect and give me correct drivers)


here are my results after using

pastebinit lsusb;lspci;lspci -nn | grep -i net;lspci -k;sudo lshw -C network;lsmod;iwconfig;ifconfig;sudo iwlist scan;uname -r -m;cat /etc/network/interfaces;nm-tool;sudo rfkill list


http://pastebin.com/EwQKJkvi


basically my problem is that there are no wifi turned on in the network notification

« Last Edit: August 25, 2013, 12:45:22 PM by chacho_2me »