Author Topic: ati Radeon X300 extended desktop for ubuntu [SOLVED]  (Read 10681 times)

darknight

  • Newbie
  • *
  • Posts: 14
    • View Profile
I'm having problems finding the correct drivers and figure out how to extend my desktop. Here is my video configuration.  It seems like it's not identifying the DVI part of graphics card.

Please help

I have DVI and VGA.

01:00.0 VGA compatible controller: ATI Technologies Inc RV370 5B60 [Radeon X300 (PCIE)] (prog-if 00 [VGA controller])
   Subsystem: ATI Technologies Inc Device 0302
   Flags: bus master, fast devsel, latency 0, IRQ 43
   Memory at d0000000 (32-bit, prefetchable) [size=128M]
   I/O ports at dc00 [size=256]
   Memory at dfde0000 (32-bit, non-prefetchable) [size=64K]
   Expansion ROM at dfe00000 [disabled] [size=128K]
   Capabilities: [50] Power Management version 2
   Capabilities: [58] Express Endpoint, MSI 00
   Capabilities: [80] MSI: Enable+ Count=1/1 Maskable- 64bit+
   Capabilities: [100] Advanced Error Reporting
   Kernel driver in use: radeon
   Kernel modules: radeon, radeonfb

01:00.1 Display controller: ATI Technologies Inc RV370 [Radeon X300SE]
   Subsystem: ATI Technologies Inc Device 0303
   Flags: bus master, fast devsel, latency 0
   Memory at dfdf0000 (32-bit, non-prefetchable) [size=64K]
   Capabilities: [50] Power Management version 2
   Capabilities: [58] Express Endpoint, MSI 00


« Last Edit: July 19, 2012, 03:44:39 PM by admin »



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #1 on: July 15, 2012, 10:18:48 PM
Hi,

You want to use 2 monitors ? If not, just use VGA and all is ok. If not go to system settings menu and you can set if you want to use 2 monitors.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


darknight

  • Newbie
  • *
  • Posts: 14
    • View Profile
Reply #2 on: July 16, 2012, 01:32:10 AM
Hi,

You want to use 2 monitors ? If not, just use VGA and all is ok. If not go to system settings menu and you can set if you want to use 2 monitors.

Yes I want to use 2 monitors. My X300 card has dvi and vga ports. I tried to go to display in the gui and there is no selection for extending the desktop. So I figured I would need to edit the xorg.conf which I can't find. I tried checking /etc/xorg.conf and its not there.

Yes I went to system settings/Display and I see both monitors but they are mirrored and there isn't an option to extend the desktop.
« Last Edit: July 16, 2012, 01:42:45 AM by darknight »



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #3 on: July 16, 2012, 01:53:36 AM
Hi,

What's the output of:
Code: [Select]
xrandrThat will tell us how your monitor(s) are detected and what resolutions are supported.

P.S. Try to run xrandr --auto, then go to Settings>Settings Manager >Display . Working with some cards.
« Last Edit: July 16, 2012, 01:59:47 AM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


darknight

  • Newbie
  • *
  • Posts: 14
    • View Profile
Reply #4 on: July 16, 2012, 02:52:38 AM
Ok I will try that see if it works. Thank you

VGA-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024      60.0 +   75.0*
   1152x864       75.0 
   1024x768       75.1     60.0 
   800x600        75.0     60.3 
   640x480        75.0     60.0 
   720x400        70.1 
DVI-0 connected 1280x1024+0+0 (normal left inverted right x axis y axis) 376mm x 301mm
   1280x1024      60.0 +   75.0*
   1152x864       75.0 
   1024x768       75.1     60.0 
   800x600        75.0     60.3 
   640x480        75.0     60.0 
   720x400        70.1 



darknight

  • Newbie
  • *
  • Posts: 14
    • View Profile
Reply #5 on: July 16, 2012, 03:25:48 AM
Still getting the same result. When I go to system settings, Display. I see 2 monitors and my only options are "use this output"
Resolution
refresh rate
rotation= normal
reflection= none



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #6 on: July 16, 2012, 04:51:03 AM
Ok before we do something "hard" try with this tool.

Code: [Select]
sudo -i
apt-get install arandr

Then go to Settings>Arandr. If you see 2 monitors just set resolutions. If you don't see, click on Layout and add 2nd monitor.

After this ...more solutions possible, but try this easy way.

1.Arandr in Backbox menu :


2.Setting resolutions


3.Setting monitor orientation





P.S. Did you try to check "Use this output" for both monitors ?
P.S-2. Run in terminal xrandr --output VGA-0  --left-of DVI-0 ! If ok, we will add this to system boot ...i will say you how.
« Last Edit: July 16, 2012, 05:18:03 AM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


darknight

  • Newbie
  • *
  • Posts: 14
    • View Profile
Reply #7 on: July 16, 2012, 04:04:20 PM
Thank you ZEROF.

No I haven't run it yet. It would really help if I can extend the destkop so I can work in both windows.



darknight

  • Newbie
  • *
  • Posts: 14
    • View Profile
Reply #8 on: July 16, 2012, 10:53:03 PM
getting the follow error "xrandr: cannot find crtc for output DVI-0"



darknight

  • Newbie
  • *
  • Posts: 14
    • View Profile
Reply #9 on: July 16, 2012, 10:56:00 PM
I got it thx for your help.

xrandr --output DVI-0 --auto



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #10 on: July 17, 2012, 04:37:29 AM
Nice, now you need to set startup ...Go to Settings>Settings Manager > Session and Startup >Application Startup.

1.Clic on Add
2.New wilndow will pop-up
3.You need to set 3 fields, check photo



In command field set xrandr --output DVI-0 --auto .


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


darknight

  • Newbie
  • *
  • Posts: 14
    • View Profile
Reply #11 on: July 17, 2012, 11:00:48 PM
Do I need to put in the command field to turn off S-video each time?

xrandr --output S-video --off



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #12 on: July 18, 2012, 05:47:24 AM
If you try you will see, no ? I like to help but don't ask stupid question bro.

Cheers!


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


darknight

  • Newbie
  • *
  • Posts: 14
    • View Profile
Reply #13 on: July 18, 2012, 05:48:41 PM
I would say it's stupid question. When restart my system I have do few things listed below.

1) fire up xrandr which is given.
2) move the DVI input on right side of xrandr box but when I hit apply I get the follow error. "xrandr: cannot find crtc for output DVI-0"
3) I open terminal and disable s-video with this command xrandr --output S-video --off.
4) go back to xrandr and select apply and now extended desktop is turned on.

The problem I'm facing is how do I disable S-video on startup. I mean I can disable S-video port in /etc/X11/xorg.conf but I can't ever track it in Ubuntu.



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #14 on: July 18, 2012, 07:59:40 PM
Hi,

Ok, then do the same add this command to Session and Startup. That need to look something like :

xrandr --output S-video --off
xrandr --output DVI-0 --auto

Or try this : http://www.anonimus.re.rs/6521
« Last Edit: July 18, 2012, 08:05:59 PM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*