Author Topic: asus eeepc 1215p [SOLVED]  (Read 8132 times)

exzR

  • Newbie
  • *
  • Posts: 18
    • View Profile
on: May 18, 2011, 10:43:55 PM
salve a tutti sono nuovo del forum e anche di backbox :D... vi pongo il mio problema, l'installazione e' andata a buon fine pero' backbox non mi vede nessuna scheda di rete.. ne ethernet ne' wireless...

con lspci | grep Network mi mostra la AR812 (ho provato a seguire http://forum.backbox.org/software-support/ar8152-v1-1-fast-ethernet/ ma mi dice no kernel version found)

e quindi non so come comportarmi visto che non riesco a collegarmi a internet...

se avete qualche consiglio e' molto gradito...

ciao a tutti :)
« Last Edit: June 04, 2011, 12:12:08 PM by SYSTEM_OVERIDE »



exzR

  • Newbie
  • *
  • Posts: 18
    • View Profile
Reply #1 on: May 19, 2011, 10:25:49 AM
ho messo il kernel con

dpkgi -i linux-image-2.6.37 e ora vede la ethernet :D


rimane solo il wireless non funzionante...che sfortunatamente con gli hardware driver provo a installare ma da un errore (su ubuntu lo sistemavo installando quei driver)...


nessuno sa aiutarmi?
« Last Edit: May 19, 2011, 11:02:20 AM by exzR »



exzR

  • Newbie
  • *
  • Posts: 18
    • View Profile
Reply #2 on: May 19, 2011, 02:31:05 PM
aime' con gran rammarico abbandonero' backbox finche' non si trovera' una soluzione per il wireless..



vincenzo

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Reply #3 on: May 19, 2011, 03:04:16 PM
Ciao, mi dispiace non poterti aiutare per il tuo specifico problema. Cercando sul wiki ufficiale di ubuntu ho trovato questa pagina: https://wiki.ubuntu.com/HardwareSupport/Machines/Netbooks#Asus Eee PC 1215P
Come vedi si fa esplicito riferimento al tuo portatile e tutto pare funzionare con Ubuntu 10.10 e Ubuntu 11.04. Ora, Backbox è basata su Ubuntu 10.04 come saprai e sul wiki non ho trovato indicazioni a riguardo. Raffaele e gli altri sono già a lavoro sulla prossima release di Backbox che sarà basata sulla 11.04, potrà quindi offrire un supporto hardware ancora migliore, ma nel frattempo ti consiglio di dare un'occhiata a qualche pacchetto nei repository delle release più recenti di ubuntu o un PPA da aggiungere al repository ufficiale.

Qui per esempio qualcuno ha aggiunto dei repo non-free per debian e ha risolto:
http://forum.eeepc.it/viewtopic.php?id=12567

PS: sui forum Eee PC è molto probabile che troverai persone che hanno risolto problemi relativi al tuo modello.
« Last Edit: May 19, 2011, 03:36:14 PM by vincenzo »

You cannot teach a man anything. You can only help him discover it within himself.




exzR

  • Newbie
  • *
  • Posts: 18
    • View Profile
Reply #4 on: May 20, 2011, 11:06:33 AM
ho provato ma non vanno i comandi ne i repo non-free (mi sa che vi vuole la pub key) cmq installando wicd per esempio ho visto che mi da' l'errore:
Bad return status for module build on kernel: 2.6.37-02063706-generic (i686)...su bcmwl-kernel-source

non vorrei aver scelto un kernel sbagliato anche se i file che ho scaricato e installato in questo ordine sono:

linux-headers-2.6.37-02063706_2.6.37-02063706.201103281005_all.deb (10 MB)

linux-headers-2.6.37-02063706-generic_2.6.37-02063706.201103281005_i386.deb (767 KB)

linux-image-2.6.37-02063706-generic_2.6.37-02063706.201103281005_i386.deb (33 MB)

installati in questo ordine (con sudo dpkg -i etc) e da nome sembrano per i386 non i686.. boh non sto capendo so solo che non riesco a sistemare il wireless che con ubuntu sistemavo installando i driver broadcom dall' "hardware driver" che su backbox mi da' errore SystemError:installArchives() failed....


purtroppo se non aggiorno il kernel all'inizio non legge neanche il wired e quindi scaricare qualsiasi cosa risulta impossibile... se riusciste a consigliarmi un kernel corretto e/o segnalarmi magari qualche errore che faccio ve ne sarei grato :)

spero di trovare una soluzione perche noto che backbox non e' per niente male anzi! e con un dual core e' veramente veloce e snella



ps: si sa gia quando uscira' la nuova versione di backbox??
« Last Edit: May 20, 2011, 11:51:50 AM by exzR »



vincenzo

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Reply #5 on: May 20, 2011, 04:44:23 PM
Ti consiglio di abilitare i repo di backports in synaptic, ora che ethernet funziona potresti trovare lì i drivers wireless per la tua scheda. Non avventurarti troppo nell'installazione manuale di pacchetti.
Prendendo spunto da altri post nel forum, potresti provare con:
http://wiki.backbox.org/Customization.html#How_to_install_compat-wireless_aircrack_patches

oppure, se non avessi installato il kernel 2.6.37 ti avrei consigliato di restare con la versione 2.6.32-31-generic per i686 e provare con qualche modulo nelle backports di Ubuntu Lucid. Qualcosa come:
linux-backports-modules-compat-wireless-2.6.38-2.6.32-31-generic, vedi: http://packages.ubuntu.com/lucid-updates/allpackages

Ma questo è un tentativo alla cieca che francamente non mi piace molto consigliare. Visita anche i forum del sito del produttore e posta il tuo problema.

Per informazioni sul supporto di ubuntu alla tua scheda dai anche un'occhiata qui:
https://help.ubuntu.com/community/HardwareSupportComponentsWireless

Di solito i moduli compat-wireless nelle backports forniscono drivers aggiornati, ma ripeto, non avventurarti troppo con l'installazione manuale perchè qualcosa puo' anche andare bene, ma rischieresti di ritrovarti con un sistema inutilizzabile.

Per la prossima versione di Backbox la roadmap prevede l'uscita in settembre, so che sono a lavoro in vista di una Release Candidate. Spero di essere stato d'aiuto.
« Last Edit: May 21, 2011, 06:40:10 PM by vincenzo »

You cannot teach a man anything. You can only help him discover it within himself.




exzR

  • Newbie
  • *
  • Posts: 18
    • View Profile
Reply #6 on: May 23, 2011, 11:46:30 AM
ciao vincenzo,
guarda ho sistemato installando la versione amd64 che non da problemi con l'installazione dei restricted drivers infatti ora la wireless funziona... ora devo solo aggiornare il kernel cosi da poter far funzionare anche l'ethernet :)

appena torno sull altro pc posto un link che ho trovato in cui spiegano che c'e' un problema sul i386 per l'installazione delle brcm43xx anche se il loro metodo a me non ha funzionato...

a presto :)



vincenzo

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Reply #7 on: May 23, 2011, 12:38:24 PM
Ciao! E' una buona notizia se funziona, ma hai provato anche con il metodo descritto nel wiki per i compat-wireless? Non per altro, sembra un modo più "limpido". Se ho capito bene poi ti ritroverai dei binari per amd64, i686, i386 tutti sulla stessa macchina. Codici macchina per architetture diverse possono essere vere miscele esplosive. :P Comunque è ottima l'idea di postare un link sulle brcm43xx , puo' essere d'aiuto per qualcuno che abbia stessi dubbi e problemi.

PS: i pacchetti più aggiornati li trovi qui:
      http://linuxwireless.org/download/compat-wireless-2.6/
« Last Edit: May 23, 2011, 12:53:50 PM by vincenzo »

You cannot teach a man anything. You can only help him discover it within himself.




exzR

  • Newbie
  • *
  • Posts: 18
    • View Profile
Reply #8 on: May 24, 2011, 10:49:37 PM
ciao,
il link che ti dicevo e' questo: http://polach.cc/howto-fix-broadcom-wifi-adapter-wpa-network-access-on-ubuntu-10-04-lucid-lynx

ora sto provando a rimettere la i386 per vedere se funziona in qualche modo :)

comunque il kernel lo devo aggiornare per forza altrimenti non va nemmeno l'ethernet...

ti sapro' dire :)


ps: dici che e' meglio se tengo la 64 bit o la 32? perche avevo sentito che la 64 in generale di ubuntu avesse qualche problema e anche incompatibilita'...
« Last Edit: May 24, 2011, 10:56:28 PM by exzR »



exzR

  • Newbie
  • *
  • Posts: 18
    • View Profile
Reply #9 on: May 24, 2011, 11:27:53 PM
niente continua a darmi error bad return status... niente vorra' dire che usero' la 64bit attendendo una conferma che funziona bene quella versione :)...



vincenzo

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Reply #10 on: May 25, 2011, 11:39:28 AM
Credimi è la prima volta che sento della necessità di installare drivers a 64bit per sistema operativo a 32bit. :-) Se si verifica questo il problema secondo me è a monte.. c'è qualcosa di sbagliato, e da qui non posso sapere cosa, che sicuramente non dipende solo dal driver in sè. I drivers sono strettamente legati all'hardware e al sistema operativo e non troverai mai un driver a 64bit nei repository (o altrove) di un sistema a 32bit o viceversa. Se tu dici che funziona probabilmente è un puro caso, ma non si puo' escludere che questo ti dia altri problemi in seguito: instabilità, surriscaldamento, danni alla periferica in questione. Se fossi nella tua situazione proverei altre strade, alcune te le ho proposte, ma vedo che continui a ignorarle. ;-) Non posso fare altro da qui, mi spiace!
« Last Edit: May 25, 2011, 11:42:40 AM by vincenzo »

You cannot teach a man anything. You can only help him discover it within himself.




exzR

  • Newbie
  • *
  • Posts: 18
    • View Profile
Reply #11 on: May 25, 2011, 12:32:43 PM
ciao vincenzo,
intendevo se e' meglio usare la versione di back 64bit o da problemi e quindi usare la 32 :) cmq dopo una settimana di test e giri per internet mettendo insieme piu' e piu' pezzi trovati in vari forum ho trovato una soluzione.. l ho provata con backtrack 5 su backbox devo ancora provare comunque ho creato una piccola guida con un all inclusive anche per eventuali errori che io ad esempio ho riscontrato.. spero sara' utile :) a presto


l'installazione con jockey-gtk mi dava errore per cui procediamo con l'installazione manuale dei driver...


premessa aver installato patch e gcc con apt-get install patch gcc e usare comandi come root

vai su Broadcom.com - 802.11 Linux STA driver(http://www.broadcom.com/support/802.11/linux_sta.php)

Scarica la versione corretta (i386 o 64) e il file patch (esempio 5_100_82_38.patch)

da console:

/etc/init.d/networking start
tar xzf file.tar.gz
se necessario entra nella cartella appena creata
make clean
make


se ricevi un messaggio tipo:



KBUILD_NOPEDANTIC=1 make -C /lib/modules/`uname -r`/build M=`pwd`
make[1]: Entering directory `/usr/src/linux-source-2.6.34'

  WARNING: Symbol version dump /usr/src/linux-source-2.6.34/Module.symvers
           is missing; modules will have no dependencies and modversions.
 LD      /root/hybrid-wl/built-in.o
  CC [M]  /root/hybrid-wl/src/shared/linux_osl.o
  CC [M]  /root/hybrid-wl/src/wl/sys/wl_linux.o
/root/hybrid-wl/src/wl/sys/wl_linux.c: In function ‘_wl_set_multicast_list’:
/root/hybrid-wl/src/wl/sys/wl_linux.c:1451: warning: assignment from incompatible

pointer type
 /root/hybrid-wl/src/wl/sys/wl_linux.c:1451: error: ‘struct netdev_hw_addr’ has no

member named ‘next’
make[2]: *** [/root/hybrid-wl/src/wl/sys/wl_linux.o] Error 1
make[1]: *** [_module_/root/hybrid-wl] Error 2
make[1]: Leaving directory `/usr/src/linux-source-2.6.34'
make: *** [all] Error 2








applicare il file patch con il comando (se non dovessi riscontrare errori salta questa parte):

portarsi nella cartella estratta (devi vedere con ls le cartelle src, lib, etc)
patch -p0 < 5_100_82_38.patch
make



controlliamo eventuali conflitti con:

lsmod  | grep "b43\|ssb\|wl"

se alcuni fossero installati andiamo a rimuoverli..

rmmod b43
rmmod ssb
rmmod wl


e ora per ultimo sempre da shell:

modprobe lib80211
insmod wl.ko

perfetto ora la wlan e' funzionante (ifconfig -a mostrera' l'interfaccia)

Nel caso in cui la wlan fosse rilevata ma dando il comando ifconfig wlan0 up desse l'errore


SIOCSSIFFLAGS: Unknown error 132

dare i comandi:

rmmod ath5k
rfkill block all
rfkill unblock all
modprobe ath5k
rfkill unblock all
ifconfig wlan0 up

e tutto funzionera' a dovere.

Rimane solo da caricare i moduli e l'insmod all'avvio (altrimenti quando riavviate il pc la wlan non funziona)

con:

nano /etc/modules

aggiungete "lib80211" senza i "

ora copiate il wl.ko in una cartella es /home/utente e modificate il file /etc/rc.local aggiungendo una riga con:

insmod percorso/wl.ko

ora al riavvio funziona tutto

ciao a tutti :)
« Last Edit: May 25, 2011, 11:06:06 PM by exzR »



vincenzo

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Reply #12 on: May 25, 2011, 04:37:11 PM
Oops, l'equivoco sui 32/64 bit è nato dal fatto che siamo partiti da 386 per poi passare a i686 e amd64, ma a un certo punto ho perso di vista il soggetto: cpu, kernel o drivers? :) ragazzi purtroppo l'assistenza hardware è un problema farla a distanza, come avete visto bisogna sperimentare, sbagliare e riprovare in certi casi. Chiunque abbia un problema simile perfavore si diano i dettagli del proprio hardware e dei passi che si stanno seguendo, perchè quando si tratta di installare kernel, moduli e drivers è fondamentale conoscere versione dei pacchetti e macchina target.. ciao!
« Last Edit: May 25, 2011, 04:42:20 PM by vincenzo »

You cannot teach a man anything. You can only help him discover it within himself.




exzR

  • Newbie
  • *
  • Posts: 18
    • View Profile
Reply #13 on: May 25, 2011, 09:47:23 PM
mi sa che non ci siamo capiti bene va beh comunque non ho capito la riposta.. ho un processore a 64 bit se uso backbox a 64bit va bene o e' "instabile/da problemi di incompatibilita'" o e' meglio usare comunque la versione a 32bit? intendo proprio di distro non di driver.



Comunico che con backbox i386 la wireless e la rete ethernet funzionano usando la guida che ho scritto sopra e mettendo il kernel 2.6.37

ciaooo

« Last Edit: May 25, 2011, 11:07:00 PM by exzR »



vincenzo

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Reply #14 on: May 26, 2011, 02:30:01 PM
Non so darti una risposta precisa, certo è che l'impegno di tutti dovrebbe essere di migrare completamente al mondo dei 64-bit. Ho sentito tante lamentele, specie in passato, sulla mancata disponibilità di alcuni applicativi, plugins dei browsers, codecs per le versioni a 64-bit. Ma è tutto in veloce sviluppo e non so a che punto si è arrivati con la compatibilità/stabilità. Personalmente sono molto legato ai 32-bit e se ho esigenze di indirizzare più ram installo kernel in versione PAE.

Ci sono però dei dettagli tecnici di cui non tutti sono al corrente. L'indirizzamento in memoria a 64-bit necessita di maggiori blocchi di allocazione nella memoria stessa, principalmente per il fatto che i puntatori stessi e gli spazi per l'allineamento sono più grandi. Quindi se è vero che i 64bit ti permettono di vedere più memoria è vero anche che ti costringono a usarne di più: questo puo' però influenzare le performance sia della cache della cpu che della batteria stessa di un portatile (per esempio) e non solo... ci sono anche altri aspetti su cui è meglio non dilungarsi.

So che hai risolto, ma se puo' ancora esserti utile, una volta che funziona almeno ethernet potresti provare ad aggiornarti allo stesso kernel di ubuntu 11.04:

sudo add-apt-repository ppa:kernel-ppa/ppa
sudo apt-get update
sudo apt-get install linux-headers-2.6.38-8-generic linux-image-2.6.38-8-generic

e aggiornare grub (se non lo fa automaticamente): sudo update-grub

Ora i broadcom sono built-in nel kernel a partire proprio dalla versione 2.6.37.. ma forse con l'installazione della 2.6.38 non avresti avuto la necessità di tutti quei passi. Ma qui parlo con la mia sfera di cristallo fra le mani  :P ciao

You cannot teach a man anything. You can only help him discover it within himself.