Author Topic: Unable to load GUI after login  (Read 6126 times)

CrypticDNA

  • Newbie
  • *
  • Posts: 3
    • View Profile
on: October 03, 2013, 04:48:10 AM
Hi there! I recently installed Backbox 3.09 64 bit version. After login i'm having trouble loading the GUI.

Output of startx command:

FATAL: Module fglrx_experimental_13 not found
FATAL: Module fglrx_experimental_13 not found

FATAL Server error
no screens found
Server terminated with error

I also tried installing Graphics Driver however i was not able to install it. I was getting Unable to install dpkg-dev please try to install manually.




ZEROF

  • Hero Member
  • *****
  • Posts: 1244
    • View Profile
    • Pen Tester
Reply #1 on: October 03, 2013, 01:50:22 PM
Hello,

Remove your graphic card, boot your pc and install drivers after. From kernel 3.5,i think so, support for some nvida drivers were removed. If this don't work, or you mother board have nvidia standard chipset, boot in text mode, run update then install last nvidia drivers.

Have fun !


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


CrypticDNA

  • Newbie
  • *
  • Posts: 3
    • View Profile
Reply #2 on: October 03, 2013, 02:14:07 PM
Thanks for your reply. I'm having AMD Raedon HD Graphics. I had no trouble while testing the live CD version. It worked prefect. Only after installing i'm having this problem.



77ABR77

  • Newbie
  • *
  • Posts: 1
    • View Profile
Reply #3 on: October 07, 2013, 09:58:29 PM
This has also happened to me.

I've recently installed BackBox, and it was making my computer running really hot, so I did some research, I found (to my knowledge) that BackBox was using my processor for graphics, so I tried installing drivers for my AMD Radeon graphics card, none of which worked (only did the non beta experimental ones)

Then tried going to AMD and trying to find it, downloaded it, and then it tried to open up in geany (which it never fully opened), I gave up and shutdown. Next time trying to running in BackBox, I get the No screen, error described above.
(not sure on the "FATAL: Module fglrx_experimental_13 not found", but everything else is the same)
 
« Last Edit: October 07, 2013, 10:00:04 PM by 77ABR77 »



TH3CR4CK3R

  • Newbie
  • *
  • Posts: 13
    • View Profile
Reply #4 on: October 08, 2013, 11:14:23 PM
If you install AMD drivers and boot to a blank screen here is the fix.

reboot and select the recovery mode to boot into. then CD to /etc/X11 and remove xorg.conf and reboot.

this will allow you to boot normally again using the standard drivers, then uninstall fglrx drivers.



CrypticDNA

  • Newbie
  • *
  • Posts: 3
    • View Profile
Reply #5 on: October 09, 2013, 04:19:57 PM
Thanks that pretty much worked for me :)

I have few doubts if you could clarify, that would be very kind of you.

When Additional Drivers is opened (BB menu=>settings=>additional drivers) it says, Driver is active but not currently in use. http://i.imgur.com/EfdV1ZQ.png

And also I've got 2 new listings under backbox settings menu
1. AMD Catalyst control centre
2. AMD Catalyst control centre(Administrative)

When I open AMD Catalyst control centre i get some kind of error dialogue box popping out. Please follow this link to see the error message. http://i.imgur.com/Tis5CXS.png

When I click on  AMD Catalyst control centre(Administrative) nothing happens.

So has graphics driver properly installed and configured ?

P.S Output of aticonfig: aticonfig: No supported adapters detected
« Last Edit: October 09, 2013, 04:32:09 PM by CrypticDNA »



TH3CR4CK3R

  • Newbie
  • *
  • Posts: 13
    • View Profile
Reply #6 on: October 10, 2013, 10:47:56 PM
It sounds like it is not installed correctly. I dont use the "available drivers" option to install them. I download it from the AMD website and install manually.

http://support.amd.com/en-us/download