Author Topic: Problema Montaggio Partizione - NTFS e XFCE  (Read 1967 times)

overmind

  • Newbie
  • *
  • Posts: 8
    • View Profile
on: June 07, 2011, 11:55:09 PM
Salve a tutti,

credo ci sia un problema che affligge l'interface grafico XFCE, ovvero quello di non permettere all'user di leggere/scrivere su partizioni NTFS.

Ho provato a risolvere il problema analizzando in primis i tabulati riguardanti i filesystems delle partizioni presenti sull'HD con il comando
Code: [Select]
cat /etc/fstab
successivamente, ho controllato le varie partizioni eseguendo
Code: [Select]
fdisk -l
dopodichè
Code: [Select]
mount -t ntfs /dev/hda1 /mnt/ntfsper montare la partizione che serviva. Ma il problema rimane comunque.

Ho provato anche ad installare i driver ntfs-3g , ma a quanto pare è un problema che affligge quasi tutti gli utenti che adottano come interface XFCE. Ovviamente, il problema è stato risolto passando a GNOME.

Non son riuscito a trovare una soluzione, pertanto credo sia una buona cosa pensare ad un cambiamento nella prossima relase, per ovviare a questo problema.

Chiaramente, eventuali procedure proposte saranno ben accette.



vincenzo

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Reply #1 on: June 08, 2011, 03:25:47 AM
Quote
credo ci sia un problema che affligge l'interface grafico XFCE, ovvero quello di non permettere all'user di leggere/scrivere su partizioni NTFS.

Ciao, qui non capisco cosa intendi. Una volta montate come "root" certo che si puo' leggere/scrivere su partizioni NTFS, a meno che non si sia esplicitamente negato l'accesso a un gruppo di utenti. Ho un'installazione fresca e minimale di Backbox, collego il mio hardisk esterno con filesystem NTFS e tutto funziona. Vedo anche l'icona sul desktop. Per la partizione Windows stessa cosa, la posso montare con "sudo mount.." e poi è visibile anche agli altri utenti e posso creare, modificare e salvare al volo dei files. Se vuoi ritrovare montata la tua partizione all'avvio puoi per esempio aggiungere questa riga al file "/etc/fstab":

Code: [Select]
/dev/hda1   /media/ntfs  ntfs  rw,locale=it_IT.UTF-8,users
dopo aver ovviamente creato la cartella con "sudo mkdir /media/ntfs". Per delle informazioni aggiornate dinamicamente sullo stato e le dimensioni dei filesystem montati ti consiglio comunque di usare i comandi:

Code: [Select]
cat /etc/mtab
df -ah

in quanto "/etc/fstab" è un file di configurazione affidato all'amministratore di sistema, non ti dà informazioni in tempo reale.



« Last Edit: June 10, 2011, 02:33:55 PM by vincenzo »

You cannot teach a man anything. You can only help him discover it within himself.




overmind

  • Newbie
  • *
  • Posts: 8
    • View Profile
Reply #2 on: June 08, 2011, 09:56:48 AM
Proverò con la prossima installazione di BB.

Ma il tutto è molto strano, poichè le operazioni che ho effettuato sono state tutte da root; solo che non riesco a spiegarmi il perchè non mi leggeva neanche la partizione di Win installata! (cosa che non accade con Ubuntu)

Ti ringrazio per il consiglio sui comandi, appena possibile proverò a risolvere il problema aggiungendo la riga al file "/etc/fstab";

grazie!



vincenzo

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Reply #3 on: June 10, 2011, 02:30:35 PM
Se la tua partizione non ne vuole sapere di essere montata è anche probabile che sia diventata "flushed", come dicono nella documentazione di Ubuntu, cioè che la tabella dei clusters ha bisogno di un aggiornamento. Questo accade spesso quando Windows termina in modo anomalo, oppure smontiamo prematuramente la partizione, non lasciando il tempo di "assestamento" del filesystem. La soluzione spesso consiste semplicemente nell'avviare Windows e terminare correttamente la sessione, con le partizioni NTFS tutte connesse. Ma nel caso non dovesse bastare, usa il tool "ntfsfix" che si trova nel pacchetto "ntfsprogs":

Code: [Select]
sudo ntfsfix /dev/hda1
« Last Edit: June 12, 2011, 05:56:45 PM by vincenzo »

You cannot teach a man anything. You can only help him discover it within himself.