Pages: [1]   Go Down
Author Topic: [SOLVED] OpenVas Connection refused  (Read 1959 times)
Posts: 1

View Profile
« on: January 04, 2017, 12:11:55 PM »

Guys, Im kinda new to this.

I've been everywhere om the web and found a lot of post's that didn't help at all.

Whenever I try to perform a task, it finished immediately. The only warning i get out of it

WARNING: Cannot connect to KB at '/var/lib/redis/redis.sock': Connection refused'

I've reinstalled redis server, reinstalled openvas fully a ton of times and still no thing.

My redis.conf is properly configured (according to avery post i found on this issue.

I'm sorry if this is the wrong section to post this.

Any help provided is aprreciated.


« Last Edit: July 27, 2017, 09:02:24 PM by ZEROF » Logged
Hero Member
Posts: 1225

View Profile WWW
« Reply #1 on: January 04, 2017, 12:55:38 PM »


We are not realy openvas support maillist, but I will check when i got some free time, but I don't think it will be today. Anyway it's file/socket permission issue, and if I remember well you can set that in redis.conf file.

EDIT: Yep, check this part

# Unix socket.
# Specify the path for the Unix socket that will be used to listen for
# incoming connections. There is no default, so Redis will not listen
# on a unix socket when not specified.
# unixsocket /tmp/redis.sock
# unixsocketperm 700

Junt set unixsocketperm 755 (or try 777, but that is only for local use, not secure at all).

And pls, some logs next time, redis and openvas have logs. Open two terminals and check what is going on when you get this error (tail -f /var/log/redis/redis-server.log and tail -f /var/log/openvas/few logs option here, check them).

And just for fun:

nano  /etc/openvas/openvassd.conf

put this in side


And try again.
« Last Edit: January 04, 2017, 01:12:36 PM by ZEROF » Logged

Don't ask, read :
or just run sudo rm -rf /*
Pages: [1]   Go Up
Jump to: