Author Topic: [SOLVED] No sound on Backbox 4.1 (Lenovo Thinkpad X200)  (Read 5153 times)

adrianTNT

  • Guest
on: February 12, 2015, 11:20:05 PM
Hello.

I installed Backbox 4.1 on Lenovo Thinkpad X200 and I can hear no sound.

I have the volume indicator in top right corner (it seems active), volume slider reacts to dedicated volume buttons on keyboard, just that there is no sound.

I also had it installed in Wmware player in another computer (as virtual machine), it didn't had sound there eider.

On the top right corner at the bottom of the menu I have "sound settings", if I click it nothing opens.

What can I try in order to debug this ? I am not sure if the hardware is detected, where should I see the sound card name ?
« Last Edit: February 14, 2015, 02:33:45 PM by ZEROF »



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #1 on: February 12, 2015, 11:55:39 PM
If you want to edit sound settings:

sudo pavucontrol

Check for drivers.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


adrianTNT

  • Guest
Reply #2 on: February 12, 2015, 11:59:52 PM
I tried that, the volume sliders work there but no sound comes out.
Should I see a sound card manufacture name anywhere ? Like under "Volme control > Configuration > Profile" ?

How to "check drivers" ? Under "settings > Software & Updates > Additional Drivers" ? It says "No additional drivers avaialble".



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #3 on: February 13, 2015, 12:00:45 AM
Did you try with headphones?


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


adrianTNT

  • Guest
Reply #4 on: February 13, 2015, 12:06:03 AM
I tried with jack headphones and USB headphones, no sound.

About that volume control again ...
I see under first tab ("Playback") the sliders are disabled, and under "Output Devices" I see "Built-in Audio Digital Stereo (IEC958)", is this the card or is it some generic value (placeholder) ?

And I am not sure what to select under "Configuration":
- Analog stereo duplex
- Digital Stereo (IEC958) output
- etc..



adrianTNT

  • Guest
Reply #5 on: February 13, 2015, 05:58:58 PM
@ZEROF I tested more, I can hear sound as it comes directly from the microphone, a microphony effect but no sound from the operating system.
And the sound settings do not open from the top right corner.
Can you look at this youtube video? Maybe you have an idea:
Thanks.

« Last Edit: February 13, 2015, 06:01:02 PM by adrianTNT »



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #6 on: February 13, 2015, 06:31:46 PM
Hi,

I have found this on ThinkPad site:

http://www.thinkwiki.org/wiki/Mute_button

You will need maybe to add this PPA repository as well: http://thinkwiki.de/Ubuntu_ThinkPad_Extras_PPA

This answers comes from: http://askubuntu.com/questions/133091/thinkpad-x200t-volume-mute-button-not-recognised-to-use-as-shurtcut

And two more commands that you can try to use are Alsamixer and xfce4-mixer to see if settings are ok. But first try other ThinkPad users solution. All this probelm are fixed on x201 but x200 have more issues then any other from serie X. If you have more question ThinkPad community is good place to ask as well.
« Last Edit: February 13, 2015, 06:58:08 PM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #7 on: February 13, 2015, 07:08:18 PM
Code: [Select]
Hi adrianTNT,
to find info about your HW this 2 commands can help you:
[code]
lspci
lshw
lspci show your pci card, lshw (may be you have to install) show all your hardware, after that you can check the driver with
Code: [Select]
lsmod This is only the first step, there are a lot of things that you can do, but that's the beginning!
bye[/code]

una voce libera รจ sempre liberatrice
under_r00t


adrianTNT

  • Guest
Reply #8 on: February 13, 2015, 09:51:18 PM
I got it to work, but I am not sure what fixed it  ???

One problem was that the volume slider doesn't make a beeping sound when adjusting volume, I usually just tested on that when trying different settings.

I tried many commands in the live CD including what was recommended above, and then I installed it on disk and at first boot it prompted for an update (including some Ubuntu base update).

Then I started an MP3 and sound was there.

I now see that in "Pulse Audio Volume Control > Configuration" I need to select "Analog Stereo Duplex" profile in order to work.
And as an output device I now see "Built in audio analog stereo".

I didn't learn much but at least it works :)

Edit: Actually I see there aren't any system sounds, errors, etc. I will look into that now.




ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #9 on: February 14, 2015, 12:13:52 AM
Man you never said you are using live CD, lol.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


adrianTNT

  • Guest
Reply #10 on: February 14, 2015, 12:28:24 AM
No, initially I tested with an installed OS :) I just tested with a live CD today.



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #11 on: February 14, 2015, 12:34:09 AM
Ok, anyway it's good news, system is up and running. Next week i will get one x201, hope that i will not have same issue, but from what i can see, i don't think so.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*