Author Topic: [SOLVED] msfupdate - parse error for armitage  (Read 5173 times)

cmurmann

  • Newbie
  • *
  • Posts: 2
    • View Profile
on: June 19, 2015, 03:01:54 AM
Hello,

After I updated to the latest msf I'm getting parse error for armitage. anyone else?

« Last Edit: November 19, 2015, 12:34:41 PM by ZEROF »



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #1 on: June 20, 2015, 09:10:25 PM
Yep,

Armitage is working on this issue, but it's not fixed yet. Check git for it but it started 2 weeks before, if I'm remember well.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


cmurmann

  • Newbie
  • *
  • Posts: 2
    • View Profile
Reply #2 on: June 22, 2015, 05:58:07 AM
Thanks, just restored to previous state.

Regards,



PhutureX

  • Newbie
  • *
  • Posts: 5
    • View Profile
Reply #3 on: June 23, 2015, 11:25:19 AM
was this the error you got?
dpkg: error processing archive /var/cache/apt/archives/msf_4.9.0+git20131215-0backbox1_all.deb (--unpack):
 trying to overwrite '/usr/bin/msfd', which is also in package metasploit-framework 4.11+git20150327-0backbox1
dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)
Errors were encountered while processing:
 /var/cache/apt/archives/msf_4.9.0+git20131215-0backbox1_all.deb
Updating BackBox console menu ...
E: Sub-process /usr/bin/dpkg returned an error code (1)




ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #4 on: June 23, 2015, 09:51:01 PM
That is not same issue. Run update, then upgrade then dist-upgrade, if something go wrong, apt-get -f install.

P.S. Don't post twice, not needed.
« Last Edit: June 23, 2015, 09:53:25 PM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


xxx600

  • Newbie
  • *
  • Posts: 31
    • View Profile
Reply #5 on: June 24, 2015, 09:51:01 PM
After updating metasploit I have become a problem in armitage

This is a general problem, I do not know


I made video:

https://www.youtube.com/watch?v=P0T4HSlOEsI&feature=youtu.be
« Last Edit: June 24, 2015, 10:33:16 PM by ZEROF »



simonepsp

  • Newbie
  • *
  • Posts: 5
    • View Profile
Reply #6 on: July 13, 2015, 09:28:29 AM
After updating metasploit I have become a problem in armitage

This is a general problem, I do not know


I made video:

https://www.youtube.com/watch?v=P0T4HSlOEsI&feature=youtu.be


same problem here :( I've updated metasploit with apt-get and now armitage can't connect to database
it shows: "org.msgpack.Unpackexception: parse error..."

:\ What can I do?
Thanks



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #7 on: July 14, 2015, 10:55:07 PM


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


simonepsp

  • Newbie
  • *
  • Posts: 5
    • View Profile
Reply #8 on: July 16, 2015, 04:40:03 PM
Check solution in last topic:

https://github.com/rsmudge/armitage/issues/184

Worked, thanks :)
I used this command to install missing msgpack 0.5.12: "sudo gem install msgpack -v 0.5.12"

Hope it helps :)



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #9 on: July 16, 2015, 06:49:50 PM
Yep,

We will push solution to next version.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


xxx600

  • Newbie
  • *
  • Posts: 31
    • View Profile
Reply #10 on: July 22, 2015, 09:25:58 AM
Yep,

We will push solution to next version.


I am Waiting



toadstool

  • Newbie
  • *
  • Posts: 2
    • View Profile
Reply #11 on: July 26, 2015, 01:26:29 AM
Yep, same problem here as well, I tried to reinstall and still the same error. Was wondering if anyone had new info? As I tried to edit gemfile.lock and no such luck as well with installing the gem as stated. The last post said waiting so is that what is expected until the next version? Just verifying this.

Thanks



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #12 on: July 26, 2015, 02:00:59 PM
Hi,

From fresh install and using gem msgpack version 0.5.2 will do the trick, but things get worst now, after last msf update even this don't work. What to say, msf and armitage developers need to deal with this not our community.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


toadstool

  • Newbie
  • *
  • Posts: 2
    • View Profile
Reply #13 on: July 26, 2015, 03:14:47 PM
Ok. Thanks ZeroF for clearing that up.

 ;)



sckull

  • Newbie
  • *
  • Posts: 4
    • View Profile
Reply #14 on: August 03, 2015, 05:41:18 AM
I have this problem with armitage
After finish loading is closed...
help!

This is the problem..

https://www.dropbox.com/s/matgc4klfsj74zd/Screenshot%20-%20020815%20-%2021%3A58%3A37.png

Please!