Author Topic: Metasploit RPC daemon Shut Down [SOLVED]  (Read 20685 times)

V3nD3774

  • Newbie
  • *
  • Posts: 31
    • View Profile
on: April 12, 2013, 11:21:20 AM
Hi All,
as u know i was trying to have Armitage working but, in doing this i did discover that maybe a i have another issue to be sorted out first, the issue is the Metasploit.

I will now list the problem:

What steps will reproduce the problem?
1.Open Armitage
2.Click on connect

What is the expected output? What do you see instead?
it suppose to open armitage window

i am using the latest version of backbox.

The error i get is this:



Following this link: http://code.google.com/p/armitage/issues/detail?id=95
I have understood that i might have a problem with Metasploit environment that is out of date.
In fact, if i run :

Code: [Select]
~$ sudo msfrpcd -U msf -P test -f
[sudo] password for stealth:
[*] MSGRPC starting on 0.0.0.0:55553 (SSL):Msg...
[*] MSGRPC ready at Fri Apr 12 12:02:18 +0200 2013.
/opt/backbox/msf/lib/fastlib.rb:374:in `fastlib_original_require': no such file to load -- msgpack (LoadError)
from /opt/backbox/msf/lib/fastlib.rb:374:in `gem_original_require'
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from /opt/backbox/msf/lib/gemcache/ruby/1.9.1/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
from /opt/backbox/msf/lib/gemcache/ruby/1.9.1/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:236:in `load_dependency'
from /opt/backbox/msf/lib/gemcache/ruby/1.9.1/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
from /opt/backbox/msf/lib/msf/core/rpc/v10/service.rb:2
from /opt/backbox/msf/lib/fastlib.rb:374:in `fastlib_original_require'
from /opt/backbox/msf/lib/fastlib.rb:374:in `gem_original_require'
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from /opt/backbox/msf/lib/gemcache/ruby/1.9.1/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
from /opt/backbox/msf/lib/gemcache/ruby/1.9.1/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:236:in `load_dependency'
from /opt/backbox/msf/lib/gemcache/ruby/1.9.1/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
from /opt/backbox/msf/plugins/msgrpc.rb:14
from /opt/backbox/msf/lib/fastlib.rb:374:in `fastlib_original_require'
from /opt/backbox/msf/lib/fastlib.rb:374:in `gem_original_require'
from /usr/lib/ruby/vendor_ruby/1.8/rubygems/custom_require.rb:36:in `require'
from /opt/backbox/msf/lib/gemcache/ruby/1.9.1/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
from /opt/backbox/msf/lib/gemcache/ruby/1.9.1/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:236:in `load_dependency'
from /opt/backbox/msf/lib/gemcache/ruby/1.9.1/gems/activesupport-3.2.8/lib/active_support/dependencies.rb:251:in `require'
from /opt/backbox/msf/lib/msf/core/plugin_manager.rb:52:in `load'
from /opt/backbox/msf/lib/msf/base/simple/framework.rb:32:in `load'
from /opt/backbox/msf/msfrpcd:112
i get a series of missing dependencies ...
Please, what is needed to be done ? if i run msfupdate does not help.

Thanks,
~V






« Last Edit: April 15, 2013, 02:14:34 PM by raffaele »



raffaele

  • Administrator
  • Hero Member
  • *****
  • Posts: 507
    • View Profile
    • My Blog
Reply #1 on: April 12, 2013, 03:19:21 PM
try:
Code: [Select]
sudo apt-get update
sudo apt-get purge msf
sudo apt-get install backbox-desktop
sudo msfupdate

raffaele@backbox:~$ Get root or die tryin'


V3nD3774

  • Newbie
  • *
  • Posts: 31
    • View Profile
Reply #2 on: April 12, 2013, 06:06:44 PM
raffaele,
i have followed your suggestion, but now msfconsole does not start, it requires bundler gem to be installed, ok.
But even after having it installed, it does not start:

Code: [Select]
stealth@stealth:~$ sudo -i
[sudo] password for stealth:
root@stealth:~# gem install bundler
Successfully installed bundler-1.3.5
1 gem installed
Installing ri documentation for bundler-1.3.5...
Building YARD (yri) index for bundler-1.3.5...
Installing RDoc documentation for bundler-1.3.5...
root@stealth:~# msfconsole
[*] Metasploit requires the Bundler gem to be installed
    $ gem install bundler

i know i am making some stupid mistake...any suggestion ?
tx




ch3rl13

  • Newbie
  • *
  • Posts: 4
    • View Profile
Reply #3 on: April 13, 2013, 03:32:36 PM
dopo l'aggiornamento ho lo stesso identico problema!



V3nD3774

  • Newbie
  • *
  • Posts: 31
    • View Profile
Reply #4 on: April 14, 2013, 06:41:41 PM
Update:

Code: [Select]
~$ cat /etc/issue.net : versione OS
BackBox Linux 3.01

then:

Code: [Select]
$ dpkg -l *ruby* | grep ii
ii  libmsgpack-ruby1.9.1                            0.4.5-1                                 binary-based efficient object serialization library for ruby1.9.1
ii  libpgsql-ruby                                   0.12.0-1                                Transitional package for ruby-pg
ii  libruby                                         4.8                                     Transitional package for libruby1.8
ii  libruby1.8                                      1.8.7.352-2ubuntu1.2                    Libraries necessary to run Ruby 1.8
ii  libruby1.9.1                                    1.9.3.0-1ubuntu2.6                      Libraries necessary to run Ruby 1.9.1
ii  libruby1.9.1-dbg                                1.9.3.0-1ubuntu2.6                      Debugging symbols for Ruby 1.9.1
ii  libsqlite3-ruby                                 1.3.4-1                                 Transitional package for ruby-sqlite3
ii  libtcltk-ruby1.9.1                              1.9.3.0-1ubuntu2.6                      Tcl/Tk interface for Ruby 1.9.1
ii  libxml-simple-ruby                              1.0.12-1                                Simple Ruby API for reading and writing XML
ii  ruby                                            4.8                                     Transitional package for ruby1.8
ii  ruby-dev                                        4.8                                     Transitional package for ruby1.8-dev
ii  ruby-json                                       1.6.3-1                                 JSON library for Ruby
ii  ruby-nokogiri                                   1.5.0-1                                 HTML, XML, SAX, and Reader parser for Ruby
ii  ruby-pg                                         0.12.0-1                                PostgreSQL interface for Ruby
ii  ruby-rchardet                                   1.3-2                                   Character encoding auto-detection for Ruby
ii  ruby-sqlite3                                    1.3.4-1                                 SQLite3 interface for Ruby
ii  ruby1.8                                         1.8.7.352-2ubuntu1.2                    Interpreter of object-oriented scripting language Ruby 1.8
ii  ruby1.8-dev                                     1.8.7.352-2ubuntu1.2                    Header files for compiling extension modules for the Ruby 1.8
ii  ruby1.9.1                                       1.9.3.0-1ubuntu2.6                      Interpreter of object-oriented scripting language Ruby
ii  ruby1.9.1-dev                                   1.9.3.0-1ubuntu2.6                      Header files for compiling extension modules for the Ruby 1.9.1
ii  ruby1.9.1-examples                              1.9.3.0-1ubuntu2.6                      Examples for Ruby 1.9
ii  ruby1.9.1-full                                  1.9.3.0-1ubuntu2.6                      Ruby 1.9.1 full installation
ii  ruby1.9.3                                       1.9.3.0-1ubuntu2.6                      Interpreter of object-oriented scripting language Ruby, version 1.9.3
ii  rubygems                                        1.8.15-1ubuntu0.1                       package management framework for Ruby libraries/applications

but if i try to install factory_girl 4.2.0, the reply i get is that i need the updated version of ruby...   ???



V3nD3774

  • Newbie
  • *
  • Posts: 31
    • View Profile
Reply #5 on: April 14, 2013, 08:39:37 PM
Ok, tx to all guys.

The main issue was to remove rubygems and ruby1.8.
Once done I only had to refresh msf.

Now Armitage works fine, as well.

Tx again,
~V



ch3rl13

  • Newbie
  • *
  • Posts: 4
    • View Profile
Reply #6 on: April 15, 2013, 01:07:27 PM
after you've made the update you have just removed rubygems and ruby1.8?



V3nD3774

  • Newbie
  • *
  • Posts: 31
    • View Profile
Reply #7 on: April 15, 2013, 08:04:16 PM
ch3rl13,
i had to remove rubygems and ruby1.8, because this was the issue for me. Before doing this you have to check whether this is your problem as well.

In my case it was not possible to install factory_girl, and i needed ruby1.9.2.

After this i did re-installed msf, created the database and started armitage.