Author Topic: Installation Failure with Broadcom WiFi Card (4311) (b43) [SOLVED]  (Read 18027 times)

lmnope1

  • Newbie
  • *
  • Posts: 11
    • View Profile
So, Backbox looks like an amazing OS, so I burned the LiveCD to a DVD and put it in my mac. (Macbook Pro 2011, 8,1) I proceeded to boot it up and everything worked great. (yay!) So, after poking around a bit, I began the installation. After It finished the Copying Files part of installing, it moved to the second stage. In the second stage, the last thing I saw was something regarding USB drivers or USB support. (something like that.) Then the screen attached came up, and i could not exit out of it. I could see and move the mouse and even click the logout button (which I did after 30 minutes on the screen) but the screen would not go away. So I logged it out and shut down. Since it finished copying files I assumed the OS would at least boot up. I was wrong. I attempted to boot the OS and received the error "Missing Operating System_"

Note: The screens were not scrolling, there were no new commands going through the console screen thing.
Note: I have the latest build (DL'd last night) and its the AMD64 version

Screenie of the error are here:
http://farm9.staticflickr.com/8383/8593648728_8f19b904a4_k.jpg

Is there any way to fix this error?
« Last Edit: March 29, 2013, 02:07:52 AM by lmnope1 »



b4d_bl0ck

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
Reply #1 on: March 27, 2013, 12:49:20 PM
Hi Imnope1,
It seems you have a broadcom wireless card, and a problem almost identical to this: http://forum.backbox.org/general-support/problema-durante-l%27installazione/msg5561/#msg5561
Don't know if you understand the italian language (google translate could provide you an idea of the discussion), but basically, during the installation, there is an issue with your wireless card.
However be sure, for all the methods listed, to uncheck the box relative to the download of updates and packets at the beginning of the installation process, avoiding to have your wireless card wrongly detected again, due to packets download.
If you can disable the wireless via BIOS configuration panel, than the OS should not detect it and never load its modules. Than, once the installation is finished, you can bring your wireless card up and reinstall the packets you need to make it work. The user in the post i linked above needed the b43_legacy drivers, so, if this is your case too, you can reinstall the right driver after the installation.
You can also try this, removing your wireless packets, or blacklisting them, on a persistent -persistent- live usb.
The user solved by blacklisting the b43 module, which generated the conflict, as boot parameter in the grub (i think editing the backbox entry at the line starting with "linux") adding:
Code: [Select]
b43.blacklist=yesthen proceeded booting the BackBox kernel just modified and installing it, and in the end reinstalled the right drivers after the reboot.
This methods worked for him, so you can try this first. Maybe try to contact him in private if you need more details, and in the case you solve you could post the solution here...
Should not be an unsolvable problem  ;)

Good luck!
Enjoy BackBox.

bool secure = check_paranoia() ? true : false;


lmnope1

  • Newbie
  • *
  • Posts: 11
    • View Profile
Reply #2 on: March 27, 2013, 04:24:57 PM
First off, I would like to say thank you for the reply.
I would like to point out that when im on my backbox live CD, there is no wifi connection. It offers wired, but I never tried plugging it in to an ethernet cable. (which I have) Should I try that?
I tried disabling the 3rd party software checkbox. I tried disabling the download updates checkbox. I tried disabling both. (all 3, different times) and they have all gave back the same error.

Seeing as I have a mac, I dont think i can disable my WiFi card at boot. Unless I can do it with a boot flag in the grub bootloader, which I am not aware of. My mac also cannot boot from USB. I tried booting backbox from USB and it failed, so i went and bought DVDs.

So, I'm going to go and try putting "b43.blacklist=yes" as a bootloader flag in grub and then try installing.
And If that doesnt work, I'm going to try plugging my computer into the Ethernet cable I have and letting it download updates and whatnot and just hope that it works.
I'll get back to you as soon as i can.
Thanks a ton
- Matt



lmnope1

  • Newbie
  • *
  • Posts: 11
    • View Profile
Reply #3 on: March 27, 2013, 04:59:51 PM
so, I tried the method you proposed, but I got no luck. it crashed when it got to installing USB drivers.....

I'm trying installing it plugged into my modem now and with updates on. maybe the driver that keeps messing me up got updated? I really don't know. I'm trying anything at this point.



lmnope1

  • Newbie
  • *
  • Posts: 11
    • View Profile
Reply #4 on: March 27, 2013, 05:41:26 PM
Still nothing is working. I have the log files though, if that will help.

I wasnt able to get all the log files, some i received permission denied errors for, but I think i got most of them.

Thanks
-Matt

Log Files: http://www.mediafire.com/?agu5m9k25g8z557



b4d_bl0ck

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
Reply #5 on: March 27, 2013, 10:47:15 PM
Wait Imnope1
Quote
it crashed when it got to installing USB drivers
that's exactly what we want not to happen... you have to install you drivers after the successfull installation on the HDD, avoiding the detection of your wireless card before and during the installation process.
Try to make these steps (I edited these lines after successfull installation, so you see strikethrough over the initial resolution attempts  ;) ):
  • Since you haven't the possibility to boot from USB, boot from your DVD. When it shows menu containing the BackBox entries in various languages, press 'e' [TAB] to edit the line with the version you want to boot
  • Now you got a line to edit: add b43.blacklist=yes after the words "quiet splash" to the end of the line starting with linux or kernel, without touching "--" at the end of the line.
  • Save and boot the entry you have just modified.
  • Once booted into your BackBox, plug in your ethernet cable and start the installation
  • Uncheck the boxes relative to updates downloads, hardware detection, third party modules, and similar, if there are (don't remember well... in general uncheck all that could cause a detection of your wireless card)
  • Start the installation and wait, crossing your fingers...  :P
  • Once (hopefully) installed, reboot the machine, remove the DVD, and you should be able to boot in BackBox (directly or via Grub menu, depending on what's your installation type)
  • Now install the right drivers for your wireless card, you might need to take a look here: http://linuxwireless.org/en/users/Drivers/b43

Thanks for the logs, but I have no time now to check them... possibly i'll do it later.
Good luck!
« Last Edit: April 12, 2013, 09:51:57 AM by b4d_bl0ck »

bool secure = check_paranoia() ? true : false;


lmnope1

  • Newbie
  • *
  • Posts: 11
    • View Profile
Reply #6 on: March 27, 2013, 11:14:18 PM
I tried using the b43.blacklist=yes at the end of the bootloader thing. What I did, is that when i got to the Grub menu, I hit the [tab] button and tried two things:

1. there was already a "--" on the line for editing, so I added the b43.blacklist=yes to that and went through the procedure. Result was a failed installation

2. I got rid of the "--" and just added the b43.blacklist=yes  The result was still a fail.



b4d_bl0ck

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
Reply #7 on: March 27, 2013, 11:38:29 PM
Oh yes you're right. It's [Tab] that enables editing... and I was referring to a grub HDD installation... sorry.
I'm just checking in virtualbox if it's possible to blacklist a module editing this type of lines, never done before... I'm supposing "--" has to stay in the end of the line.
Stay tuned.

[EDIT]

OK, i was able to blacklist bluetooth module as test!
In your case, simply insert b43.blacklist=yes after the words "quiet splash" in the entry you have chosen with [Tab]. Don't touch "--" at the end.
Then follow the steps listed above from 3rd point going on...
(I corrected the above list of steps)

Keep us up to date.

[/EDIT]
« Last Edit: April 12, 2013, 09:46:29 AM by b4d_bl0ck »

bool secure = check_paranoia() ? true : false;


lmnope1

  • Newbie
  • *
  • Posts: 11
    • View Profile
Reply #8 on: March 28, 2013, 01:17:28 AM
YOU ARE A GENIUS. It worked perfectly! thank you so much! You know, its people like you that keep the tech world spinning!
Honestly, I cannot thank you enough for your help.

Thank you so much!
- Matt


EDIT:

So, now I have no WiFi drivers, and when I went to get the drivers from the top right hand corner of the screen, I got the same error depicted in the first post.... how do I get my drivers?
« Last Edit: March 28, 2013, 03:21:28 AM by lmnope1 »



b4d_bl0ck

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
Reply #9 on: March 28, 2013, 02:01:15 AM
Ehy Imnope1, I'm glad for the successfull installation...
[OT] anyway nobody is a genius, unfortunately reading and studying is never enough to follow the technological progress coming from millions of human minds through the world. There's always too much to learn, so never stop your curiosity... this is the essence of hacking  ;)

Anyway, can you specify in a better form the error you are getting now? I mean: is BackBox installed? Can you work with it? Does it boot without DVD, that is from your HDD? You "hit install drivers" where? How? What's the "same error" you're telling about? Does it boot again after this?

P.S. Two things more: I'd change the title in something like "Installation failure with broadcom wireless card [b43]", because it's not a MacBook problem. When you think the issue is solved you can edit the title adding "[SOLVED]" in front of it.
Also, when you have to write something, and you see the last post in a thread is still a post written by you, don't hit "reply", but edit your last post clicking "Modify", thus having less confusion. Simple forums rule, not a critic  ;)

Enjoy

bool secure = check_paranoia() ? true : false;


lmnope1

  • Newbie
  • *
  • Posts: 11
    • View Profile
Reply #10 on: March 28, 2013, 02:49:15 AM
Sorry about that. I'll fix it in a sec.
Well, Backbox is installed to my HDD, thanks to your help. I got the little drivers symbol in the top right of my screen, so i clicked it and clicked on the broadcom driver part, and from that point I clicked Activate. After that, I got the same error displayed in the first post of this thread. So I shut it down and turned it back on. The OS still works great, but the driver is not installed.
« Last Edit: March 28, 2013, 02:52:24 AM by lmnope1 »



b4d_bl0ck

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
Reply #11 on: March 28, 2013, 03:10:04 AM
Oh, let's say it's half-solved...
Anyway i think you have exactly the issue of the user in the link i provided you in my first reply. He needed to run:
Code: [Select]
sudo apt-get install firmware-b43-lpphy-installerbut don't know if this is your case too. To be sure try reading something more here, and see what driver you need. Also remove the harware checking at startup if you want.
Oh, and thanks for the fixes :)

bool secure = check_paranoia() ? true : false;


lmnope1

  • Newbie
  • *
  • Posts: 11
    • View Profile
Reply #12 on: March 28, 2013, 03:56:03 AM
I tried using the apt-get command that you recommended, but it returned an error along the lines of "no supported card found" but I did some investigating and I do have the b43 card...... I'm trying another guide I found online. I'll post it in a few minutes when I get back home.
EDIT:Posted 2 posts down.
« Last Edit: March 28, 2013, 04:19:59 AM by lmnope1 »



weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #13 on: March 28, 2013, 04:07:49 AM
Bella b4d_bl0ck!
complimenti, ben fatto!
well done! =)
« Last Edit: March 28, 2013, 04:09:55 AM by weVeg »

una voce libera รจ sempre liberatrice
under_r00t


lmnope1

  • Newbie
  • *
  • Posts: 11
    • View Profile
Reply #14 on: March 28, 2013, 04:19:13 AM
Sorry for the delay. The method that I posted here before failed. I'll just keep scavenging the net until I find a way.
I'll post one here when I find a working one.
« Last Edit: March 28, 2013, 05:23:45 PM by lmnope1 »