Author Topic: How to prevent sleep / hibernation?  (Read 7764 times)

kepa

  • Newbie
  • *
  • Posts: 2
    • View Profile
on: June 20, 2014, 10:58:21 PM
I am trying backbox via usb on my ASUS Q500.  Everything works well, even the wifi.  However, my laptop will eventually timeout and go into sleep mode.  I have to do a hard reboot to get back online.  How can I prevent this from happening?



b4d_bl0ck

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
Reply #1 on: June 20, 2014, 11:58:25 PM
kepa,
are you talking about sleep/hibernation, aren't you?
This is really strange, it can be an ACPI issue. Or just some misconfiguration in the power manager... But the fact that it is unable to recover from the sleeping state sounds strange to me.
Does it happen regularly after a precise given period, or randomly? You may want to give a look to your log files and double check the power manager settings.

Bye.

bool secure = check_paranoia() ? true : false;


kepa

  • Newbie
  • *
  • Posts: 2
    • View Profile
Reply #2 on: June 21, 2014, 09:01:10 AM
yes, i believe it is sleep/hibernation.  it happens after a precise given period of non-use (idle, no typing, mouse movement, etc).  when trying to hit keys or moving the mouse it does not recover.  since i am running off the usb, will log files still be written?



b4d_bl0ck

  • Sr. Member
  • ****
  • Posts: 285
    • View Profile
Reply #3 on: June 21, 2014, 09:58:47 AM
kepa,
yes if it's on usb you will have no logs, so i guess you have to disable idle times in the xfce power manager. Maybe instead of saving to the ram it savses to disk (your usb, which may be too little to contain the whole system image), and then it's unable to recover. But i'm not sure if this is the reason, or if it is even a plausible theory.
Anyways, as said, try playing a bit with power manager settings, but this needs to be done on every boot.
For persistent disabling you can either try turning ACPI off in BIOS configuration screen (if there is such an option), or you can force the kernel to not load ACPI modules passing the parameter acpi=off to it in the bootloader configuration file (the file to edit depends on which bootloader was installed by the tool you used to create the bootable usb, mostly syslinux or extlinux).
But disabling ACPI functionalities can be a temporary solution. You should really try to fix it. Maybe with a full disk installation it works as expected.

Good luck.
Bye.

bool secure = check_paranoia() ? true : false;