Author Topic: How to add service on startup?  (Read 5291 times)

schema

  • Guest
on: November 24, 2013, 11:58:15 PM
I've been trying to add ssh to startup. Traditionally, openssh daemon starts on boot by default. I've reinstalled it, set the configs to default. I tried uncommenting the address it listens to in the config file thinking that the error arises from it trying to find something to listen to before the network interface loads. that hasn't worked either. I am not sure conventional ubuntu 12.4 solutions apply so how do I do this for backbox?  



raffaele

  • Administrator
  • Hero Member
  • *****
  • Posts: 507
    • View Profile
    • My Blog
Reply #1 on: November 25, 2013, 12:23:07 PM
vi /etc/init/ssh.conf

and edit:
#start on filesystem or runlevel [2345]

to:
start on filesystem or runlevel [2345]

raffaele@backbox:~$ Get root or die tryin'


schema

  • Guest
Reply #2 on: November 25, 2013, 05:24:31 PM
thanks. that worked! I've been trying to uncomment the wrong option.