Author Topic: [SOLVED] First logging problem...  (Read 2104 times)

r0n1n

  • Newbie
  • *
  • Posts: 3
    • View Profile
on: November 22, 2015, 02:53:12 PM
Hi there! I have installed backbox recently. But i have problem with first logging. When I choose user and input pass, system don't logging. I have selected languages, i have reinstall OS(because I thought that I could input wrong char in pass) - problem don't solved. Please help me.
« Last Edit: January 18, 2016, 09:48:36 PM by ZEROF »



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #1 on: November 22, 2015, 05:42:18 PM
Yes you didn't type good password. Did you check keyboard settings when you boot in live mode? When you boot, open geany and type random text and numbers. Don't run installation before checking keyboards settings.


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


r0n1n

  • Newbie
  • *
  • Posts: 3
    • View Profile
Reply #2 on: November 22, 2015, 06:35:34 PM
Did you check keyboard settings when you boot in live mode?
Yes! I did it. Twice. I'm 2-years experience linux user. I'm always pay attention on this.
Logging form have behaviour like it recognize pass, but then loading again form login/pass without any alerts about wrong pass or login. I try login in the guest mode and try change user with "su" in console. But I couldn't do this.
I switched in console mode with  ctrl+alt+f1. And I DID IT!! My pass is right. Problem with login form(I don't know name of this programm). Have you any ideas, how I can fix it?
upd_1: I can do it:"sudo startx". But I can't login like username.
upd_2: I logined like root. Change pass. After that login like root in form login/pass. I have alert massege "/root/.profile have error     stdin: is not tty" I'm in the X.
« Last Edit: November 22, 2015, 07:16:39 PM by r0n1n »



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #3 on: November 22, 2015, 09:17:59 PM
Hi again,

Why do you want to log in as root graphically? Graphical root login is disabled by default. But if you have standrad user you will need to edit /root/.profile file.

I will go first with this. Find:

mesg n

And replace it,

if `tty -s`; then
   mesg n
fi

2nd solution you can try to repace mesg n with,

tty -s && mesg n

Good luck!
« Last Edit: November 22, 2015, 10:41:21 PM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


r0n1n

  • Newbie
  • *
  • Posts: 3
    • View Profile
Reply #4 on: November 22, 2015, 10:07:40 PM
Why do you want to log in as root graphically?
Just like a try. I understand that is wrong.

I looked in $HOME/xsession-error.  There  some problem with login.
Code: [Select]
Xsession: X session started for root at неділя, 22 листопада 2015 20:10:55 +0200
localuser:root being added to access control list
openConnection: connect: Немає такого файла або каталогу
cannot connect to brltty at :0
Скрипт для none запущено з run_im.
Скрипт для auto запущено з run_im.
Скрипт для default запущено з run_im.
Скрипт для none запущено з run_im.
Скрипт для auto запущено з run_im.
Скрипт для default запущено з run_im.
xfce4-session-Message: ssh-agent is already running

** (update-notifier:4203): WARNING **: not starting for system user

(polkit-gnome-authentication-agent-1:4219): GLib-CRITICAL **: g_variant_new_string: assertion 'string != NULL' failed

(polkit-gnome-authentication-agent-1:4219): polkit-gnome-1-WARNING **: Failed to register client: GDBus.Error:org.freedesktop.DBus.Error.ServiceUnknown: The name org.gnome.SessionManager was not provided by any .service files
Home directory not accessible: Відмовлено у доступі

(xfce4-volumed:4249): xfce4-volumed-WARNING **: xvd_connect_to_pulse: failed to connect context: Гаразд

(xfce4-volumed:4249): xfce4-volumed-WARNING **: Unable to initialize pulseaudio support, quitting

(xfce4-volumed:4249): GLib-GObject-CRITICAL **: g_object_unref: assertion 'G_IS_OBJECT (object)' failed
Home directory not accessible: Відмовлено у доступі
Спроба встановлення з’єднання зазнала невдачі: У з'єднанні відмовлено
Спроба виконання pa_context_connect() завершилася невдало: У з'єднанні відмовлено
No protocol specified
xscreensaver: 20:10:57: Can't open display: :1.0
xscreensaver: 20:10:57: initial effective uid/gid was root/root (0/0)
xscreensaver: 20:10:57: running as nobody/nogroup (65534/65534)

xscreensaver: 20:10:57: This is probably because you're logging in as root.  You
              shouldn't log in as root: you should log in as a normal user,
              and then `su' as needed.  If you insist on logging in as
              root, you will have to turn off X's security features before
              xscreensaver will work.

              Please read the manual and FAQ for more information:

              http://www.jwz.org/xscreensaver/faq.html
              http://www.jwz.org/xscreensaver/man.html

initctl: UPSTART_SESSION isn't set in the environment. Unable to locate the Upstart instance.

** (nm-applet:4228): CRITICAL **: nm_secret_agent_register: assertion 'priv->registered == FALSE' failed
Home directory not accessible: Відмовлено у доступі
thunar-volman: Немає пристрою з шляхом sysfs  "/sys/devices/pci0000:00/0000:00:1a.0/usb3/3-1/3-1.1".
thunar-volman: Тип пристрою USB не підтримується.
thunar-volman: Тип пристрою USB не підтримується.
thunar-volman: Тип пристрою USB не підтримується.
xfsettingsd: Fatal IO error 11 (Ресурс тимчасово недоступний) on X server :1.0.
xfdesktop: Fatal IO error 11 (Ресурс тимчасово недоступний) on X server :1.0.
xfwm4: Fatal IO error 11 (Ресурс тимчасово недоступний) on X server :1.0.
blueman-applet: Fatal IO error 11 (Ресурс тимчасово недоступний) on X server :1.0.
Loading configuration plugins
blueman-applet version 1.23 starting
Stale PID, overwriting
Using gconf config backend
Using gconf config backend
Using gconf config backend
Using gconf config backend
Using gconf config backend
Using gconf config backend
Using gconf config backend
Using gconf config backend
Using gconf config backend
Using gconf config backend
Using gconf config backend



ZEROF

  • Hero Member
  • *****
  • Posts: 1245
    • View Profile
    • Pen Tester
Reply #5 on: November 22, 2015, 10:55:47 PM
You go all around, using root over and over. Like, you type sudo startx, type bro just startx etc..

But if i was you:

1. I would check ISO MD5
2. When i run install I will create normal user, like "Alex"
3. Use English for installation, then install your language


Cheers!
« Last Edit: November 23, 2015, 08:38:01 AM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*