Author Topic: Errore Broken-Count >0 [SOLVED]  (Read 2404 times)

V3nD3774

  • Newbie
  • *
  • Posts: 31
    • View Profile
on: December 25, 2012, 11:26:39 AM
Hi All,
during the installation of updates i got the following error:

I seguenti pacchetti presentano dipendenze non soddisfatte:

postgresql-client-9.1: Depends: zlib1g (>= 1:1.1.4) ma 1:1.2.3.4.dfsg-3ubuntu4 è installato
                       Depends: postgresql-client-common (>= 115~) ma 136~precise è installato

I have tried to run apt-get install -f as suggested and this is the outcome :

Code: [Select]
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  libopenal1:i386 bluez-alsa:i386 libsdl-ttf2.0-0:i386 libkrb5-3:i386
  libgconf-2-4:i386 libatk1.0-0:i386 libk5crypto3:i386 libstdc++5:i386
  libstdc++6:i386 libxfixes3:i386 ia32-libs-multiarch:i386
  libqt4-declarative:i386 libxcomposite1:i386 libgail18:i386
  libldap-2.4-2:i386 libv4l-0:i386 liblcms1:i386 libqt4-qt3support:i386
  libroken18-heimdal:i386 libunistring0:i386 libcupsimage2:i386
  libgphoto2-port0:i386 libidn11:i386 libnss3:i386 libwrap0:i386 libcaca0:i386
  gtk2-engines:i386 libgudev-1.0-0:i386 libsamplerate0:i386
  libjpeg-turbo8:i386 libcdparanoia0:i386 libcairo-gobject2:i386
  libavc1394-0:i386 libjpeg8:i386 ia32-libs libaio1:i386 libsane:i386
  odbcinst1debian2:i386 libqt4-test:i386 libqt4-script:i386
  libqt4-designer:i386 libsdl-mixer1.2:i386 libqt4-network:i386
  libqt4-dbus:i386 libxxf86vm1:i386 libcap2:i386 libproxy1:i386 ibus-gtk:i386
  libdbus-glib-1-2:i386 libgl1-mesa-dri:i386 libtdb1:i386 libxcb-glx0:i386
  libasn1-8-heimdal:i386 libgl1-mesa-glx:i386 libspeex1:i386 gvfs-libs:i386
  libjack-jackd2-0:i386 libxslt1.1:i386 libgomp1:i386 libcapi20-3:i386
  libibus-1.0-0:i386 libcairo2:i386 libx11-xcb1:i386 libgnutls26:i386
  libglapi-mesa:i386 libgssapi3-heimdal:i386 libvisual-0.4-0:i386
  libcanberra-gtk-module:i386 libcanberra0:i386 libtasn1-3:i386
  libfreetype6:i386 gtk2-engines-murrine:i386 libwavpack1:i386
  libqt4-opengl:i386 libsoup-gnome2.4-1:i386 libmysqlclient18:i386
  libexpat1:i386 libv4lconvert0:i386 gstreamer0.10-plugins-good:i386
  libc6-i386 libqt4-xmlpatterns:i386 librsvg2-common:i386 libdatrie1:i386
  libavahi-common-data:i386 libiec61883-0:i386 libjson0:i386
  libgdk-pixbuf2.0-0:i386 libsdl-image1.2:i386 libxcb1:i386 libp11-kit0:i386
  libwind0-heimdal:i386 libxau6:i386 libpixman-1-0:i386 libsdl1.2debian:i386
  libxaw7:i386 libgdbm3:i386 libcups2:i386 libcurl3:i386 libqtcore4:i386
  libxinerama1:i386 libesd0:i386 libmikmod2:i386 libkrb5support0:i386
  libxft2:i386 libcroco3:i386 libpulse-mainloop-glib0:i386 libtheora0:i386
  libice6:i386 libaa1:i386 libspeexdsp1:i386 libxdmcp6:i386 libieee1284-3:i386
  libgcrypt11:i386 libthai0:i386 libxml2:i386 libao4:i386 pax
  libkeyutils1:i386 libxmu6:i386 libcanberra-gtk0:i386 libvorbisfile3:i386
  libqt4-sql:i386 esound-common libasound2:i386 libxpm4:i386 libflac8:i386
  libqt4-svg:i386 libusb-0.1-4:i386 libgail-common:i386 libxrender1:i386
  libhcrypto4-heimdal:i386 liborc-0.4-0:i386 libraw1394-11:i386 libnspr4:i386
  libshout3:i386 libdv4:i386 libhx509-5-heimdal:i386 libvorbisenc2:i386 rpm
  librpmbuild2 libqt4-xml:i386 libasyncns0:i386 gstreamer0.10-x:i386
  libgettextpo0:i386 libxss1:i386 libgd2-xpm:i386 libheimbase1-heimdal:i386
  libtiff4:i386 libsdl-net1.2:i386 libjasper1:i386 libvisual-0.4-plugins:i386
  libgstreamer-plugins-base0.10-0:i386 libgnome-keyring0:i386 libxtst6:i386
  gtk2-engines-pixbuf:i386 libqtgui4:i386 libtag1c2a:i386 librsvg2-2:i386
  libavahi-client3:i386 libssl0.9.8:i386 libmpg123-0:i386 libmad0:i386
  libx11-6:i386 libsasl2-2:i386 gtk2-engines-oxygen:i386 libfontconfig1:i386
  lib32z1 xaw3dg:i386 libpango1.0-0:i386 libsm6:i386 libpulse0:i386
  libheimntlm0-heimdal:i386 librpmsign0 libpulsedsp:i386 libxdamage1:i386
  gvfs:i386 libqt4-sql-mysql:i386 libxcb-render0:i386 libodbc1:i386
  libexif12:i386 libqt4-scripttools:i386 libglu1-mesa:i386 librtmp0:i386
  libgssapi-krb5-2:i386 libxi6:i386 libvorbis0a:i386 libqtwebkit4:i386
  lsb-core libgstreamer0.10-0:i386 libxp6:i386 libaudio2:i386 libxcursor1:i386
  libxcb-shm0:i386 libxt6:i386 alien libxv1:i386 libxext6:i386 ncurses-term
  libsasl2-modules:i386 libavahi-common3:i386 libxrandr2:i386
  gstreamer0.10-plugins-base:i386 libsndfile1:i386 libsqlite3-0:i386
  libmng1:i386 libgtk2.0-0:i386 libltdl7:i386 libkrb5-26-heimdal:i386
  libasound2-plugins:i386 glib-networking:i386 libgpg-error0:i386
  libllvm3.0:i386 libsoup2.4-1:i386 libgphoto2-2:i386 libogg0:i386
  libtag1-vanilla:i386 libaudiofile1:i386
Usare "apt-get autoremove" per rimuoverli.
I seguenti pacchetti saranno inoltre installati:
  postgresql-9.1
Pacchetti suggeriti:
  oidentd ident-server locales-all
I seguenti pacchetti saranno aggiornati:
  postgresql-9.1
1 aggiornati, 0 installati, 0 da rimuovere e 51 non aggiornati.
1 non completamente installati o rimossi.
È necessario scaricare 0 B/4299 kB di archivi.
Dopo quest'operazione, verranno liberati 5300 kB di spazio su disco.
Continuare [S/n]? s
dpkg: problemi con le dipendenze impediscono la configurazione di postgresql-9.1:
 postgresql-client-9.1 (9.1.7-0ubuntu12.04) danneggia postgresql-9.1 (<< 9.1.7-0ubuntu12.04) ed è installato.
  La versione di postgresql-9.1 da configurare è 9.1.6-1~precise2.
dpkg: errore nell'elaborare postgresql-9.1 (--configure):
 problemi con le dipendenze - lasciato non configurato
Segnalazione apport non scritta poiché il messaggio di errore indica la presenza di un fallimento precedente.
                             Si sono verificati degli errori nell'elaborazione:
 postgresql-9.1
E: Sub-process /usr/bin/dpkg returned an error code (1)

Now the situation is that this postgresql issue is preventing me even to install the other updates.Is anybody able to shed some light ??

Thanks to All
« Last Edit: December 28, 2012, 01:24:48 PM by raffaele »



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #1 on: December 25, 2012, 10:06:58 PM
Hi man,

Try next :
sudo -i
add-apt-repository ppa:pitti/postgresql
apt-get purge postgresql*
apt-get install update && apt-get install upgrade
apt-get install postgresql
apt-get update && apt-get upgrade


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


V3nD3774

  • Newbie
  • *
  • Posts: 31
    • View Profile
Reply #2 on: December 25, 2012, 10:41:52 PM
ZEROF, u are the number 1.

It look like it works, thanks again.



V3nD3774

  • Newbie
  • *
  • Posts: 31
    • View Profile
Reply #3 on: January 02, 2013, 08:48:34 PM
Might this issue have created some problem with Armitage ? since then i cannot connect to the server, i have a wrong message error for the password...



V3nD3774

  • Newbie
  • *
  • Posts: 31
    • View Profile
Reply #4 on: January 02, 2013, 09:41:13 PM
yes it did ...but i did follow again the 2 posts/wiki on metasploit and armitage and now it is working again.