Author Topic: dualboot, secondo tempo [SOLVED]  (Read 3803 times)

dravok

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
on: June 05, 2011, 01:19:50 PM
Mi scuso per l'apertura di un nuovo topic sullo stesso argomento, ma li non potevo rispondere.

Ho liberato la partizione G con i suoi 140 gb

con gparted avviato tramite livecd Bbox ho smontato volume G, cancellato la partizione e dopo averla estesa ho dato i valori

100 gb vuoti (per salvare i dati su window)
40 gb per creare / e swamp da 512

al termine ho premuto la conferma del programma, la V verde.

inizia a caricare 1 su 4 e subito mi dice
impossibile montare "Volume"..
The enclosing drive for the volume is locked

c è un metodo per sbloccarlo e riprocedere con le partizioni sopra descritte?

se il topic è inutile dato che l argomento era trattato da un altro topic, mi potete spostare il messaggio li..

Perdonatemi per la confusione
« Last Edit: February 03, 2012, 08:22:16 PM by raffaele »



dravok

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
Reply #1 on: June 05, 2011, 03:02:36 PM
 :'(
dopo aver creato la partizione per bbox, anch (e se diceva quell errore, mi ha fatto andare avanti e ho fatto l installazione di bbox,

ho riavviato il pc e la schermata era diversa.

avvia bbox
avvia bbox (recupera impostazioni)
osserva controllo memoria
osserva controllo memoria in un altro modo
avvia windows 7 sda2

quando ho visto sda2 mi sono preoccupato,

comunque ho avviato 7 e...
ci dispiace, non è possibile avviare windows 7 per possibili modifiche hardware

ho riavviato, provato bbox installato e funziona bene,

prendo il disco di ripristino di windows, lo faccio partire ma..

impossibile trovare drive hardisk, scegliere hardisk...

le ho provate tutte, ma niente,

sono rientrato su bbox con g parted e ho cancellato la partizione creata iunendo quella e formattandola in nfts

ma nulla, non riconosce l hardware.

ho preso un cd di installazione di windows, nulla!

ho guardato che su g parted mi spuntano le due partizioni di ripristino, ma non so perche non mi si ripristina nulla!

che faccio?

al momento il pc mi si avvia solo tramite livecd



vincenzo

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Reply #2 on: June 05, 2011, 05:24:24 PM
Fai partire il programma da terminale con il comando "gksudo gparted". Se spuntano le partizioni di ripristino immagino che tutto il resto lo vedi (almeno) come spazio non allocato. Se è così, devi solo creare una nuova partizione primaria (di dimensione a tua scelta), formattarla come NTFS (icona verde acqua) e creare il resto come partizione estesa (icona celeste). All'interno della partizione estesa, come hai fatto l'altra volta, devi creare due partizioni logiche, una con filesystem ext4 (icona blue) e l'altra di 512MB come linux-swap (icona rossa). Per applicare le modifiche clicca sull'icona "tick" in verde. Fatte queste modifiche installa prima Win7 sulla partizione primaria NTFS e in seguito Backbox su quella formattata come ext4 (a cui assegnerai il mount point "/" in fase di installazione). Non è un problema di riconoscimento hardware, da quello che mi pare di capire devi solo partizionare e formattare.
« Last Edit: June 05, 2011, 05:41:12 PM by vincenzo »

You cannot teach a man anything. You can only help him discover it within himself.




dravok

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
Reply #3 on: June 05, 2011, 06:55:10 PM
grazie per le dritte,
ho provato ma da sempre errore con g parted sul fatto che non si sono smontate le parti,
provando a installare windows si ferma a meta dicendomi che manca il file sistem, manca l hardisk..

stanco di provare e riprovare ho cancellato tutte le partizioni,
ne ho creato una da 140  primaria formattata nfts
il resto estesa
dove 50 giga sono nfts
80 gica ext3 per bbox
550 mega rossi per swap

adesso l installazione di windows riconosce l hardisk
ma serve installare una nuova versione di 7.

quella in mio possesso dell altro pc è per 32bit e non 64 come il mio pc (e come il cd di ripristino in mquindi mi procuro una da 64 e poi vi dico come è andata,adessoio possesso, che non ne ha voluto sapere di funzionare)

intanto installo bbox, sperando che si installi tranquillamente.

non mi va di partire solo ed esclusivamente in live.

 :(



dravok

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
Reply #4 on: June 06, 2011, 10:12:46 PM
 :o allooora..

Ripeto, ho creato due partizioni, una primaria e una estesa, nell estesa ho messo bbox, swap, e  50gb in nfts

Bbox si é installato perfettamente. Funziona bene e al momento sono soddisfatto.
Di pomeriggio ho preso un cd windo 7 ultim.
L ho installato sulla partizione primaria e si é installato senza problemi.

Adesso pero m trovo senza bbox

Mi spiego, se riavvio il pc vede solo windo7 anche se clicco su f5 sceglie solo windo7.
Su windo7 la partizione di bbox non appare affatto quindi presumo ci sia ancora
Come faccio a vederlo insieme a windo7 all avvio dopo il bios cosi da poter scegliere?



vincenzo

  • Full Member
  • ***
  • Posts: 103
    • View Profile
Reply #5 on: June 07, 2011, 04:05:53 AM
Eheh.. perdonami, però un appunto devo fartelo perchè mi sembra che non hai letto i consigli che ti avevo dato.. avevo consigliato di installare Backbox alla fine proprio per questo motivo. Nota: anche se GParted ti segnalava di non aver smontato le parti ti faceva formattare, ed era quello che ti serviva. Windows purtroppo sovrascrive l'MBR (Master Boot Record), ed è per questo che non ti ritrovi più Backbox all'avvio. Comunque ci sono diversi modi per ripristinare il bootloader Grub e uno di questi consiste nei seguenti comandi (usando lo stesso CD Live di Backbox e aprendo un terminale):

Code: [Select]
sudo -i
fdisk -l

con questi in pratica ti assicuri di essere sempre root e rintracci la partizione dove avevi installato Backbox, che facciamo finta si trovi su /dev/sda2. A questo punto:

Code: [Select]
mount /dev/sda2 /mnt
mount --bind /dev /mnt/dev
mount --bind /proc /mnt/proc
chroot /mnt
grub-install /dev/sda       [NB: non è un errore, è "sda" non "sda2"]
umount /mnt/proc
umount /mnt/dev
umount /mnt
reboot

ma stavolta vedi Backbox e non Windows7. Allora fai il login in Backbox, apri un terminale e aggiorni il bootloader:

Code: [Select]
sudo update-grub
sudo reboot

e il gioco è fatto. All'avvio dovresti ritrovare entrambi i sistemi operativi.






« Last Edit: June 07, 2011, 08:42:39 AM by vincenzo »

You cannot teach a man anything. You can only help him discover it within himself.




dravok

  • Jr. Member
  • **
  • Posts: 84
    • View Profile
Reply #6 on: June 07, 2011, 11:48:19 AM
 ;D
siiiii!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

scusa se non sono riuscito a seguire alla lettera i tuoi consigli precedenti, ma il panico del pc senza hardisk riconosciuti mi assaliva.

comunque grazie a queste dritte sono arrivato al mio intento, non so come esprimerti verbalmente la mia gratitudine.

 ;D

ora funziona.

Devo solo capire perche questa installazione di bbox non mi fa sentire l audio (mentre il live e i virtuali di bbox si) ma come dice bene raffaele, basta googlare..

ti ringrazio tanto!

per me potete chiudere questo argomento...



raffaele

  • Administrator
  • Hero Member
  • *****
  • Posts: 507
    • View Profile
    • My Blog
Reply #7 on: June 07, 2011, 01:46:19 PM
basta alzare i volumi dal mixer ;)

chiudo.

raffaele@backbox:~$ Get root or die tryin'