Author Topic: Backbox 4: apps don't appare in the apps menu [SOLVED]  (Read 4723 times)

bartx

  • Newbie
  • *
  • Posts: 6
    • View Profile
on: November 10, 2014, 03:09:05 PM
hi to all, i just install backbox 4, and i see that if i install some apps (bum, grub customizer, and others) i can't see this in the backbox menu, also i cant'see too items in the system submenu, if i login whit xfce session i find everithing.
i try to see in the menu option if this apps are hidden, but all the items are visible

and also i can't disable some services (ssh, for exemple) from but or from the shell (update-rd.c), this problem also i was in backbox 3.19

any idea?
« Last Edit: November 24, 2014, 09:38:51 PM by ZEROF »



ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #1 on: November 10, 2014, 10:51:21 PM
Hi bartx,

BBox is made to run with xfce session. You can use sysv-rc-conf tool for disabling any services from boot.

sudo apt-get install sysv-rc-conf
« Last Edit: November 10, 2014, 11:35:48 PM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*


bartx

  • Newbie
  • *
  • Posts: 6
    • View Profile
Reply #2 on: November 11, 2014, 01:42:39 PM
i know sysv-rc-conf, but is the same of bum or update-rc.d, ssh appear disabled, but the daemon is running



i know that backbox is working with xfce menu, but in the menu, when i open a standar backbox session, some application are missing, if i open at the login, standard xfce session all application appear, as exception of backbox applications




« Last Edit: November 11, 2014, 01:48:07 PM by bartx »



bartx

  • Newbie
  • *
  • Posts: 6
    • View Profile
Reply #3 on: November 11, 2014, 06:08:10 PM
the ssh isn't in the rc.d directory, for stopping ssh starting at the boot is needed to comment the line start on boot in the /etc/init/ssh,conf




ZEROF

  • Hero Member
  • *****
  • Posts: 1247
    • View Profile
    • Pen Tester
Reply #4 on: November 11, 2014, 09:30:14 PM
Yep,

sudo mv /etc/init/ssh.conf /etc/init/ssh.conf.disabled

Reboot. Will do the trick.

You can mark topic as SOLVED.
« Last Edit: November 24, 2014, 09:38:36 PM by ZEROF »


Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*