Author Topic: Another update problem [SOLVED]  (Read 3092 times)

weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
on: May 04, 2013, 06:48:18 PM
Hi guys! I've this problem with upgrade, I try to follow this http://tinyurl.com/bo9edox that is the same, but I can't do nothing.... any ideas?
Code: [Select]
[ sudo apt-get -f install                                             ] 7:10
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  linux-image-3.2.0-39-generic linux-backports-modules-cw-3.4-3.2.0-36-generic
  linux-backports-modules-cw-3.4-3.2.0-39-generic
Usare "apt-get autoremove" per rimuoverli.
I seguenti pacchetti saranno inoltre installati:
  backbox-menu
I seguenti pacchetti NUOVI saranno installati:
  backbox-menu
0 aggiornati, 1 installati, 0 da rimuovere e 7 non aggiornati.
7 non completamente installati o rimossi.
È necessario scaricare 0 B/141 kB di archivi.
Dopo quest'operazione, verranno occupati 377 kB di spazio su disco.
Continuare [S/n]?
(Lettura del database... 244900 file e directory attualmente installati.)
Estrazione di backbox-menu (da .../backbox-menu_3.05_all.deb)...
dpkg: errore nell'elaborare /var/cache/apt/archives/backbox-menu_3.05_all.deb (--unpack):
 tentata sovrascrittura di "/usr/share/applications/backbox-ettercap.desktop" presente anche nel pacchetto ettercap-graphical 1:0.7.6-1backbox3
dpkg-deb: errore: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta)
Elaborazione dei trigger per desktop-file-utils...
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/backbox-menu_3.05_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
~ [ sudo apt-get purge ettercap-common ettercap-graphical               ] 7:17
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
 backbox-desktop : Dipende: backbox-menu ma non sta per essere installato
                   Dipende: ettercap-graphical ma non sta per essere installato
                   Raccomanda: blueman ma non sta per essere installato
                   Raccomanda: libreoffice-draw ma non sta per essere installato
                   Raccomanda: linux-headers-generic ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).
~ [ sudo apt-get -f install                                             ] 7:17
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
Correzione delle dipendenze... Fatto
I seguenti pacchetti sono stati installati automaticamente e non sono più richiesti:
  linux-image-3.2.0-39-generic linux-backports-modules-cw-3.4-3.2.0-36-generic
  linux-backports-modules-cw-3.4-3.2.0-39-generic
Usare "apt-get autoremove" per rimuoverli.
I seguenti pacchetti saranno inoltre installati:
  backbox-menu
I seguenti pacchetti NUOVI saranno installati:
  backbox-menu
0 aggiornati, 1 installati, 0 da rimuovere e 7 non aggiornati.
7 non completamente installati o rimossi.
È necessario scaricare 0 B/141 kB di archivi.
Dopo quest'operazione, verranno occupati 377 kB di spazio su disco.
Continuare [S/n]?
(Lettura del database... 244900 file e directory attualmente installati.)
Estrazione di backbox-menu (da .../backbox-menu_3.05_all.deb)...
dpkg: errore nell'elaborare /var/cache/apt/archives/backbox-menu_3.05_all.deb (--unpack):
 tentata sovrascrittura di "/usr/share/applications/backbox-ettercap.desktop" presente anche nel pacchetto ettercap-graphical 1:0.7.6-1backbox3
dpkg-deb: errore: il sottoprocesso paste è stato terminato dal segnale (Pipe interrotta)
Elaborazione dei trigger per desktop-file-utils...
Si sono verificati degli errori nell'elaborazione:
 /var/cache/apt/archives/backbox-menu_3.05_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
~ [ sudo apt-get purge ettercap-common ettercap-graphical               ] 7:18
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
 backbox-desktop : Dipende: backbox-menu ma non sta per essere installato
                   Dipende: ettercap-graphical ma non sta per essere installato
                   Raccomanda: blueman ma non sta per essere installato
                   Raccomanda: libreoffice-draw ma non sta per essere installato
                   Raccomanda: linux-headers-generic ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).
~ [ sudo apt-get remove ettercap-common                                 ] 7:18
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
 backbox-desktop : Dipende: backbox-menu ma non sta per essere installato
                   Raccomanda: blueman ma non sta per essere installato
                   Raccomanda: libreoffice-draw ma non sta per essere installato
                   Raccomanda: linux-headers-generic ma non sta per essere installato
 ettercap-graphical : Dipende: ettercap-common (= 1:0.7.6-1backbox3) ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).
~ [ sudo apt-get remove ettercap-graphical                              ] 7:18
Lettura elenco dei pacchetti... Fatto
Generazione albero delle dipendenze      
Lettura informazioni sullo stato... Fatto
È utile eseguire "apt-get -f install" per correggere questi problemi:
I seguenti pacchetti hanno dipendenze non soddisfatte:
 backbox-desktop : Dipende: backbox-menu ma non sta per essere installato
                   Dipende: ettercap-graphical ma non sta per essere installato
                   Raccomanda: blueman ma non sta per essere installato
                   Raccomanda: libreoffice-draw ma non sta per essere installato
                   Raccomanda: linux-headers-generic ma non sta per essere installato
E: Dipendenze non soddisfatte. Provare "apt-get -f install" senza pacchetti (o specificare una soluzione).
« Last Edit: May 06, 2013, 01:07:57 PM by raffaele »

una voce libera è sempre liberatrice
under_r00t


weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #1 on: May 04, 2013, 07:01:32 PM
ok, I've solved disabling repo on /etc/apt/sourced.list.d/backbox-three.list
update
upgrade
then renabled the repo, and made update and upgrade....

una voce libera è sempre liberatrice
under_r00t


souhail

  • Newbie
  • *
  • Posts: 3
    • View Profile
Reply #2 on: May 05, 2013, 10:51:16 AM
Ihave the same probléme

How can i renabled the repo ???

Nothing is impossible because the whole word impossible says I-M-POSSIBLE :D


weVeg

  • Hero Member
  • *****
  • Posts: 737
    • View Profile
Reply #3 on: May 05, 2013, 04:03:24 PM
Code: [Select]
sudo nano /etc/apt/sources.list.d/backbox-three-precise.list comment repo then, update & upgrade
after upgrade, get rid of comment and update & upgrade again!

una voce libera è sempre liberatrice
under_r00t


Max4me

  • Newbie
  • *
  • Posts: 11
    • View Profile
Reply #4 on: May 05, 2013, 06:26:05 PM
Hi guys, same problem here.
Solved by: sudo apt-get -f autoremove, I guess.
From my .bash_history
Code: [Select]
sudo apt-get check
sudo apt-get dist-upgrade
sudo apt-get -f install
sudo apt-get autoremove
sudo apt-get -f install
sudo apt-get -f autoremove
sudo apt-get update
sudo apt-get dist-upgrade
sudo apt-get -f dist-upgrade
sudo apt-get -f install
exit