Pages: [1]   Go Down
Print
Author Topic: Laptop shutting down because of overheating and something with AbiWord  (Read 10225 times)
LutherWest
Newbie
*
Posts: 7


View Profile
« on: March 30, 2013, 09:05:18 PM »

Hello everyone,

Sometimes I block my laptop's fan unintentionally and when the laptop overheats, Backbox just shuts down and turns off the computer, it's running alongside Windows 7 but Windows 7 just hibernates, so my work doesn't go unlike what happens with Backbox. Can anyone please tell me how I can set Backbox to hibernate in the case of overheating rather than shutting down?

One other thing, sometimes I need to read documents online and in most cases it's in the .docx format. But, when I press the download link in Firefox, there's those 2 options, Save file and Open with. I want to know how I can "Open with" the document with AbiWord because the only choice I have is Archive Manager.

Any help with both issues will be appreciated. Smiley
Logged
b4d_bl0ck
Global Moderator
Sr. Member
*****
Posts: 273



View Profile
« Reply #1 on: March 30, 2013, 11:13:17 PM »

Hi LutherWest ,
Windows 7 doesn't matter, the point is how the Operating System manages overheating... Anyway i'm sorry, i don't know how to configure it to hibernate when overheating instead of shutting down, also some googling didn't show me interesting infos. Maybe wait if someone more experienced could help you...
meanwhile just don't obstruct your fan  Tongue (how the hell can you actually block your fans???)

About Firefox and AbiWord, i think you can change that behaviour going to Preferences -> Applications, and there you can modify the default action for each filetype.

Enjoy BackBox!
Bye
Logged

bool secure = check_paranoia() ? true : false;
ZEROF
Global Moderator
Hero Member
*****
Posts: 678


View Profile WWW
« Reply #2 on: March 30, 2013, 11:32:02 PM »

Hi,

When you say "running alongside Windows 7", you think double boot or vmware ? If this going with vmware, that is because you don't have RAM for both systems.
Logged

Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*
LutherWest
Newbie
*
Posts: 7


View Profile
« Reply #3 on: March 31, 2013, 12:33:00 AM »

Hi,

When you say "running alongside Windows 7", you think double boot or vmware ? If this going with vmware, that is because you don't have RAM for both systems.

Double boot.
Logged
LutherWest
Newbie
*
Posts: 7


View Profile
« Reply #4 on: March 31, 2013, 12:35:49 AM »

Hi LutherWest ,
Windows 7 doesn't matter, the point is how the Operating System manages overheating... Anyway i'm sorry, i don't know how to configure it to hibernate when overheating instead of shutting down, also some googling didn't show me interesting infos. Maybe wait if someone more experienced could help you...
meanwhile just don't obstruct your fan  Tongue (how the hell can you actually block your fans???)

About Firefox and AbiWord, i think you can change that behaviour going to Preferences -> Applications, and there you can modify the default action for each filetype.

Enjoy BackBox!
Bye

I understand that Windows 7 doesn't matter I'm just trying to show that it's not something from the BIOS as much as I know it's more an OS thing.

I block my fans by putting the laptop on my lap and my lap blocks the fan. Smiley

I checked the preferences on Firefox and the System settings, I can't locate such a thing.
Logged
ZEROF
Global Moderator
Hero Member
*****
Posts: 678


View Profile WWW
« Reply #5 on: March 31, 2013, 01:51:01 AM »

If it does a clean shutdown, it is a temperature problem and if you check /var/log/syslog you can find information about. If it simply powers-off without a clean shutdown, this points to a hardware failure. Most people will disable acpi, and maybe this will help you too, but i don't say that this is best solution or solution, let's try.

To do that, we can play with kernel>grub settings, but today we have easy solution for that. We can use tool Boot repair to disable acpi. 1st you need add to repository and install this tool :

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update

Install :

sudo apt-get install -y boot-repair && (sudo boot-repair &)

Go to BBox menu>system>boot repair. Type your root password and wait few sec. Then click on "Advanced option", check on "Add a kernel option. Then check photo and make same settings, then click apply, reboot and see if now all goes well.



Good luck !

« Last Edit: March 31, 2013, 02:26:45 AM by ZEROF » Logged

Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*
LutherWest
Newbie
*
Posts: 7


View Profile
« Reply #6 on: March 31, 2013, 05:41:45 AM »

If it does a clean shutdown, it is a temperature problem and if you check /var/log/syslog you can find information about. If it simply powers-off without a clean shutdown, this points to a hardware failure. Most people will disable acpi, and maybe this will help you too, but i don't say that this is best solution or solution, let's try.

To do that, we can play with kernel>grub settings, but today we have easy solution for that. We can use tool Boot repair to disable acpi. 1st you need add to repository and install this tool :

sudo add-apt-repository ppa:yannubuntu/boot-repair && sudo apt-get update

Install :

sudo apt-get install -y boot-repair && (sudo boot-repair &)

Go to BBox menu>system>boot repair. Type your root password and wait few sec. Then click on "Advanced option", check on "Add a kernel option. Then check photo and make same settings, then click apply, reboot and see if now all goes well.



Good luck !



I know it turns off because of overheating since when I turn the machine back on it tells me in the BIOS that the system turned off because of overheating. But actually, Backbox does just powers off I dont see the usual black screen when the system overheats.
Logged
b4d_bl0ck
Global Moderator
Sr. Member
*****
Posts: 273



View Profile
« Reply #7 on: March 31, 2013, 07:35:16 PM »

Most people will disable acpi, and maybe this will help you too, but i don't say that this is best solution or solution, let's try.
Sure... what ZEROF is saying is right.
If you are going to try this, keep in mind that now on you won't get any warning message from your OS on overheating, nor any action will be executed to prevent system damages. So, system health will be up to you. If you have a prolonged usage of your pc without a fan running, your temps will increase and you can even burn some hardware components.
It's like you are deciding to turn the air-bag off in your car, for the reason you don't want to repair it each time you have a crash. It's its function, the reason it was invented for... So the solution is not to turn your air-bag off, but stay away from dangers and avoid crashing... in the same way, in your case the problem is not the ACPI system, but the obstruction of the fan. Think about it, or you will run your system without an "air-bag".

It's strange you can't find that options in firefox preferences... you should have a thing like this:


Bye.
« Last Edit: March 31, 2013, 09:09:30 PM by b4d_bl0ck » Logged

bool secure = check_paranoia() ? true : false;
LutherWest
Newbie
*
Posts: 7


View Profile
« Reply #8 on: April 01, 2013, 03:53:51 AM »

Most people will disable acpi, and maybe this will help you too, but i don't say that this is best solution or solution, let's try.
Sure... what ZEROF is saying is right.
If you are going to try this, keep in mind that now on you won't get any warning message from your OS on overheating, nor any action will be executed to prevent system damages. So, system health will be up to you. If you have a prolonged usage of your pc without a fan running, your temps will increase and you can even burn some hardware components.
It's like you are deciding to turn the air-bag off in your car, for the reason you don't want to repair it each time you have a crash. It's its function, the reason it was invented for... So the solution is not to turn your air-bag off, but stay away from dangers and avoid crashing... in the same way, in your case the problem is not the ACPI system, but the obstruction of the fan. Think about it, or you will run your system without an "air-bag".

It's strange you can't find that options in firefox preferences... you should have a thing like this:


Bye.

Oh, I definitely can't disable that. I only don't pay attention to the fan when I'm doing something that needs me to focus such as programming or coding. Is there a way to set that ACPI system to hibernate instead of just power off? That would be much better, my work isn't going to disappear.

For the Firefox, I actually found what you were talking about and found the doc file thing but, I can't set it to open with AbiWord. I tried searching for it, nothing comes up. I wrote locate AbiWord in the terminal also nothing comes up. If you or anyone else knows how to find it that would be pretty helpful. Smiley

Thanks.
Logged
ZEROF
Global Moderator
Hero Member
*****
Posts: 678


View Profile WWW
« Reply #9 on: April 02, 2013, 02:42:28 PM »

Hi LutherWest,

Try to disable acpi, like that you will know if you have some hardware issue, then check your pc configuration and search google to see what part of your hardware make pain in the ... Smiley with Linux, after that you can update drivers for that part of hardware (if you can find patched or new version) and run acpi again.

Have a nice day.
Logged

Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*
rose23
Guest
« Reply #10 on: July 11, 2013, 06:47:45 AM »

The overheating issue of laptop can be solved with following procedure. Start with dust out the Unit, remove the old Thermal Grease and  apply new Thermal Grease. It is also better to replace the Unit.
Logged
Pages: [1]   Go Up
Print
Jump to: