Pages: [1]   Go Down
Print
Author Topic: Amilo 7640 wireless non riconosciuto [SOLVED]  (Read 5361 times)
acme
Newbie
*
Posts: 7



View Profile WWW
« on: June 26, 2013, 12:57:26 AM »

Salve,

Possiedo un Amilo 7640 che monta una scheda wireless ISL3886 di conseguenza il driver è p54pci, ma nonostante abbia installato i compact wireless di backbox, il mio hardware non viene riconosciuto.

Possibili soluzioni?

L'hardware è perfettamente funzionante perché prima di backbox usavo kali linux è funzionava, anche nella partizione windows funziona.

Grazie...

English translate with google:

Hello,

I have a Amilo 7640 which features a wireless card ISL3886 a result the driver is p54pci, but despite having installed the compact wireless backbox, my hardware is not recognized.

Possible Solutions?

The hardware is fully functional because before I used kali backbox linux is working, even in your windows partition works.

Thank you ...
« Last Edit: June 28, 2013, 04:40:21 PM by acme » Logged
ZEROF
Global Moderator
Hero Member
*****
Posts: 694


View Profile WWW
« Reply #1 on: June 26, 2013, 03:49:34 AM »

Hi, try next :

sudo modprobe p54pci
sudo depmod -a
sudo update-initramfs -u
sudo reboot

If you don't have internet after reboot try :

nano /etc/modules

Add in the end:

p54pci

Save file (ctrl-x, Y, Enter).

Reboot your pc ! If no luck you have 2 more solution. Remove compact drivers, try then. Or remove compact drivers and upgrade kernel up to version 3.9. But what you need to know, don't install something that your system don't need, even if you do that in the end remove all and come back for help, don't try to resolve if you don't know what you are doing.
« Last Edit: June 26, 2013, 03:55:10 AM by ZEROF » Logged

Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*
acme
Newbie
*
Posts: 7



View Profile WWW
« Reply #2 on: June 26, 2013, 07:18:00 PM »

The proposed solutions have not worked. Now I try to reinstall the compact wireless. Then let you know
Logged
ZEROF
Global Moderator
Hero Member
*****
Posts: 694


View Profile WWW
« Reply #3 on: June 26, 2013, 08:28:56 PM »

Check this liens too:


http://wiki.debian.org/prism54
http://wireless.kernel.org/en/users/Drivers/p54

Wink
Logged

Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*
acme
Newbie
*
Posts: 7



View Profile WWW
« Reply #4 on: June 26, 2013, 09:17:18 PM »

Thank you for your help Zerof. I did so I installed linux-firmware-nonfree and wireless is gone, then I reinstalled compat-wireless, but I do not have packet injection
Logged
ZEROF
Global Moderator
Hero Member
*****
Posts: 694


View Profile WWW
« Reply #5 on: June 26, 2013, 11:11:48 PM »

From : http://www.aircrack-ng.org/doku.php?id=p54

We can see that you need to patch your compact drivers and reload them. If you have installed compact drivers go to (you need mac80211 patch):

cd /usr/src

Then download patch and install :

sudo apt-get install patch
sudo wget http://patches.aircrack-ng.org/mac80211.compat08082009.wl_frag+ack_v1.patch
sudo wget http://patches.aircrack-ng.org/channel-negative-one-maxim.patch
sudo patch -p1 < mac80211.compat08082009.wl_frag+ack_v1.patch
sudo patch -p1 < channel-negative-one-maxim.patch
« Last Edit: June 26, 2013, 11:13:42 PM by ZEROF » Logged

Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*
acme
Newbie
*
Posts: 7



View Profile WWW
« Reply #6 on: June 27, 2013, 07:10:36 PM »

Thank you for your help Zerof I finally resolved.
Let me explain how I did it:
Code:
1) sudo apt-get install linux-firmware-nonfree
2) sudo apt-get purge linux-backports-modules-cw-*
3) reboot
4) sudo apt-get install linux-backports-modules-cw-3.8-precise-generic
4) sudo modprobe p54pci
at the next
P.S: how do I put solved
Logged
b4d_bl0ck
Global Moderator
Sr. Member
*****
Posts: 278



View Profile
« Reply #7 on: June 28, 2013, 09:04:47 AM »

Hey acme,
we are happy you solved the issue and now you can start having fun with BBox.
Thanks for having summarized the procedure Wink
And really thanks to ZEROF Cheesy

You can edit thread title in the first post, adding the tag [SOLVED] in front or in the end.

Ciao, buon divertimento! Grin
Logged

bool secure = check_paranoia() ? true : false;
ZEROF
Global Moderator
Hero Member
*****
Posts: 694


View Profile WWW
« Reply #8 on: June 28, 2013, 04:29:21 PM »

Hi man,

Welcome to Linux world Smiley. Have a good learning and like i said you, if we do "step by step" resolving we can fix almost all issue.

Have fun.
Logged

Don't ask, read : http://wiki.backbox.org
or just run sudo rm -rf /*
Pages: [1]   Go Up
Print
Jump to: